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Overview
The IBM Softcopy Reader is made up of two programs, Book Reader and Shelf Organizer.

Book Reader

Book Reader allows you to open softcopy books created with one of the IBM BookManager
Build programs. You can:
•
View and navigate through the softcopy books and PDFs online
•
Do searches within the book
•
Create notes
•
Copy text
•
Print text selections, a section, or the entire book
Following is an example of the Book Reader screen.

Shelf Organizer

Shelf Organizer allows you to specify the locations (paths) of all of the books, PDFs, shelves and
shelf indexes you want to use. You can specify the paths of the books, PDFs, shelves and shelf
indexes on:
•
Internal hard drives (C:, D:, E:, etc.)
•
CD-ROM drives on your workstation or on a network
•
External hard drives on a network
•
Other storage devices that can be attached to your system
With the Shelf organizer, you can manage your softcopy libraries in the following ways:
•
Specify the location (paths) of all books, PDFs and shelves located on your
workstation, on a network, or an external storage device
•
Organize your shelves by name, date, or title
•
Organize your books and PDFs by name, date, title, or document number
•
Create your own shelves
•
List shelves
•
Delete shelves
•
Import books into a shelf
•
Search bookshelves or selected books
•
Search an indexed bookshelf or bookshelves (quick search)
•
Move books between bookshelves, and PDFs between extended shelves
Following is an example of the Bookshelf Organizer screen.

When to Use Each Program
Functions
Open a shelf
Open a book
Open a PDF file
Create a new shelf
Search a book
Search a PDF file
Search a shelf (of books)
Search an extended shelf (of
PDFs)
Search an indexed shelf (of
books)

Book Reader
Yes
No
Yes (single book)
No
No

Shelf Organizer
Yes
Yes
Yes
Yes
Yes (multiple books)
No
Yes
No
Yes

Create a note in a book
Use a bookmark
Print a topic
Copy a topic to clipboard
Save a topic as HTML

Yes
Yes
Yes
Yes
Yes

Prerequisites
Software and Hardware Requirements
Required Software

Operating systems - one of the following:

•
Microsoft Windows 2000 or XP
Note: Starting with the March 2003 IBM Online Library Collection Kits, the Book Reader and
Bookshelf Organizer programs are now executable in the native Windows environment. You no
longer need to have the Java Runtime environment on your machine.

Required Hardware
•
•
•
•
•
•

Any personal computer capable of running Windows 2000 or XP with an Intel®
PentiumII® (or higher), or compatible processor
Display device supported by Windows 2000 or XP (VGA or better resolution)
Any pointing device supported by Windows 2000 or XP
256MB of RAM is recommended
Hard-disk drive storage in addition to the storage required by Windows 2000 or
XP:
•
IBM Softcopy Reader - 61MB (Note: A total of 100MB of free space is
required to run the install pogram.)
One or more Windows-supported CD-ROM drives and the equipment needed to
attach them to your workstation

Optional Hardware
•

A Windows-supported printer

Directory Names of Your Books, PDFs, Shelves and Shelf Indexes
During installation, you will be asked to specify the locations (path names) for books, PDFs,
shelves and shelf indexes on your system. You can specify books, PDFs, shelves and shelf indexes
on:
•
The hard drive(s) on your system (C:,D:,E:, etc.)
•
CD-ROM drive(s) on your system
•
External hard drives or CD-ROM drives that you are connected to via a network

(you may have multiple CD-ROM drives you want to access)
•
Other storage devices that can be attached to your system
During installation, you will also be asked to specify the drive letter of your primary CD-ROM
drive. The Shelf Organizer can do an auto refresh when the CD is removed and replaced with
another. For more information, see “Auto Refresh” on page 40.
Please have this information available when you start the installation.

Installing IBM Softcopy Reader
The IBM Softcopy Reader can be installed on a personal computer with Windows 2000 or XP.
When you install Softcopy Reader, four items will be installed on your workstation.
•
Readme file - contains the latest information on the product and installation
instructions
•
User’s Guide - explains how to use the Softcopy Reader
•
Book Reader program - allows you to view and search online books and PDFs
•
Shelf Organizer program - allows you to view and manage online shelves, and
view or search the online books or PDFs they contain.
Once installed, you can select these through Windows Start > Programs > IBM Softcopy Reader
Installation Steps

This is the recommended sequence for installing IBM Softcopy Reader:
1.
Remove any previous versions of IBM Softcopy Reader, and beta versions of
Softcopy Reader for Java. See “Removing IBM Softcopy Reader from Your
System” on page 81.
2.
Install IBM Softcopy Reader - this program can be downloaded from IBM
Softcopy Collection Kits, and from the IBM BookManager pages on the IBM Web
site (the latest level will be on the IBM Web site).
3.
Start and run Book Reader or Shelf Organizer.
Installing IBM Softcopy Reader

These procedures allow you to install the IBM Softcopy Reader, which consists of the Book
Reader and Shelf Organizer, on your system. The install program can be downloaded for free
from:
•
An IBM Online Library Collection Kit CD-ROM
•
The IBM BookManager pages on the IBM Web site
http://www.ibm.com/software/applications/office/bkmgr/softcopyread.html

Specifying Paths to Books, PDFs, Shelves and Shelf Indexes

You can specify the locations (path names) for books, PDFs, shelves and shelf indexes on your
system, that reside on:
•
The hard drive(s) of your system (C:,D:,E:, etc.)
•
CD-ROM drive(s) on your system

•
•

External hard drives or CD-ROM drives that you are connected to via a network
(you may have multiple CD-ROM drives you want to access)
Other storage devices that can be attached to your system

Installing From an IBM Online Library Collection Kit CD-ROM

IBM Online Library Collection Kit CD-ROMs contain a copy of the IBM Softcopy Reader
installation program. If the collection kit is made up of several CDs, refer to the documentation
that came with it to see which CD-ROM contains the installation program. On most collections it
will be on the first CD-ROM of the set.
These instructions assume your hard disk is C and your CD-ROM drive is D. If they are not,
substitute the drive letters you are using for the letters shown in the examples.
1
Start the Windows Program
2.
From the IBM Online Library collection, insert the CD-ROM containing the
Softcopy Reader installation program, into the CD-ROM drive on your PC.
3.
Click on the Start button.
The Start menu appears.
4.
Select the Run option.
The Run window appears.
5.
In the Run window, if the following path does not appear:
d:\ilrjava\ilrjava.exe
Then type this path: d:\ilrjava\ilrjava.exe
6.
Click on OK.
A window will open with the following message: The InstallShield(R) Wizard will
install the IBM Softcopy Reader on your computer.
7.
Click Next and follow the instructions on the Installation window.
8.
During installation, you will be asked to:
•
Specify the location (paths) to books, PDFs, shelves and shelf indexes.
For example: D:\BOOKS;D:\PDF;D:\SHELVES
Note: These must be valid paths; that is, the directories must already exist
in the drives specified.
Multiple CD-ROM drives - if you have more than one CD-ROM drive,
you can add the paths to them.
Hard disk - If you plan to copy files to your hard disk, you can add hard
drive paths as well, after defining the directories on your hard drive. For
example, if your hard disc is C and a second CD-ROM drive is E, the
preceding example would now be:
D:\BOOKS;D:\PDF;D:\SHELVES;C:\BOOKS;C:\PDF;C:\SHELVES;E:\
BOOKS;E:\PDF;E:\SHELVES
•
Specify the drive letter of your primary CD-ROM drive.
•
Select the default directory shown in the window to save any notes you
create in the books, or specify your own directory.
Make sure the path for the notes directory is the same as the directory in
which the program files were installed. The default is C:\Program
Files\IBM\Scr.
•
You have the option to specify the drive letter(s) for your CD-ROM

drive(s). While optional, specifying the drive letter is recommended,
particularly when using the IBM Online Library Collection CD-ROMs, so
that the Bookshelf Organizer knows to refresh its list of Bookshelves when
the CD in the CD-ROM drive is changed.
•
If you already have the IBM Library Reader installed on your system,
specify if you would like to make the IBM Softcopy Reader the default
reader.
9.
When the installation is complete, you can start using Book Reader and Shelf
Organizer. You do not have to reboot your system.
Icons for the Book Reader and Shelf Organizer will be placed on your desktop during installation.

Installing From the IBM BookManager pages of the IBM Web Site

You can download the latest level of the IBM Softcopy Reader from the IBM BookManager
pages on the IBM Web site as follows:
1
Start the Windows program.
2.
Open your Web browser and go to the IBM BookManager Web site:
http://www.ibm.com/software/applications/office/bkmgr/softcopyread.html
3.
Click on Download Softcopy Reader self-extracting file.
The Save As… window will open.
4.
Select a drive and folder on your system to download the executable Softcopy
Reader installation file (ilrjava.exe), then click Save.
The Softcopy Reader file will be downloaded to this drive and folder on your
system.
5.
Click on the Windows Start button.
The “Start” menu should appear.
6.
Select the Run option.
The Run window should appear.
7.
In the Run window, click on Browse. When the Browse window opens, select the
drive and folder you specified in Step 4 to save the file, then highlight the
ilrjava.exe file and click on Open.
The correct path to the ilrjava.exe file should be displayed in the Run window.
8.
Click on OK.
A window will open with the following message:
9.
The InstallShield(R) Wizard will install the IBM Softcopy Reader on your
computer.
10. Click Next and follow the instructions on the Installation window.
11. During installation, you will be asked to:
•
Specify the location (paths) to books, PDFs, shelves and shelf indexes.
For example: D:\BOOKS;D:\PDF;D:\SHELVES
Note: These must be valid paths; that is, the directories must already exist
in the drives specified.
Multiple CD-ROM drives - if you have more than one CD-ROM drive,
you can add the paths to them.
Hard disk - If you plan to copy files to your hard disk, you can add hard
drive paths as well, after defining the \books and \shelves directories on

your hard drive. For example, if your hard disc is C and a second CD-ROM
drive is E, the preceding example would now be:
D:\BOOKS;D:\PDF;D:\SHELVES;C:\BOOKS;C:\PDF;C:\SHELVES;E:\
BOOKS;E:\PDF;E:\SHELVES
•
Specify the drive letter of your primary CD-ROM drive.
•
Select the default directory shown in the window to save any notes you
create in the books, or specify your own directory.
Make sure the path for the notes directory is the same as the directory in
which the program files were installed. The default is C:\Program
Files\IBM\Scr.
•
You have the option to specify the drive letter(s) for your CD-ROM
drive(s). While optional, specifying the drive letter is recommended,
particularly when using the IBM Online Library Collection CD-ROMs, so
that the Bookshelf Organizer knows to refresh its list of Bookshelves when
the CD in the CD-ROM drive is changed.
•
If you already have the IBM Library Reader installed on your system,
specify if you would like to make the IBM Softcopy Reader the default
reader.
12. When the installation is complete, you can start using Book Reader and Shelf
Organizer. You do not have to reboot your system.
Icons for the Book Reader and Shelf Organizer will be placed on your desktop during
installation.
The installation program also establishes the necessary file associations with appropriate content
type settings to ensure that Softcopy Reader is launched when Books or Shelves are selected from
the user’s desktop, or accessed from a browser.

Starting and Using Book Reader
This section shows:
•
How to start Book Reader and open an on-line book
•
The Book Reader window and its four sections
•
The Menu Bar and its functions
•
The Tool Bar and its functions
Starting Book Reader:

1.
2.

Insert the IBM Online Library CD-ROM into the CD-ROM drive.
Note: If you are using multiple CD-ROM drives, be sure you put all of the Online
Library CD-ROMs you plan to use in the drives before starting Book Reader or
Shelf Organizer to open the Online Library.
On the Windows Desktop, start the Book Reader either by double clicking the
Book Reader desktop icon, or by clicking on the Start button, and do the
following.
•
Select the Programs option
•
Select IBM Softcopy Reader
•
In the Softcopy Reader group, select the icon for Book Reader. The IBM

3.
4.
5.
6.

window should open.
From the Menu Bar click on File, then click on Open.
The Open Book window should open.
On the Open Book window, in the Look in window click on the down arrow
symbol. You should see a list of drives that are physically on or attached to your
system via a network.
Click on the drive letter (C:, D:, etc.), then click on the folder containing the book
you want to open. The books contained in the folder should be listed.
Highlight the book you want to open by clicking on it, then click on Open. The
book should open.
Softcopy Reader

Book Reader Window

There are five main sections on the Book Reader window.

Menu Bar

Lets you elect functions from drop down windows under each item.

Tool Bar

Lets you click on the picture button to do a specific function.

Table of Contents

Lets you see all of the chapters and topics within a chapter and jump directly to them.

Topics (pages) of the Book

Where the topics (or pages from the book) are displayed.

Font Size Selector

Lets you select a font size that is best for your viewing needs. On the right side of the Tool Bar,
next to “Font Size” you will see a box with a number in it and a down arrow. Click on the down
arrow to open a drop-down box with the numbers 1-6. Select the size font 1 (very small) to 6
(very large) that is best for you.

Menu Bar

You can navigate in the Book Reader program by clicking on the menu items on the Menu Bar. In
addition to the functions that appear on the toolbar, there are several additional features that are
available through the menus.

Following is a list of the Menu Bar items with the corresponding drop-down windows. There is a
description of each action item in the drop down window.

File

Opens a new book in the reader.
Book Description – Displays additional book information.
Open –

Save Topic as HTML - Allows you to save a topic as an HTML file.
Print – Opens a Print window allowing you to select the printing of the current or selected topics.
Close – Closes the Book Reader.

Edit

Copy – Copies text highlighted in the Book Reader window to the clipboard.
Place Bookmark - Places a bookmark on the current topic. The bookmarked topic will have an icon under its

heading. Using the Navigate » Go to Bookmark menu selection will bring the reader back to this topic from other
places in the book.
Remove Bookmark - Removes the previously placed bookmark.

Select All - Selects all topics in the Table of Contents.
Deselect All - Removes all selected topics in the Table of Contents.
User Defined Directories - Displays the User Defined Directories for Books, Bookshelves and Bookshelf Indexes
window to allow changes to the user defined Books, Bookshelf and Bookshelf Index paths.

View

Expand All - Expands all topics and sub topics to display the entire topic tree in the Table of Contents panel.
Collapse All - Collapses all topics and sub topics to display only the top-level topics in the Table of Contents panel.
Pictures

•
•

Navigate

Show Pictures in Text - This check box item determines whether pictures are

displayed inline with the text. If not selected, the pictures may be opened manually
by clicking on the picture labels. When opened manually, the pictures will be
displayed in a separate window.
Scale Images - This check box item determines whether inline pictures are to be
scaled down to a size that can be comfortably viewed within the text body frame.
When any of these pictures are opened in a separate window, the unscaled picture
is always rendered.
Note: The Scaled Images check box does not appear for books whose pictures are
stored internally in Web-ready format (such as gif and jpeg) since these pictures
should always fit within the text body frame. However, when any of these Webready pictures is opened in a separate window, its low resolution counterpart is
rendered instead.

By Topics - Opens the Table of Contents window. Double-click on a topic and it will be displayed in the Book Reader
window.

By Topics Seen - Opens the Topics Seen window. Double-click on a topic and it will be displayed in the Book Reader
window.

By Revisions - If a book contains revisions the By Revisions text bar will be active. Click on this bar and the Revi-

sions window will open with the list of revised topics. Double-click on a topic to open it in the Book Reader window.
By Figures - Opens the Figures window. Double-click on a figure in the list to display the topic in which it appears.
By Tables - Opens the Tables window. Double-click on a table in the list to display the topic in which it appears.
By Index - Opens the Index window and displays the book’s index. Click on the underlined topic numbers in the
Index to go to the appropriate topic.
Go To Topic ID - Opens the Go To Topic ID window. Enter the desired topic ID (e.g. “2.0” or “GLOSSARY”) in the
Enter a Topic ID panel. The selected topic (if the ID is valid) will be opened in the Book Reader window.
Go To Bookmark - Returns to the topic previously bookmarked during the current session.
Go To Previous Topic - Moves to the previous sequential topic in the book.
Go To Next Topic - Moves to the next sequential topic in the book.

Search

Search Book – Opens the Search Book window.
Display Search Results – Displays a list of search results from the last search performed. Double-click on a search
result to see the topic containing the result.
Go To Previous Topic Match – Moves to the topic for the previous sequential result from the last search.
Go to Next Topic Match – Moves to the topic for the next sequential result from the last search.

Notes

New – Displays the New Note input window that allows you to create a new note attached to the currently displayed
topic.
Display Notes List – Displays the Notes List window showing all notes in this book. Double-click on the notes in the
list to see the topic containing the note.

Help

Getting Started – Displays the help screen.
User’s Guide - Opens the IBM Softcopy Reader User's Guide
About Softcopy Reader – Opens the About Softcopy Reader window which describes the current version of the

reader.
Tool Bar

You can navigate in the Book Reader program by clicking on the icons on the Tool Bar.

Navigate by Table of Contents

Clicking on this icon expands the current topic (text and pictures) to the full size of the Book
Reader window. The Table of Contents will open in a smaller floating window that you can
position anywhere. Double-click on a topic to open it in the main window. Also available from the
menu: Navigate » By Table of Contents.
Navigate by Revisions

If a book contains revisions this icon will be active. Click on the icon and a window will open
with the list of revised topics. Double-click on a topic to open it in the main window. Also
available from the menu: Navigate » By Revisions.
Navigate by Topics Seen

Displays the history of topics visited. Double-click on a topic to open it in the main window.
Also available from the menu: Navigate » By Topics Seen.
Back

Moves to the previous topic visited.
Forward

Moves to the next topic visited (after using the Back button).
Go to Previous Topic

Moves to the previous sequential topic in the book.
Also available from the menu: Navigate » Go To Previous Topic.
Go to Next Topic

Moves to the next sequential topic in the book.
Also available from the menu: Navigate » Go To Next Topic.
Search

Opens the Search Book window.
Also available from the menu: Search » Search Book.
Display Search Results

Displays a list of search results from the last search performed. Double-click on a search result to
see the topic containing the result.
Also available from the menu: Search » Display Search Results.
Go To Previous Topic Match

Moves to the topic for the previous sequential result from the last search.

Also available from the menu:

.

Search » Go To Previous Topic Match

Go To Next Topic Match

Moves to the topic for the next sequential result from the last search.
Also available from the menu: Search » Go To Next Topic Match.
Create New Note

Displays the New Note input window that allows you to create a new note attached to the
currently displayed topic.
Also available from the menu: Notes » New.
Display Notes List

Displays the Notes List window showing all notes in this book. Double-click on the notes in the
list to see the topic containing the note.
Also available from the menu: Notes » Display Notes List.
Print

Opens a Print window allowing you to select the printing of the current or selected topics.
Also available from the menu: File » Print.
Help

Displays this help screen.
Also available from the menu:

.

Help » Getting Started

Starting Book Reader from a Command Line

To start Book Reader from the command line:
1. Open a Command Prompt and navigate to the directory where Book Reader is installed. (Generally C:\Program Files\IBM\SCR\sys)
2. At the command prompt, type: hlcb -d <sourcepath>
In the above example <sourcepath>= “C:\Program Files\IBM\SCR\sys”.

3. Advanced Book Reader features are also available from the command line according to the
following usage when typed at the command prompt:

Following are some examples of using advanced Book Reader features from the command line
when typed at a command prompt:
hlcb “c:\books\book.boo” -d “c:\Program Files\IBM\SCR\sys” -t “1.1”
hlcb “c:\books\book.boo” -d “c:\Program Files\IBM\SCR\sys” -s “001011000” “Table 13-1”

Starting and Using Shelf Organizer
This section shows:
•
How to start Shelf Organizer
•
The Shelf Organizer window
•
The Menu Bar and its functions
•
The Tool Bar and its functions
Starting Shelf Organizer

1.

Insert the IBM Online Library Collection CD-ROM into the CD-ROM drive.
Note: If you are using multiple CD-ROM drives, be sure you put all of the Online
Library Collection CD-ROMs you plan to use in the drives before starting Book
Reader or Shelf Organizer to open the Online Library.

2.

3.

On the Windows Desktop start the Shelf Organizer either by double clicking on the
Shelf Organizer desktop icon, or by clicking on the Start button and do the
following:
•
Select the Programs option.
•
Select IBM Softcopy Reader.
•
In the Softcopy Reader group, select the icon for Shelf Organizer.
The IBM Softcopy Reader List of Shelves window should open.
The List of Shelves sub-window shows a list of the shelves you can access.
This list of shelves is from all of the directory paths you specified when
installing IBM Softcopy Reader, and shelves you added to the User
Defined Directories for Books, PDFs, Shelves and Shelf Indexes since
installation.
From the List of Shelves sub-window, highlight the shelf that contains the book
you want to open by clicking on the shelf name.

Notes:
•

4.

The icon to the left of the Shelf Name you selected will change to show an
open shelf.
•
By clicking on the Name, Date, and Title tabs of the window, you can
change the order of how the bookshelves are listed:
•
Alphabetically – Name and Title tabs (ascending or descending)
•
Chronologically – Date tab (ascending or descending) Click once
for ascending and a second time for descending. The Shelf subwindow will display the name of the Shelf you selected and list all
of the books and PDFs on that shelf.
From the Shelf sub-window, double click on a book. This will open the Book
Reader window and display the book you selected.

Bookshelf Organizer Window

There are five main sections on the Shelf Organizer window.

Menu Bar

Lets you select functions from drop down windows under each item.
Tool Bar – List of Shelves
Lets you click on the picture button to do a specific function.

List of Shelves window

Shows a list of the bookshelves you can access.
Tool Bar – List of Books and PDFs
Lets you click on the picture button to do a specific function.

List of Publications window

Shows the list of the publications in the selected shelf. If the shelf has an associated search index
file, all books contained in the search index will have a book icon that has a sheet of paper behind
the book.

Menu Bar
Using the Menus

In addition to the functions that appear on the tool bar, there are several additional features that
are available through the menus. These are:

File

Create Shelf

- Opens the Create Shelf window where you can enter the name and title of the

new shelf, select books or PDFs, and create a shelf.
Shelf Description - Displays information about the selected shelf.
Delete Shelves - Deletes the selected shelves from the list. Books and PDFs belonging to the
shelves are not deleted – only the shelf files.
Open Publication - Allows you to open a publication -- book in Book Reader, or a PDF using a
PDF reader. You can select which book or PDF to open from the books, PDFs, shelves and shelf
indexes directories that were defined when Softcopy Reader was installed and any that were
added since installation.
Close - Closes the Shelf Organizer.

Edit

Import Publication - Allows you to import books or PDFs from any location and include them in the selected shelf.
This is regardless of whether the new location path exists in the user-defined configuration. Books can only be
imported into bookshelves, and PDFs can only be imported into extended shelves.
Cut Publications - Cuts the selected books or PDFs from the current shelf. These books or PDFs may be pasted into
other shelves. Books can only be cut from bookshelves, PDFs can only be cut from extended shelves.
Copy Publications - Copies the selected books or PDFs from the current shelf. These books or PDFs may be pasted
into other shelves. Books can only be copied from bookshelves, PDFs can only be copied from extended shelves.
Paste Publications - Pastes the last cut or copied books into the currently selected bookshelf.
User Defined Directories - Opens the
window. Books can only be imported into bookshelves, and PDFs can only be imported into extended shelves.
User Defined Directories for Books, P DFs, Shelves and Shelf Indexes

View

Sort Shelves - Sorts the list of shelves by the selected column. Name, Date, Title
Sort Publications - Sorts the list of books by the selected column. Name, Date, Title, Document No
Filter - Opens the filter windows for selecting and entering filter criteria for books, PDFs, or shelves. For more

information, see “Using Filters” on page 21.
Refresh - Allows you to swap CD-ROMs in a CD-ROM drive and refresh the directories, books, and bookshelves
displayed on the Bookshelf Organizer with those of the CD-ROM currently in the drive.

Search

Bookhelves – Opens the Books
Selected Books - Opens the

Active Directories

window to allow searching through all books on the bookshelf.
window to allow searching through all the books selected

earch Bookshelf

Search Bookshelf

The term Active Directories refers to active User Defined Directories and specifies a subset of the
User Defined Directories to use when building the List of Shelves.
Edit User Defined Directories - Opens a window to allow changes to the User Defined Directories for locating

Books, PDFs, Shelves, and Shelf Indices.
Change Active Directories - Opens a window to allow changes to the Active Directories. Only the directories
selected in the Active Directories Window will be used in building the List of Bookshelves.
Perform Auto Refresh - When selected, the Shelf Organizer performs an automatic refresh of the List of Shelves if
it detects a change. It will do a refresh if one of the directories used to build the List of Shelves points to a storage
device with removable media, such as a CD-ROM, and the device has been changed (for instance, a new CD has been
inserted).

Help

Getting Started - Displays this help screen.
User’s Guide - Opens the IBM Softcopy Reader User's Guide
About Bookshelf Organizer - Displays information about the Softcopy Reader.
Tool Bar – List of Bookshelves

You can navigate in the List of Bookshelves window by clicking on the icons in the Tool Bar.

Create Shelf

A dialog is opened asking if you want to create a bookshelf or extended shelf.
•
Create a bookshelf -- the Create Booksheld window opens where you can enter the name and title
of the new bookshelf, select books, and create a bookshelf.
•
Create an extended shelf -- the Create Extended Shelf window opens where you can enter the name,
title of the new extended shelf, select PDFs and create an extended shelf.
Also available from the menu:
.
F ile » Create Shelf

Shelf Description

Displays information about the selected shelf.
Also available from the menu:

F ile » Shelf Description

.

Search Bookshelf

Opens the
window to allow searching through all books on the selected bookshelf.
Also available from the menu:
.
Search Bookshelf

Search » Bookshelf

Search Indexed Bookshelf

Opens the Search Bookshelf window to allow searching through all books on the selected bookshelf using the
associated bookshelf index, if one exists.
Also available from the menu:
Search » Indexed Bookshelf.

Delete Shelves

Deletes the selected shelves from the list. Books, Shelf indexs or PDFs belonging to the bookshelves are not deleted –
only the bookshelf files.
Also available from the menu:
.
F ile » Delete Bookshelves

Filter Shelf List

Allows you to open and close the filter criteria field for filtering the list of shelves. Entering a filter criteria in these
fields will mask the shelves displayed in the list. Filtering criteria are discussed in the
section below.
Also available from the menu:
.
Using Filters

View » F ilter » Shelves

Using Filters

The shelf list or book list may be filtered by clicking on the [Filter Shelves] button which
opens the filter windows for selecting and entering filter criteria. Select the column to filter from
the drop-down list (Name, Date, Title or Document Number for books or PDFs) and enter a
regular expression in the adjacent field for masking the entries in the table, then press Enter.
Valid expression operators are:
*

Multiple-character Wildcard

Matches any number of any characters. Example: *book* matches books, notebook, etc.

? Single-character Wildcard

Matches any character in the specified location. Example: she?? Matches shelf, shell, sheep, etc.

!

NOT

Excludes entries matching the criteria. This operator may be placed only at the beginning of the regular
expression. Example: !*book* matches all except books, notebook, etc.

Tool Bar – List of Books or PDFs
You can navigate in the List of Books or PDFs window by clicking on the icons in the Tool Bar.

Open Publication

Opens the selected book in the
Also available from the menu:

.

Book Reader

F ile » Open Book

.

Publication Description

Displays additional information about the selected book or PDF.

Search Selected Books

Opens the
window to allow searching through the selected books on the bookshelf.
Also available from the menu:
.
Search Bookshelf

Search » Selected Books

Import Publication

Allows you to import books or PDFs from any location and include them in the selected bookshelf, or extended shelf
respectively. This is regardless of whether the new location path exists in the user-defined configuration
Also available from the menu: Edit » Import Publication.
.

Cut Selected Publications

Cuts the selected books from the current bookshelf. These books may be pasted into other bookshelves.
Also available from the menu: Edit » Cut Books.
Copy Selected Publications

Copies the selected books from the current bookshelf. These books may be pasted into other bookshelves.
Also available from the menu: Edit » Copy Books.
Paste Books

Pastes the last cut or copied books into the currently selected bookshelf.
Also available from the menu: Edit » Paste Books.
Filter Publication List

Allows you to open and close the filter criteria field for filtering the list of publications. Entering a filter criteria in
these fields will mask the books displayed in the list. Filtering criteria are discussed in the Using Filters section
below.
Also available from the menu: View » Filter » Publications.

Opening a Shelf
This section shows how to start Shelf Organizer, view the list of shelves on your system, and view
the books or PDFs within the shelf. If the bookshelf has an associated search index file, all books
contained in the search index will have a book icon that has a sheet of paper behind the book.

When the Shelf Organizer is started, the IBM Softcopy Reader List of Shelves window opens and
lists all of the shelves on your system that:
•
You specified during the IBM Softcopy Reader installation, or changed later
•
You added to the User Defined Directories for Books, PDFs, Shelves and Shelf
Indexes since installation
Note: You must have all CD-ROMs you plan to use, such as the IBM Online Library CD-ROMs,
in the CD-ROM drives before starting the Shelf Organizer.

Starting Shelf Organizer
1.
2.

Insert the IBM Online Library CD-ROM into the CD-ROM drive.
Note: If you are using multiple CD-ROM drives, be sure you put all of the Online
Library CD-ROMs you plan to use in the drives before starting Book Reader or
Shelf Organizer to open the Online Library.
On the Windows Desktop start the Shelf Organizer by double clicking the Shelf
Organizer desktop icon, or click on the Start button and do the following:

•
•
•

Select the Programs option.
Select IBM Softcopy Reader.
In the Softcopy Reader group, select the icon for Shelf Organizer.

The IBM Softcopy Reader List of Bookshelves window (below) will open.

The List of Shelves sub-window shows all of the shelves that you have access to on your system.
This list of shelves contains all those found on the directory paths configured into your userdefined directories.

Notes:

•
•

The icon to the left of the Name you selected will change to show an open shelf.
You can change the order of how the shelves are listed (alphabetically or
chronologically) by clicking on the Name, Date, and Title tabs of the window.

Selecting a Shelf and List the Books or PDFs

From the List of Shelves sub-window, highlight the shelf that contains the book or PDF you want
to open by clicking on the shelf name. The Shelf sub-window (below) will display the name of the
Shelf you selected and list all of the books. If the bookshelf has an associated search index file, all
books contained in the search index will have a book icon that has a sheet of paper behind the
book.

You can change the order of how the book are listed (alphabetically or chronologically) by
clicking on the Name, Date, Title, and Document tabs of the window.

Opening a Publication from the Shelf

From the Shelf sub-window, double-click on a book or PDF. For books, this will open the Book
Reader window and display the book you selected. For PDFs, this will launch the user-specified
PDF reader.

Getting a Description of a Shelf

You can see a description of the shelf by clicking on File, then on Shelf Description.

The Book Description window (below) will open.

Closing a Shelf and Shelf Organizer
Click on File, then Close.
This closes the shelf and Shelf Organizer.

Creating a Shelf
These are the steps involved in creating a new Bookshelf:
1. Determine the books you want to include in the new bookshelf. These books can be from:
•
One or more existing bookshelves on your system
•
New books that are not in any of your current bookshelves
Note: All of the books that are currently on your system (that are in user-defined directories
you specified during the IBM Softcopy Reader installation and in any new user-defined directories created since installation) can be listed in the Create Bookshelf window.
2. Determine a title or description for the new bookshelf - optional, but recommended
3. Determine a bookshelf name you want to assign to the new bookshelf - required
4. Determine if an index file has already been created for this bookshelf - optional
5. Determine where you want to store the new bookshelf. Once you create the new bookshelf it
must be saved to a drive with write access, such as the C-drive on your personal computer.
6. Start Shelf Organizer
7. Create the new bookshelf

Creating an Extended Shelf

These are the steps involved in creating a new Extended Shelf:
1. Determine the PDFs you want to include in the new shelf. These PDFs can be from:
•
One or more existing bookshelves on your system
•
New PDFs that are not in any of your current bookshelves
Note: All of the PDFs that are currently on your system (that are in user-defined directories
you specified during the IBM Softcopy Reader installation and in any new user-defined directories created since installation) can be listed in the Create Shelf window.
2. Determine a title (required) -- 1 to 255 characters with at least one non-whitespace character
3. Determine a shelf name you want to assign to the new shelf - required
4. Determine if an index file has already been created for this shelf - optional
5. Determine where you want to store the new shelf. Once you create the new shelf it must be
saved to a drive with write access, such as the C-drive on your personal computer.
6. Start Shelf Organizer
7. Create the new shelf

Start Shelf Organizer:

1.
2.
3.
4.

On the Windows Desktop, click on the Start button.
Select the Programs option.
Select IBM Softcopy Reader.
In the Softcopy Reader group, select the icon for Shelf Organizer.
The IBM Softcopy Reader List of Shelves window (below) will open.

Create a New Shelf

You can create two kinds of shelves:
1. Book shelf
2. Extended shelf
In the IBM Softcopy Reader List of Shelves toolbar, click on File, then select Create Shelf.
The Select the type of shelf to create: window will open.
In this procedure you will create a new bookshelf and store it on a directory that you specify. This
directory must have write permission.
1.

On the Toolbar, Click on

(Create Shelf).

The following Create Bookshelf window will open.

2.

Under Bookshelf Title [1], enter a description or title of your new bookshelf optional, but recommended.

3.

Under Bookshelf Name [2], enter a Bookshelf name (this is the name stored
internally in the Bookshelf)- a bookshelf name is required (limited to 8 characters)

4.

Under Index Name [3], enter the name of any pre-built bookshelf index that was
built for this bookshelf (e.g. if for a shelf called “mybooks” the index file name is
called mybooks.bki, the Index Name should be specified as “mybooks” - an Index
Name is optional (limited to 8 characters)

5.

From the Include Books From Locations window [4] you will see a list of user
specified paths and directories, and the number of books in each directory. Check
the boxes next to the path names on your system, or attached to your system via a
network, that include books you want to include in the bookshelf you are creating.
All of the books from the directories you selected will be listed in the Include
Selected Books window [5].

6.

From the Include Selected Books window, select the books you want to include in
your new bookshelf:

•
•
•
•

Single book - click on the book
Multiple books in various places - hold down the Ctrl key, then click on
each book wanted
Multiple books in sequence - hold down the Shift key, select the first book
in the list and last in the list
All books - press the Ctrl + A keys

7.

Click OK [6].
The Save Bookshelf window (below) will open.

8.

Verify the file name [7]

9.

If the directory in which you want to save the new bookshelf is listed, highlight the
directory name by clicking on it [8], then click on Save [9]. This directory must
have write permission.
If the directory you want is not listed, you must go to the correct drive on your
system and locate the directory - see next step.

10.

In the Look in: window, click on the down arrow [10] and select the drive [11]
which contains the directory where you want to store the new bookshelf.

11.

When you locate the proper directory, highlight it by clicking on it, then click
Save.

Import PDF Files Into a Shelf

This section shows you how to import PDF files into an Extended shelf.
In this procedure, you will see how to select PDF files from various locations (such as: internal
hard drives, external drives on a network, or other storage devices attached to your system) and
put them into an extended shelf.
1. Start the Shelf Organizer program.
2. From the List of Shelves, select a shelf in which you wish to import PDF files. You can also
create a new shelf in which to import the PDF files.
Select the shelf by clicking on it which will highlight it, as shown in the following example:

3. On the Shelf Toolbar (lower toolbar in the IBM Softcopy Reader List of Shelves window),
click on the Import Publication icon.
4. The Import Publications window will open.

5. Under Include PDF’s From Locations [1], select the location(s) from where you wish to
select PDF files.
6. Under Include Selected PDF’s [2], select the PDFs you wish to import. Select the PDFs by
clicking on them to highlight the one(s) you want. Hold down your [Ctrl] key to select multiple PDFs.

7. You must have a Title for each PDF you want to import. Under Title [3], enter a title for each
PDF, then press the [Enter] key. Other PDF file fields can be modified (customized), see
“Customizing the Document Properties of Your PDF Files” on page 33.
8. Click on OK. The PDF files will now be displayed in the extended shelf that you selected in
step 2, as shown in the following example.

PDF File Details - Viewing and Customizing

This section shows you (1) how to view the details of your PDF files, and (2) how to customize
the document properties of each PDF file.

Viewing the Details of a PDF File

1. In the Import Publications window, right click on the PDF file you wish to view details. A
Properties box will pop up.

2. Click on the Properties box. The following window will open with the details of the PDF file.

Customizing the Document Properties of Your PDF Files

You can create a detailed description of each of your PDF files. When you view the list of PDF
files in the Import Publications window or Document Properties window (see “Viewing the
Details of a PDF File” on page 33), you will see a number of columns which you can fill in with
information about the files. Following is a list of the information fields and the ones that you can
customize:
•
ID (required) - An identifier unique within the Extended Shelf which starts with a
letter or an underscore and contains one or more letters, numbers, periods or
dashes.
•
Type - PDF File (default)
•
Name (required) - Name within the shelf. Must be 1 to 8 characters starting with a
letter. The remaining characters can be either/or a combination of letters, numbers,
and dashes.
•
Title (required) - 1 - 255 characters
•
Update Timestamp - The time the publication was last updated following this
format: MM/dd/yy HH:mm:ss
•
Update Comment - Whatever information you want to put in this field
•
Subject - Whatever information you want to put in this field
•
Keywords - A list of author-provided, "Find Book" searchable keywords. Each
keyword should be separated by a blank space.
•
Author - Whatever information you want to put in this field
•
Expiration Timestamp - A date that you choose as an expiration date. This is not an
automated field and nothing will happen to the document on that date. The field
uses this format: MM/dd/yy HH:mm:ss
•
URI - Fully qualified location of publication. Usually takes form of file URL. Use
of this field is neither portable, nor encouraged. For MVS Datasets, use this
format: file:////’EOX.EN.BOOK.ONE.PDF’

Using the Active Directories, User Defined
Directories and Auto Refresh
This section Describes:
• How to add or remove items from the User Defined Directories which tell Softcopy Reader
where to look for Books, PDFs, Shelves, and Shelf Indices.
• How to use the Active Directories to control which Shelves are being displayed in the List of
Shelves.
• How Auto Refresh works and how to turn it on and off.

User Defined Directories

The “User Defined Directories” is a list of directories that Softcopy Reader uses to locate Books,
PDFs, Shelves and Shelf Indices on, or attached to, your PC workstation. The User Defined
Directories window can be accessed from two places.
• Edit Menu: Edit >> User Defined Directories
• Active Directories Menu: Active Directories >> Add/Remove

The User Defined Directories window allows you to add or remove directories. To add a
directory, in the right panel navigate to the directory you want to add, select the directory, then
click on Add. The directory name you added will be listed in the left panel. To remove a directory,
in the left panel, select the directory to be removed and click on Remove. To save any changes
click on Save, or click on Cancel to exit without saving changes. After clicking on Save, the
Bookshelf Organizer will refresh it's List of Bookshelves if necessary.

Active Directories

The Active Directories window lists all the User Defined Directories that the Shelf Organizer
uses to locate Books, PDFs, Shelves, and Shelf Indices on, or attached to, your PC. It also lists
any directories that may have been passed to the Shelf Organizer as parameters from a Command
Prompt. These directories are classified as “Other Directories.” By selecting or de-selecting
directories listed in the Active Directories window you can control which directories are used
when building the List of Shelves. The selected active directories pertain only to Shelves. The
Shelf Organizer will still use the complete list of directories when locating Books, PDFs, and
Shelf Indices.
The Active Directories window can be displayed by selecting Change Active Directories from
the Active Directories menu, as shown in the following example.

The Active Directories window, shown in the following example, allows you to select one or
more, or all, of the directories containing shelves on your system. You can use this window to

look at specific directories to see which shelves are located in the directory.

Other Directories will not be remembered between uses of the Shelf Organizer. To have the
Bookshelf Organizer remember one or more of these directories, select the Add to User Defined
Directories check box for each directory you wish to save, and click OK.
.

Open the Active Directories window again and you will see that the selected directories were
added to the User Defined Directories.

On startup, the default is to make all the directories active, therefore they will all be selected. If
you de-select all but C:\Shelves from the Active Directories window and click on OK, as shown.

The Shelf Organizer will show only Shelves for the "C:\Shelves" directory. See the following
example.

The advantages of using the Active Directories in coordination with Auto Refresh can be seen in
the next section “Auto Refresh.”

Auto Refresh

If Auto Refresh is turned on, the Shelf Organizer will automatically rebuild the List of
Bookshelves when removable media, such as a CD, is removed or inserted in a CD-ROM drive.
To ensure Auto Refresh works properly, be sure that:
• Perform Auto Refresh is selected in the Active Directories Menu.
• The User Defined Directories has a path that is on a storage device with removable media,
such as a CD-ROM drive, or such a path is passed to the Shelf Organizer as a Command Line
parameter. The CD should be one that has Books, PDFs, Shelves, or Shelf Indices.
• In the Active Directories Window, the directory on the storage device with the removable
media, such as a CD-ROM drive, is selected.
In this example, the CD-ROM drive is represented by “D:\”. The "D:\Shelves" and "D:\Books"
were added to the User Defined Directories as described in the section “User Defined
Directories.” These were then made the only active directories in the Active Directories window.
You can have other directories selected as well -- these Active Directories are limited to the CDROM drive to simplify the example.

Click on OK, and you will see the following window displayed.

In this example, the CD-ROM drive contains one of the OS\390 Collection Kit CDs. If you
remove the CD, the Shelf Organizer will refresh the List of Shelves. Since the only active
directories that are selected point to the CD-ROM, the list of shelves will be empty as seen in the
following example.

If you put in a different OS\390 Collection Kit CD, the Shelf Organizer again refreshes the List of
Shelves listing the shelves and books as shown in the following.

This can be very convenient when viewing Books on many different CD-ROMs or other storage
devices with removable media. To turn off Auto Refresh simply de-select it in the Active
Directories Menu, as shown in the following example.

Searching Multiple Books in a Single
Bookshelf (or Across Multiple Bookshelves)
This section describes how to:
•
Initiate a search for specific information (word or words) across all books in a
single bookshelf (or across multiple bookshelves at the same time)
•
Initiate an indexed search for specific information (word or words) across all
books in a single bookshelf (or across multiple bookshelves at the same time)
•
Initiate a search for specific information (word or words) across selected books in
a bookshelf
•
Customize the way books are searched and the results displayed:
•
Find an exact match (case sensitive)
•
Find an exact match (not case sensitive)
•
Fuzzy match
•
Use Boolean operators in the search
•
Specify what material in the book to search (titles, text, and indexed words)
•
List the results in order of importance (or in page sequence)
Note: Extended shelves cannot be searched.

What if search can not find a book or books

If the search cannot find a book or books in the bookshelf, you will get a message indicating the

book (books) listed in the message could not be found. This could be as a result of:
•
The path that you defined for the book (books) is not valid
•
A CD-ROM containing the books is not in inserted in the CD-ROM drive
•
A network connection, to books at a remote location, is broken
•
Missing books due to modifications to existing bookshelves or creating your own
custom bookshelves by adding and deleting books

Searching a Bookshelf (or multiple bookshelves) - All Books
Entering a New Search Word (words)

You can start the search process from either the Menu Bar or the Tool Bar:
1.
Select a bookshelf you want to search from the IBM Softcopy Reader List of
Bookshelves window.
Multiple bookshelves – You can select multiple bookshelves for the search. Hold
down the control [Ctrl] key, and select (Click on) all of the bookshelves you want
to search.
2.
Start the search process:
From the Menu Bar: Click the Search button, then click Bookshelf...

Or, from the Tool Bar: Click on

[Search]

The Search Bookshelf window (below) will open.

3.

Enter a search word (words) in the Search Request window. The example below
shows “workstation” as the search request. You can customize the search in
numerous ways - see Customizing the Search below.

Buttons on the Search Bookshelf window
•
Search – Start the search process.

•
4.

5.

Reset – Clears the Search Request window and returns the options to their

default state.
•
Close – Closes the search window
•
Help – Displays the help screen
Click Search to start the search.
The results of the search are displayed (below) in the lower two windows of the
Search Bookshelf window: In this example.
•
8 Books with Hits Found - this is the number of books in the bookshelf
(bookshelves) that contained the search word “workstation.” You can scroll
down this list to see the Name (file name) and Title of each book. You can
highlight any book in the list (click on it) and see which topics in the book
contain search results in the lower window.
•
6 Search Results for Book EPA3LM03 - this is the number of topics in
the book where the word “workstation” was found.

Double-click on any of the search results listed for the book, and:
•
The Book Reader program will open (see below)
•
The book with the search results will be displayed
•
A Search Book window will be open on the Book Reader window showing

•

all of the search results for that book
All words matching the search are highlighted in red.

Searching an Indexed Bookshelf (or Multiple Bookshelves)All Books
Entering a New Search Word (words)

An Indexed Bookshelf Search is a high speed search of a bookshelf using a specially created
index file. An Indexed Bookshelf Search is only performed if an index file is associated with the
Bookshelf and is located within one of the user-defined directories. In the List of Books for an
Indexed Bookshelf, all books that have been built into the Search Index are designated with a
special indexed book icon.
You can start the search process from either the Menu Bar or the Tool Bar:
1.
Select a bookshelf you want to search from the IBM Softcopy Reader List of
Bookshelves window.
Multiple bookshelves - You can select multiple bookshelves for the search. Hold
down the Control [Ctrl] key, and select (click on) all the bookshelves you want to
search. Not all Selected Bookshelves need to be indexed.

2.

Start the search process:
From the Menu Bar: Click the Search button, then click Indexed Bookshelf...

Or, from the Tool Bar: Click on

[Search]

The Search Indexed Bookshelf window (below) will open.

3.

Enter a search word (words) in the Search Request window. The example below
shows “workstation” as the search request. You can perform an indexed search
using boolean operators by selecting the Advanced Search button; however, unlike
regular (i.e., non indexed) Bookshelf searches, the default values of “Fuzzy
Search,” “List Results in order of Importance,” “Search Topic Titles,” “Search
Topic Text” and “Search Indexed Words” are not customizable when performing
an Indexed Bookshelf Search.

4.

Buttons on the Search Indexed Bookshelf window
•
Search – Start the search process.
•
Reset – Clears the Search Request window and returns the options to their
default state.
•
Close – Closes the search window
•
Help – Displays the help screen
Click Search to start the search.
The results of the search are displayed (below) in the lower two windows of the
Search Indexed Bookshelf window: In this example.
•
20 Books with Hits Found - this is the number of books in the bookshelf
(bookshelves) that contained the search word “workstation.” You can scroll
down this list to see the Name (file name) and Description of each book.
You can highlight any book in the list (click on it) and see which topics in
the book contain search results in the lower window.
•
4 Search Results for Book F1AF9001 - this is the number of topics in the
book where the word “workstation” was found.

.
5.

Double-click on any of the search results listed for the book, and:
•
The Book Reader program will open (see below)
•
The book with the search results will be displayed
•
A Search Book window will be open on the Book Reader window showing
all of the search results for that book
•
All words matching the search are highlighted in red.

Searching a Bookshelf - Selected Books

You can select multiple books in a bookshelf to search.
1.
From the List of Bookshelves, select a bookshelf to search. The books in the
selected bookshelf will be listed in the lower window.
2.
From the list of books, select the ones you want to search by highlighting (clicking
on) them. Use your keyboard keys to help select books - hold down the Shift key
to select a list of books or hold down the Ctrl key to select specific books.
The following example shows four books selected from bookshelf AB0RWT25. If
the bookshelf has an associated search index file, all books contained in the search
index will have a book icon that has a sheet of paper behind the book.

3.

From the Menu Bar, click Search, then click Selected Books...
You can also click on the search icon .

The Search Bookshelf window (below) will open with:
•
The number of books found with search matches
•
A list of the books containing matches (one book in the list will be
highlighted)
•
A list of the specific search results for the highlighted book

You can highlight any of the books in the list and see the search results.

4.

Double-click on any of the search results listed for the book, and:
•
The Book Reader program will open
•
The book with the search results will be displayed
•
A Search Book window will be open on the Book Reader window showing
all of the search results for that book
•
All words matching the search are highlighted in red.

Customizing the Search

Using the Tool Bar functions you can customize the way the books, bookshelves and bookshelf
indexes are searched and how the search results are listed. (Note: There are default settings if you
don’t select any of the customization functions.)

Using the Tool Bar Functions

Specify the method for searching
One of the following must be specified:

Exact Case-sensitive

Finds only words matching the search request exactly, including case.

Exact Non Case-sensitive

Finds words exactly matching the search request, but ignoring upper/lower case.
Fuzzy (Default).
Uses a morphological fuzzy search algorithm to identify appropriate matches.

Specify how you want the results listed

One of the following two options must be selected:

List Results in Sequence

When a search is performed, the search results are listed in the sequence as they appear in the
book.

List Results in Order of Importance (Default)

When a search is performed, the search results are listed in the order of importance (results by
relevance), with the most relevant topics listed first.

Specify Where to Search

Any combination (or all) of the following three options may be chosen to specify where to search:
Search in topic titles (Default)

.

Search in topic text (Default).
Search indexed words, i.e, entries in the Index topic (Default).

Using Boolean Operators
The Boolean operator buttons may be displayed or hidden with the following button:
Advanced search.
Click on the Advanced search button to bring up the row of Boolean operators (below) that you
can use in your search.

Following is a list of the Boolean operators and symbols that may be included in the search
criteria. You can enter them either directly from the keyboard, or insert them into your search by
clicking on the buttons (above).

&
|
!
‘‘

logical AND
logical OR
logical NOT

quoted phrase

Takes the character between the two single-quotes as a literal. Used only around
Boolean operators and symbols otherwise having meaning to a search request.

[ ] parenthesized expression

Controls the order of precedence of Boolean operations.

,

list separator

Word or phrase separator

= equal sign
? wildcard character
•
•

Single-character wildcard - Matches any character in the specified
position.
Multiple-character wildcard - Matches any number of any character.

Opening a Book in Book Reader
This section shows you how to:
•
Open a book in Book Reader
•
Get a description of the book
•
Close a book
For information on starting the Book Reader program, see Starting Book Reader.

Opening books contained on an IBM Online Library CD-ROM

If you plan to open a book contained on an IBM Online Library CD-ROM, be sure to insert the
IBM Online Library CD-ROM into the CD-ROM drive on your system. If you are using multiple
CD-ROM drives, be sure you put all of the Online Library CD-ROMs you plan to use in the
drives before starting Book Reader to open the Online Library.
Opening a Book

1.

From the Menu Bar click File, then Open

The Open Book window (below) will open.

2.

On the Open Book window in Look in: click on the “down arrow symbol”
A drop-down window will open listing all of the drives physically on or attached
to your system via a network.

3.

Click on the drive letter (C:, D:, etc.) of the drive where the book is stored, or the
drive letter of the CD-ROM drive containing the CD with the book.
The Open Book window (below) now lists all of the folders on the drive.

4.

Click on the folder containing the book you want to open.
The Open Book window (below) now lists all of the books contained in the
selected folder.

5.

Highlight the book you want by clicking on it, then click Open.
The book will open in the Softcopy Reader window with the Table of Contents on
the left and the book topics (pages) on the right.

Getting a Description of a Book

You can see a description of the book by clicking on File, then on Book Description.

The Book Description window (below) will open.

Closing a Book

There are two ways to close a book.
1.
Open another book. The book currently open will be closed and the new book will
be displayed in Softcopy Reader.
2.
Click on File, then Close.
This will close the book and Book Reader.

Navigating in a Book
This section shows how to navigate (move around a book and go to specific topics) within an online book in Book Reader.
The Book Reader Window

There are five main sections on the Book Reader window.

Menu Bar

Lets you select functions from drop down windows under each item.

Tool Bar

Lets you click on the picture icons to do a specific function.

Table of Contents

Lets you see all of the chapters and topics within a chapter and jump directly to them.

Topics (Pages) of the Book

This is where the topics (or pages from the book) are displayed.

Font Size Selector

Lets you select a font size that is best for your viewing needs. On the right side of the Tool Bar,
next to “Font Size” you will see a box with a number in it and a down arrow. Click on the down
arrow to open a drop-down box with the numbers 1-6. Select the size font 1 (very small) to 6
(very large) that is best for you.

Ways of Navigating in a book

The primary ways of navigating in a book include:
•
Selecting items from the Table of Contents
•
Using the navigation buttons on the Tool Bar
•
Using the Navigate drop-down window features on the Menu Bar
Using the Table of Contents

When you open a book, the Table of Contents will be displayed on the left side of the Softcopy
Reader window. You can go directly to any topic in the Table of Contents by double clicking on
the topic.

Expanding/collapsing the topics
Unexpanded topics will have a + (plus) icon next to them. Click on the + to expand or collapse the
topic. When you expand a topic, the - (minus) icon will appear. To expand or collapse “all” topics,
choose the View » Expand All or View » Collapse All from the Menu Bar.

Moving the Table of Contents to a floating window

You can close the Table of Contents window on the left side and open it as a floating window that
you can move around and position anywhere in the open topic. Doing this will expand the topic
currently displayed (text and pictures) to the full size of the Book Reader window. You can do this
from:
•
The Menu Bar - Click on: Navigate » Topics
•
The Tool Bar - Click on:

Closing or fully expanding the Table of Contents window

By clicking on the arrow keys on the bar to the right of the Table of Contents window, you can
close the Table of Contents window and expand the current topic (text and pictures) to the full size
of the Softcopy Reader window. You can also expand the Table of Contents to fill the entire
screen. You will not see any of the current topic window at this time.
Using the Tool Bar
Following are ways to navigate within a book by clicking on the buttons in the Tool Bar.

Go to Next Topic

Moves to the next sequential topic in the book.
Also available from the menu:

Navigate » Go To Next Topic

.

Go to Previous Topic

Moves to the previous sequential topic in the book.
Also available from the menu:

Navigate » Go To P revious Topic

Back

Moves to the previous topic visited.

.

Forward

Moves to the next topic visited (after using the

Back

button).

Navigate by Topics Seen

Displays the history of topics visited. Double-click on a topic to open it in the main window.
Also available from the menu:
.
Navigate » By Topics Seen

Navigate by Revisions

If a book contains revisions this icon will be active. Click on the icon and a window will open with the list of revised
topics. Double-click on a topic to open it in the main window.
Also available from the menu:
.
Navigate » By Revisions

Using Menu Bar Navigation features
Following are ways to navigate within a book by clicking on the functions listed in the drop-down
window of the Navigate button on the Menu Bar.

By Topics

By Topics Seen

Opens the
window.
Double-click on a topic and it will be displayed in the
Table of Contents

Book Reader

window.

Opens the Topics Seen window.
Double-click on a topic and it will be displayed in the Book Reader window.

By Revisions

If a book contains revisions the By Revisions text bar will be active.
Click on this bar and the Revisions window will open with the list of revised
topics.
Double-click on a topic to open it in the Book Reader window.

By Figures

Opens the
window.
Double-click on a figure in the list to display the topic in which it appears.

By Tables

Opens the
window.
Double-click on a table in the list to display the topic in which it appears.

Figures

Tables

Index window and displays the book’s index.
Click on the underlined topic numbers in the Index to go to the appropriate topic.

By Index

Opens the

Go To Topic ID

Opens the Go To Topic ID window.
Enter the desired topic ID (e.g. “2.0” or “GLOSSARY”) in the Enter a Topic
ID panel. The selected topic (if the ID is valid) will be opened in the
Softcopy Reader window.

Go To Bookmark

Returns to the topic previously book marked during the current session.

Go To Previous
Topic

Moves to the previous sequential topic in the book.

Go To Next Topic

Moves to the next sequential topic in the book.

Viewing Pictures in a Book
You can select if you want the pictures in the book to be automatically displayed in the text. From
the Book Reader Menu Bar, click on View, then Pictures.

You can specify how you want the pictures displayed by clicking the check boxes of:
•
Show Pictures in Text
This check box item determines whether pictures are displayed inline with the text.
If not selected, the pictures may be opened manually by clicking on the picture
labels. When opened manually, the pictures will be displayed in a separate window.
•
Scale Images
This check box item determines whether inline pictures are to be scaled down to a
size that can be comfortably viewed within the text body frame. When any of
these pictures are opened in a separate window, the unscaled picture is always
rendered.
Note: The Scaled Images check box does not appear for books whose pictures are
stored internally in Web-ready format (such as gif and jpeg) since these pictures
should always fit within the text body frame. However, when any of these Webready pictures is opened in a separate window, its low resolution counterpart is
rendered instead.

Searching for Information in a Book
This section describes how to:

1.
2.
3.

Initiate a search for specific information (word or words) in a book.
•
Entering a new search word (words)
•
Looking at previous search requests
Navigate between search results
Customize the way the book is searched and the results displayed:
•
Find an exact match (case sensitive)
•
Find an exact match (not case sensitive)
•
Fuzzy match
•
Use Boolean operators in the search
•
Specify what material in the book to search (titles, text, and indexed words)
•
List the results in order of importance (or in page sequence)

Starting the Search

You can search by entering a new word, or by looking at words previously searched.

Entering a New Search Word (words)

You can start the search process from either the Menu Bar or the Tool Bar
1.
Start the search process:
From the Menu Bar: Click the Search button, then click Search Book...

Or, from the Tool Bar: Click on

[Search]

The Search Book window (below) will open.

2.

Enter a search word (words) in the Search Request window. The example below
shows “OS/390” as the search request. You can customize the search in numerous
ways - see Customizing the Search below.

Buttons on the Search Book window
•
Search – Start the search process.
•
Reset – Clears the Search Request window and returns the options to their
default state.
•
Close – Closes the search window.
•
Help – Displays the help screen.

3.

Click Search to start the search. The Search Results window (below) lists all of the
search results found in the book, and the number of topics with matches found at
the bottom of the window.

4.

Double-click on any of the search results listed in the Search Results window and
the corresponding topic will be displayed in the Book Reader window, with all
words matching the search criteria highlighted in red.

Looking at Previous Search Requests from the

Search Book

Window

You can look at the search results of other words previously searched by clicking on the “down
arrow” just below the Search Request window, and click on Search. The Search Results panel
shows the topics that matched the search, including the number of search results found. Doubleclick on any of the search results and the corresponding topic will be displayed in the Book
Reader window with all words matching the search criteria highlighted in red.
Navigating Between Search Results

You can look at the results of the last search you made.
1.
From the Menu Bar, click on Search.
2.
Click Display Search Results

The Search Results window (below) will open listing the search results from your
last search.

3.

You can navigate (jump from one search result topic to another) in the following
ways:
•
By double clicking on specific item in the Search Results window. The
topic (page of the book) that corresponds to the search result you clicked
on will open in the Book Reader window.
•
By clicking on Go To Previous Topic Match and Go To Next Topic
Match in the drop-down window under Search. This opens up the
corresponding page in the Book Reader window.
•
By clicking on the Tool Bar icons [Previous] and [Next]

Customizing the Search

Using the Tool Bar functions you can customize the way the book is searched and how the search
results are listed. (Note: There are default settings if you don’t select any of the customization
functions.)

Using the Tool Bar Functions

Specify the method for searching
One of the following must be specified:

Exact Case-sensitive

Finds only words matching the search request exactly, including case.

Exact Non Case-sensitive

Finds words exactly matching the search request, but ignoring upper/lower case.

Fuzzy

(Default)

Uses a morphological fuzzy search algorithm to identify appropriate matches.

Specify how you want the results listed

One of the following two options must be selected:

List Results in Sequence

When a search is performed, the search results are listed in the sequence as they appear in the
book.

List Results in Order of Importance (Default)

When a search is performed, the search results are listed in the order of importance (results by
relevance), with the most relevant topics listed first.

Specify Where to Search

Any combination (or all) of the following three options may be chosen to specify where to search:
Search in topic titles (Default).
Search in topic text (Default).
Search indexed words, i.e., entries in the Index topic (Default)
Using Boolean Operators

The Boolean operator buttons may be displayed or hidden with the following button:

Advanced search.
Click on the Advanced search button to bring up the row of Boolean operators (below) that you
can use in your search.

Following is a list of the Boolean operators and symbols that may be included in the search
criteria. You can enter them either directly from the keyboard, or insert them into your search by
clicking on the buttons (above).

&
|
!
‘‘

logical AND
logical OR
logical NOT

[]

parenthesized expression

,

list separator

=
?

equal sign
wildcard character

quoted phrase

Takes the character between the two single-quotes as a literal. Used only
around Boolean operators and symbols otherwise having meaning to a search
request.
Controls the order of precedence of Boolean operations.
Word or phrase separator

² Single-character wildcard - Matches any character in the specified position.
² Multiple-character wildcard - Matches any number of any
character.

Creating and Viewing Notes in a Book
This section describes how:
•
Create a new note in a book
•
How to display the list of notes in a book, and view them
Creating a Note

You can create and view notes from either the Menu Bar or the Tool Bar.
1.
Open the new Notes window
From the Menu Bar: Click the Notes button, then click New

2.

Or, from the Tool Bar: Click on [New Note]
In the Notes window (below), you will see the “topic” you selected to put a note
under, and an open window where you can type your note. The example shows that
a note will be attached to the “Title Page” of the book.

3.

Click Save to save the note or Cancel to cancel the note – close the window and
exit the Note function.

Viewing Notes

1.

Open the Notes list window
From the Menu Bar: Click the Notes button, then click Display Notes List

2.

Or, from the Tool Bar: Click on [Notes List]
In the Notes window (below), you will see a list of the notes in the book.
The upper window lists all of the notes in the book. The topic ID and the first line
of each note appears in the list. Double-click on any of the notes to see the full text
for the note under Note Body in the lower window. The Book Reader will now be
positioned at the topic in which the note appears. The body of a note may be edited
in the Note Body window, but you must save the changes (to avoid losing them)
before another note is displayed.

Description of the Notes Window Tool Bar

Create New Note

Opens an input window to enter a new note on the currently displayed topic.

Delete Note

Deletes the currently-selected note.

Save Note

Saves any changes made to the currently displayed note.

Previous Note

Moves to the previous note in the list and displays the note text under the Note Body section.
The Book Reader will not be positioned to the note topic.

Next Note

Moves to the next note in the list and displays the note text under the Note Body section.
The Book Reader will not be positioned to the note topic.

Help

Displays this help screen.

Using a Bookmark in a Book
This section describes:
•
Placing the bookmark
•
Finding (going to) the book marked page

•

Removing the bookmark

Placing the Bookmark

You can place the bookmark on any topic (page) in a book. You can have only one bookmark in a
book. If you try to place a second bookmark, the first one will be removed.
1.
Select a topic (page in the book you want to bookmark
2.
Click on Edit, then Place Bookmark

The bookmark icon will be placed at the top of your selected topic (page). In the
example below, you can see the bookmark next to the chapter title.

Finding (Going To) the Bookmarked Page
You can go to a bookmarked page from other places in the book.
On the Menu Bar click Navigate, then click Go to Bookmark,

Removing the Bookmark

On the Menu Bar, click Edit, then click Remove Bookmark,

Printing
This section describes:
•
Printing the current topic
•
Printing selected topics

Printing the Current Topic

This allows you to print the topic currently displayed in the Book Reader window. Only the topic
currently displayed will be printed, even if you have other topics highlighted in the Table of
Contents.
1.
Start the print process:
You can start the print process from either the Menu Bar or the Tool Bar
From the Menu Bar: Click the File button, then click Print...

Or, from the Tool Bar: Click on

[Print]

The Print window (below) will open.

2.

Click Current
•
The topic currently displayed on your screen will be printed.
•
The Print window on your personal computer will open allowing you to
specify how and where you want to print the current topic.

Printing Selected Topics
1.
2.

Select the topics you want to print from the Table of Contents by highlighting
(clicking on) them. Use your keyboard keys to help select topics - hold down the
Shift key to select a list of topics or hold down the Ctrl key to select specific
topics.
Start the print process:
You can start the print process from either the Menu Bar or the Tool Bar
From the Menu Bar: Click the File button, then click Print...

Or, from the Tool Bar: Click on

[Print]

The Print window (below) will open.

3.

Click Selected
•
All of the topics you selected for printing will be displayed in the Book
Reader window. They will be in sequential order, from the lowest
numbered topic to the highest, regardless of how you selected them.
•
The Print window on your personal computer will open allowing you to
specify how and where you want to print the selected topics.

Printing a Range of Topics
1.
2.

Select the topics you want to print from the Table of Contents by highlighting
(clicking on) them. Use your keyboard keys to help select topics - hold down the
Ctrl key and select the first Table of Content’s topic in the range by clicking on it,
then select the last topic in the range by clicking on it.
Start the print process:
You can start the print process from either the Menu Bar or the Tool Bar
From the Menu Bar: Click the File button, then click Print...

Or, from the Tool Bar: Click on

[Print]

The Print window (below) will open.

3.

Click Range
•
The range of topics you selected for printing will be displayed in the Book
Reader window. They will be in sequential order, from the lowest
numbered topic to the highest, regardless of how you selected them.
•
The Print window on your personal computer will open allowing you to
specify how and where you want to print the specified range of topics.

Copying
This section describes how to copy text from a book topic to the Windows Clipboard. Once in
Clipboard, you can copy the text to a text- or word-processing program.

Copying Text to Clipboard
1.

Highlight the text you want to copy.

2.

Click Edit, then Copy.

Note: On some systems, when you click Edit the highlighting on the material you

selected will disappear. The material will still copy to the clipboard when you click
Copy.

Saving a Topic as an HTML File
This section describes how to save a topic as an HTML file.

Saving a topic

This allows you to save the topic currently open in the Book Reader as an HTML file. All of the
text will be converted to HTML. Any hypertext links in the softcopy book will not be converted to
links in the HTML file that you create.
1.
2.

Open the softcopy book to the topic you wish to save as an HTML file.
From the Softcopy Reader Menu Bar: Click the File button, then click Save

Topic as HTML

The following Save Topic HTML window opens. A file name will be assigned to
the file with the extension .htm.

3.

You can rename the filename and select any directory (with write permission) on
your system to save the file.

Specify Paths to Books, PDFs, Shelves and
Shelf Indexes on Your System
This section describes how to set up path names to books, PDFs, shelves and shelf indexes so they

are readily available each time you use Book Reader and Shelf organizer.
There are two ways to access softcopy books, shelves and shelf indexes with Book Reader and
Shelf Organizer:
•
Manually – each time you want to open a book or shelf, you can manually search
through the directories and folders on your system.
•
Automatically – You can identify the location (set up paths) to the books,
bookshelves and bookshelf indexes that you want to work with in the User Defined
Directories for Publications, Shelves and Shelf Indexes window. The publications,
shelves and shelf indexes will then be readily available each time you open Book
Reader and Shelf Organizer.
Specifying Paths

You can specify publications, shelves and shelf indexes on:
•
The hard drive of your system (C:, D:, E:, etc.)
•
CD-ROM drives on your system
•
External hard drives or CD-ROM drives that you are connected to via a network
(you may have multiple CD-ROM drives you want to access)
•
Other storage devices that can be attached to your system
You can do the following procedure from either Book Reader or Shelf Organizer.
1.
From the Menu Bar of either Book Reader or Shelf Organizer, click Edit, then
click User Defined Directories.

The User Defined Directories for Publications, Shelves and Shelf Indexes window
(below) will open.

2.

In the Available Folders and Drives window [1], click on the + icons to list the
contents of each directory on your system. Select, by clicking on them, the books,
bookshelves and folders that you want to access with the Softcopy Reader
programs.

3.

Click on the Add button [2] and the path will be listed in the Paths for
Publications, PDFs, Shelves and Indexes window [3]. Continue these steps until
all books, shelves and folders are listed.
You can remove unwanted items in the Paths for Publications and Bookshelves
window by highlighting the item and clicking on the Remove button.
Note: At least one directory must be specified in the User Defined Directories for
Publications and Bookshelves window. If only one directory is listed, you will not
be able to remove it until you add another directory.

Removing IBM Softcopy Reader from Your
System
You can easily remove (uninstall) IBM Softcopy Reader (Book Reader and Bookshelf Organizer)
from your system.
Note: If you have created any shelf (*.BKS or *.XKS) or notes (*.NTF) files in the directory

where the Softcopy Reader is installed (or its subdirectories) you should backup up those files to a
different location before uninstalling.
To remove (uninstall) the program:
1.
Double click on My Computer on your Windows Desktop.
The My Computer window should open.
2.
Double click on the Control Panel folder.
The Control Panel window should open.
3.
Double click on Add/Remove Programs.
The Add/Remove Program window should open.
4.
Scroll down the list of software and highlight IBM Softcopy Reader by clicking
on it.
5.
Click on the Add/Remove button and follow the instructions on the screen.

