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About This Book
This guide introduces the VisualAge RPG and Cooperative Development
Environment for AS/400 (VisualAge RPG and CODE/400) program, which
consists of the following features:
v VisualAge RPG
v Cooperative Development Environment/400 (CODE/400)
In addition, the guide introduces the concept of project management which
allows you to develop and maintain applications with VisualAge RPG and
CODE/400 features.
This guide does not describe in detail how to use VisualAge RPG and
CODE/400. For details about further VisualAge RPG and CODE/400
information, see “VisualAge RPG and CODE/400 Information”.
As well, this guide does not describe CODE/400’s support for C, C++, CL,
COBOL, or DDS in detail.

Who Should Use This Guide
This guide is intended for application developers or analysts who are
interested in developing applications cooperatively using a programmable
workstation. It is also intended for developers who want to learn about the
Java language support offered in VisualAge RPG and CODE/400. Those who
are investigating how they can create client/server applications with graphical
user interfaces (GUIs) will also benefit from reading this guide.
You should have a general knowledge of the Application System/400
(AS/400) system. You should have experience in using applicable AS/400
menus and displays, or control language (CL) commands.
Experience with a programmable workstation and either the Windows 95,
Windows 98, or Windows NT operating system is also suggested.

VisualAge RPG and CODE/400 Information
If you want to learn more about VisualAge RPG and CODE/400, or you have
a question that is not answered in this guide, refer to the manuals listed in
“Related Publications” on page 103. The most current information is available
at the following Web site: http://www.ibm.com/software/ad/varpg/

© Copyright IBM Corp. 1994, 2000
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You can obtain information about other AS/400 publications at the following
Web site: http://publib.boulder.ibm.com/
For a softcopy version of AS/400 publications refer to the AS/400e Softcopy
Library CD-ROM, SK3T-0118-04.
In addition, extensive online help is part of the VisualAge RPG and
CODE/400 product. This includes contextual user interface help, help on
performing specific tasks, and online reference information.
VisualAge RPG and CODE/400 Tutorial
An HTML-based tutorial is available at the following Web site:
http://www.ibm.com/software/ad/varpg/download/#interactive
This interactive tutorial records your progress so you can easily return to the
last exercise you completed. Quizzes at the end of each lesson help test your
understanding of the unit.
Note: To use the tutorial, you will require a browser that can handle frames,
Java, and Javascript. You also need a file extraction tool, like WinZip,
that can handle long file names.
Publications in PDF Format
All VisualAge RPG and CODE/400 publications are included as part of the
regular product help. In addition to the regular format, the product also
contains the PDF version of these publications.
Note: You need the Adobe Acrobat Reader, Version 3.01 or later for Windows,
to view the PDF files on your workstation. You can download a copy of
the Reader from the Adobe Systems Web site at:
http://www.adobe.com
The following publications are available in PDF format in the online help:
v Installing VisualAge RPG and CODE/400 for AS/400, SC09-2446-03
v Getting Started with VisualAge RPG and CODE/400, SC09-2625-02
v Programming with VisualAge RPG, SC09-2449-02*
v VisualAge RPG Parts Reference, SC09-2450-02*
v VisualAge RPG Language Reference, SC09-2451-01*
*Note: All online versions of VisualAge RPG and CODE/400 publications
have been updated. Publication order numbers marked with an
asterisk (*) indicate manuals that have not been reprinted in this
release.

|
|
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Prerequisite and Related Information
Use the AS/400 Information Center as your starting point for looking up
AS/400 technical information. You can access the Information Center from the
AS/400e Information Center CD-ROM (English version: SK3T-2027-03 ) or
from one of these Web sites:
http://www.ibm.com/as400/infocenter
http://publib.boulder.ibm.com/pubs/html/as400/infocenter.htm
The AS/400 Information Center contains important topics such as logical
partitioning, clustering, Java, TCP/IP, Web serving, and secured networks. It
also contains Internet links to Web sites such as the AS/400 Online Library
and the AS/400 Technical Studio. Included in the Information Center is a link
that describes at a high level the differences in information between the
Information Center and the Online Library.
For a list of related publications, see “Related Publications” on page 103.

How to Send Your Comments
Your feedback is important in helping us to provide the most accurate and
high-quality information possible. IBM welcomes any comments about this
book or any other AS/400 documentation.
v If you prefer to send comments by mail, use the following address:
IBM Canada Ltd. Laboratory
Information Development
2G/KB7/1150/TOR
1150 Eglinton Avenue East
Toronto, Ontario, Canada M3C 1H7
If you are mailing a readers’ comment form from a country other than the
United States, you can give the form to the local IBM branch office or IBM
representative for postage-paid mailing.
v If you prefer to send comments by FAX, use the following number:
– 1-416-448-6161
v If you prefer to send comments electronically, use one of these e-mail
addresses:
– Comments on books:
Internet: torrcf@ca.ibm.com
IBMLink: toribm(torrcf)
– Comments on the AS/400 Information Center:
RCHINFOC@us.ibm.com

About This Book

vii

Be sure to include the following:
v The name of the book
v The publication number of the book
v The page number or topic to which your comment applies.

Conventions Used in this Guide
Directory names and file names appear LIKE THIS or like this.
Commands appear Like this.
Coding examples and text that you enter appear Like this.
User interface controls (such as check boxes, push buttons, radio buttons, and
list boxes) appear Like this.
New terms appear like this.
Note: This book does not contain a glossary. Terms are defined when they
first appear.
Window titles, folder names, notebooks, notebook tabs, or keys (for example,
the Enter key) have no special appearance.

Mouse Button Naming Conventions
The following mouse-button naming conventions are used in this guide:
v The left button is used to select an object, open a file, or start an
application. It is the physical left button unless this button has been
customized to do something else.
v The right button is used to invoke a pop-up menu for an object from which
you can then manipulate it. It is the physical right button unless this button
has been customized to do something else.
You can define the function of each mouse button from the Windows Control
Panel. If you are not sure how your mouse is configured, check the properties
of the mouse item in your Control Panel.
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Chapter 1. Overview of the VisualAge® RPG and
Cooperative Development Environment for AS/400®
Product
This chapter provides an overview of the IBM® VisualAge RPG and
Cooperative Development Environment for AS/400 (VisualAge RPG and
CODE/400) product and describes the application development tasks it can
help you perform.

What is the VisualAge RPG and Cooperative Development Environment for
AS/400 Product?
VisualAge RPG and CODE/400 is a development environment that you can
use to produce client/server applications on a programmable workstation.
You can also use it to create and maintain applications on the AS/400 host.
A programmable workstation has some degree of processing capability and
allows you to change its functions. A nonprogrammable workstation has no
processing capability. It is a terminal that is attached to an AS/400 host in
which all the user-interface functions are controlled by the host. In this
document, workstation is used to refer to a programmable workstation.

© Copyright IBM Corp. 1994, 2000
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Why would I want to use it?
Up to now you may have done all your application development on a
5250 ″green-screen″ terminal. By harnessing the ease-of-use and power of
the programmable workstation, you can start to do all of your
development and maintenance work on the workstation. Common
components allow you to learn how to work with something just once
and leverage that knowledge across all of your development activities.
Producing your application on the workstation, you can start to explore
the world of AS/400 client/server applications. See “Benefits of a
Distributed Logic Application” on page 24 for details about why you
might want to do this.
You may have existing host-based RPG applications which your user
community has been demanding you to ″modernize″. You may have a
new distributed application idea which you want to get up and running
quickly, and everyone in your programming shop is primarily skilled in
RPG. You need only a little extra knowledge in addition to your existing
RPG skills to produce a full-featured client/server application.
The VisualAge RPG and CODE/400 product includes two features for AS/400
application programmers:
v CODE/400
Contains features to help edit, compile, and debug: RPG, Integrated
Language Environment® (ILE) RPG, COBOL, ILE COBOL, Control
Language (CL), ILE C, C++, DDS, Java, and ILE CL host source programs;
design display, printer, and physical host files; and manage the components
that make up your application. The application, when built, runs on an
AS/400.
CODE/400 operates in a windowed environment in cooperation with an
AS/400 host. CODE/400 is cohesive because the tools are integrated. The
Project Organizer can start all of the tools, while the Editor can start the
compiler and debugger and the Designer can start the compiler. The
compiler errors can be automatically displayed in the Error List window.
CODE/400 also features integration with the AS/400 change and version
control tool, Application Development Manager (ADM). See “Chapter 6.
Managing VisualAge RPG and CODE/400 Projects” on page 83 for more
details on how to use ADM with VisualAge RPG and CODE/400. In
addition, integrated support for SoftLanding’s Turnover and Aldon’s CMS
products can be enabled via the EXTRAS command. From the CODE
Editor, go to Actions > Enable Extras, then click OK. After opening a new

|
|
|
|
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file, you will see the Extras menu item. Go to Extras > Change
Management Tools and select either Turnover or CMS depending on
which one you want to be enabled.
v VisualAge RPG
Offers a visual development environment on the workstation for RPG
application developers to develop and maintain client/server applications.
Applications can be edited, compiled, and debugged on your workstation.
The applications, when built, run on a workstation and can access AS/400
host data and other AS/400 objects. Its integrated components allow
application developers to preserve their current skills and easily develop
AS/400 RPG applications with graphical user interfaces.
With VisualAge RPG, you can build an application from the top down. You
start by focusing on the look and feel of the interface, and then you tie all
the parts together with workstation RPG logic that you write in the
VisualAge RPG language.
You can reuse RPG logic and display files (DSPF) from an existing
application. See Figure 1 on page 4.
The learning curve is minimal because you are using tightly integrated
tools in a visual development environment. For example, windows, buttons,
and fields are selected from a parts palette and applied with a point and
click action. You then use the GUI Designer to customize the properties of
these parts.

Chapter 1. Overview of the VisualAge® RPG and Cooperative Development Environment for AS/400® Product
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Import DSPF

Import

VARPG
Logic

EDITOR

Cut and Paste
Business Logic into
VARPG Applications

VARPG
GUI

DSPF

Logic

80% Re-use

DATA

DATA

START

RESULT

Figure 1. Reusing an existing RPG application

The term client/server in its simplest form means that there is a client
program which can request services of a server program. Both programs may
run on the same machine or on different machines, under the same operating
system, or on different platforms. In any case, the end user has the perception
of a single system. Client/server middleware and communication software
take care of data transfer and communication.
A client is a system that requests the services of a server. A client starts a
transaction with the server; a server does not normally start a transaction with
a client. The client’s main tasks are to request specific functions and accept the
corresponding results from the server.
A server is a system that provides services on request. Once a request has
been received, the server is responsible for synchronizing services and
communication with the client, and informing the client that the request has
been completed.
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Where Does VisualAge RPG and CODE/400 Fit In?
IBM® offers a wide range of tools and languages that let you develop AS/400
client/server applications. Figure 2 shows the relationship between the main
products, and where VisualAge RPG and CODE/400 fit in. For more
information about AS/400 Client Series™ application development offerings,
visit the World Wide Web site at: http://www.ibm.com/as400

AS/400 Host Application Development
Application Development ToolSet (ADTS),
Application Development Manager (ADM),
Application Dictionary Services (ADS)

Middleware
TCPIP and SNA

Host/Server
Workstation/Client

PC-Based Application Development
CODE/400, VisualAge RPG, VisualAge Generator,
VisualAge for C ++ for AS/400, VisualAge Java,
VisualAge Smalltalk, VisualAge COBOL

Figure 2. AS/400 Application Development Products

The middleware that is shown in Figure 2 simplifies your connection from
your PC to the AS/400, and includes such products as Client Access.
Another layer is the data access APIs (application programming interfaces)
which allow your clients to access data on the AS/400. These include such
things as Java Database Connection (JDBC), DB2® DDCS, and Smalltalk’s
wide variety of AS/400 parts. VisualAge RPG has its own direct I/O to
AS/400 databases.

Chapter 1. Overview of the VisualAge® RPG and Cooperative Development Environment for AS/400® Product
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Components Common to Both VisualAge RPG and CODE/400
The following components are common to both VisualAge RPG and
CODE/400, as illustrated in Figure 3 on page 7:
v Editor: a programmable editor that allows you to add new editor functions
or change existing ones in either VisualAge RPG or CODE/400.
Language-sensitive editing and language-sensitive help come with the
editor.
v Debugger: two debuggers are supported with the product: the IBM
Distributed Debugger and the VisualAge RPG debugger. The IBM
Distributed Debugger is the debugger for CODE/400, and is the debugger
for VisualAge RPG on Windows NT.
v CODESRV workstation command: for accessing host commands, lists from
REXX (REstructured eXtended eXecutor), and editor macros. CODESRV can
be run directly from a DOS window.

|
|
|
|

v Uniform installation procedure: the communications setup between the
AS/400 host and the workstation only needs to be performed once. Both
use exactly the same communications setup and share the same
communications link with the AS/400 system. VisualAge RPG requires
some additional communications setup between the workstation and the
AS/400 host. See the Installing VisualAge RPG and CODE/400 for AS/400
manual for more information.
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AS/400 Host
Server access programs for VisualAge RPG and
CODE/400 are shipped with ADTS (5769-PW1).
VisualAge RPG runtime support is
shipped with OS/400 (5769-SS1).

Host/Server
Workstation/Client

Communications with AS/400 host
and Communications Configuration

VisualAge RPG
Project Organizer

CODE/400
Project Organizer

Editor
CODE Designer

VisualAge RPG
GUI Designer

IBM Distributed
Debugger

VisualAge RPG
Debugger

CODE/400
Program Verifiers and
Host Compiler Interfaces

VisualAge RPG
Workstation Compiler

Figure 3. The VisualAge RPG and CODE/400 Product
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Components Unique to Either VisualAge RPG or CODE/400
The following components in the VisualAge RPG and CODE/400 product are
unique to either VisualAge RPG or CODE/400 as indicated below:
v CODE/400 (see Figure 3 on page 7):
– CODE Designer: screen (display), report (printer) and physical file design
utility.
– Editor: DDS, ILE and OPM RPG, and ILE and OPM COBOL syntax
checking: help you to quickly detect syntax errors in your programs.
Color tokenization of DDS, RPG, COBOL, and CL also improves the
readability of your code.
– DDS, ILE and OPM RPG, and ILE and OPM COBOL program verifiers:
help to reduce the workload on the AS/400 and speed up application
development. The RPG and COBOL program verifiers allow you to
check for syntax and semantic errors in the program source locally on
the workstation.
– Compiler interface (program generator): provides an interface that allows
you to submit requests to compile, bind, or build objects on the host.
Compiler interface provides error feedback on the workstation.
– Project Organizer: helps you manage persistent lists of local, host, and
Application Development Manager entities.
v VisualAge RPG (see Figure 3 on page 7):
– GUI Designer: A tool suite that allows you to create interfaces by
dragging and dropping parts onto the window you are designing. From
the GUI Designer, you can also launch edit, compile, and debug tasks.
– VisualAge RPG syntax checker: helps you to quickly detect syntax errors
in your VisualAge RPG programs.
– VisualAge RPG compiler: performs compilations on the workstation,
where your applications eventually run.

|
|
|
|
|
|

– Help and message compiler: allows you to incorporate online help and
messages into your workstation application.
– Project Organizer: helps you manage your VisualAge RPG source and
objects.
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What This Release Offers
The VisualAge RPG and CODE/400 product addresses many of your
client/server application development needs. Listed here are brand new
features for this release.

|

For CODE/400

|
|
|
|
|
|
|

Editor
v HTML support

|
|
|
|
|
|
|
|
|

Support for editing HTML files has been enhanced with token highlighting.
v Compiling C++ source from a mounted drive.
Support has been added to allow compiling C++ source on the AS/400 that
is accessed from a mounted AS/400 drive.
v Quiet exit in Command Shell
The Command shell normally displays a confirmation message before
closing. The Quiet exit option allows the Command Shell to close without
displaying the message.
v Tips and Techniques Guide
New tips and techniques have been added about extracting the source type
of the current document, compiling files on an AS/400 IFS, and using the
CODE tools with the Operations Navigator.
v Extra Features Guide
New macros have been added to the Primary and Extra macros sections.

|
|
|
|

Program Generator
v C/C++ compile option dialogs

|
|
|
|

Operations Navigator plug-in

|
|
|
|
|
|
|

For VisualAge RPG
v Subfile fields now support the VALUE keyword.
v A new StartAt attribute is available for the subfile part. You can now force
the READC operation to start at the record specified.
v The label substitution character (|) is now supported for subfile column
headings.
v A tab stop can now be set for the subfile part.

New compile option dialogs are provided for the CRTCMOD, CRTBNDC,
CRTCPPMOD, and CRTBNDCPP commands.

v CODE/400 now provides a plug-in for the Client Access Operations
Navigator. This plug-in allows you to invoke the CODE editor, compiler,
debugger, and designer from within the Operations Navigator.

Chapter 1. Overview of the VisualAge® RPG and Cooperative Development Environment for AS/400® Product
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v Auto format and auto validation for entry fields have been added.
v The subfile, container, and list box parts now support the KeyPress and
VKeyPress events.
v The Notebook page TabLabel attribute is now gettable.
v A new ShowTabs attribute for the Notebook part allows you to show all
tabs or not.
v A new setting in the Options dialog determines if all tabs should be shown
in properties notebooks.

|
|
|

v Additional spacing capabilities for parts relative to a bounding area are
now supported.
v The Canvas part now supports the Enabled attribute.

|
|
|
|
|

v The new *component part attribute, Platform, returns the environment the
application is running in (Java or Windows).
v The ability to specify a part’s size and position in the part’s settings
notebook.
v The ability to invoke user commands as the last build step.

|

v Personal Communications (PCOMM) for Windows is now supported.

|
|

v A new option allows you to specify that you only want to work with
TCP/IP servers.

|
|
|
|
|
|
|
|

v The ’Who Am I’ dialog in the GUI Designer provides project and VARPG
information.
v The new Java Bean part has been added to the parts palette. You can now
use JavaBean components in your application.
v Menu items now support What’s This? help for Java applications.
v The Entry Field and Multiline Edit parts now provide a new setting that
retains text selection even if the window they are on loses focus.
v A Find button has been added to the Component Package dialog.

|

v The TEST directory can now be specified for each project.

|

For Documentation

|
|
|
|
|
|
|
|

Online Help
v The VisualAge RPG and CODE/400 documenation, now in HTML format,
can be viewed in a Web browser. The online help is a collection of help
topics, references, programming guides, and other information about
VisualAge RPG and CODE/400. Browsing the online help is much like
browsing the Internet. Hypertext links take you from one topic to another.
You can also search for words or phrases, and restrict your search to
specific information types.

|
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What Can You Do with VisualAge RPG and CODE/400?
While you develop an RPG client/server application, the tools in VisualAge
RPG and CODE/400 help you to:
v Create device files
v Create application user interfaces on the workstation and the host
v Edit host-based RPG or workstation-based RPG program source
v Create help and messages on the workstation
v Compile RPG program source on the workstation and on the AS/400 host
v Debug host-based RPG or workstation-based RPG program source
These tasks appear in the order in which you might perform them.

Designing Device Files
|
|
|
|

CODE/400 includes a full-featured DDS design tool called CODE Designer
which you can use to design DDS screen (display), report (printer), and
physical files. It is a complete design environment, incorporating such tools as
the CODE Editor, the Error List, and the Program Generator.
The CODE Designer consists of the following views:
v DDS Tree
The DDS Tree is located on the left-hand side of the CODE Designer
window. This view presents the loaded DDS source as a tree structure,
showing the hierarchy of files, records, fields, and keywords in each
selected DDS object. Groups of records, which represent the screens or
reports you are designing, are shown as peers of the file in the tree
hierarchy.
v Workbook
The Workbook is the area of the CODE Designer where you design display
files, printer files, or physical files. This notebook is located on the top
right-hand side of the CODE Designer window, and contains the following
pages:
The Details page provides a detailed view of the DDS objects selected
by the DDS Tree. You can view this page in either details mode or list
mode.

|
|

The Design page shows the DDS source as it would appear on either a
screen (for display files) or a printed page (for printer files). You can
easily create new records, fields, and constants directly on the Design
page using the palette to the left of the design area. The toolbar above
the design area allows quick access to many of the editing features as
well as information about the currently selected object.
The Source page can be altered to be in edit or design mode. In edit
mode you can use the full power of the CODE editor.
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The Verify Listing page is a listing of the source statements generated by
the program verifier. This page provides you with information regarding
the correctness of the syntax and the semantic structure of your DDS
code.
v Utilities
The Utility notebook is located on the lower right-hand side of the CODE
Designer window and lets you view specific elements of the DDS source
such as errors and selected objects. This notebook contains the following
pages:
The Selected source page displays the generated DDS source for the
currently selected item in the Details page or Design page of the
Workbook, or in the DDS Tree.
The Error list page shows you the error messages from the previous
DDS source verification. You can view the messages associated with
errors in source programs along with their message numbers and
severity codes.
The Comments page displays the DDS comments associated with the
selected item and allows you to modify them.
The Create keywords page lets you add, modify, and obtain help for
DDS keywords for a file, record, or field. Keywords are represented as
icons. There are keyword icons for simple keywords, and property icons
for those keywords which are created and modified through a page in
their file, record, or field’s property notebook.

Designing a Workstation-Based Graphical User Interface
This section describes how you can use the VisualAge RPG GUI Designer to
create a workstation graphical user interface.
The GUI Designer is similar to Application Development ToolSet for AS/400’s
Screen Design Aid (SDA), because the GUI code is created for you, from a
visual interface which you manipulate. However, unlike SDA, the GUI
Designer does not create editable user interface source (like DDS). Instead you
always use the GUI Designer to change your user interface. With the GUI
Designer, you tie all the parts together with the workstation RPG logic that
you write in the VisualAge RPG language.
You can access a DB2/400 database, just like you can with SDA. You can
easily pick up fields from the database.
The GUI Designer consists of the following parts:
v Parts palette
The parts palette is a collection of icons representing a window canvas, list
box, push button, check box, radio button, and other objects that are used
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in designing a window. These objects are known as parts. Text, like labels in
push buttons, field prompts, and titles in windows, usually identifies parts.
The palette allows you to work quickly when designing a window. For
example, with your mouse you can simply drag a push button part to the
window you are designing and drop a new push button into place.
v Project window
The Project window contains the menu bar, tool bar, project view, and
information area.
The menu bar appears below the title bar. Pull-down menus from the menu
bar provide a variety of tasks you perform when you design an application.
For example, creating and running your application, customizing the GUI
Designer, and using help.
The icons in the tool bar are the most frequently used actions from the
menu bar. You can customize the tool bar to support the actions that are
most appropriate to your own particular needs.
The Project window displays a representation of the current project you are
working with in VisualAge RPG. The representation appears as either a tree
view or an icon view.
The tree view is a hierarchical structure that shows an icon and name
for each window and part. The relationship between the window part
and the parts within a window is called a parent-child relationship. The
window part is a parent to each of the parts it contains (the children).
You can see this relationship using the tree view. The tree view also
allows you to display the pop-up menus on parts so that you can select
and manipulate them.
The icon view shows a window part icon for each of the windows in the
project. Only the windows of the project appear with this view.
The information area provides a brief description of an icon when you
position your mouse over any of the icons in the palette or the tool bar.
This area is sometimes called the status bar.
See “The GUI Designer” on page 29 for more details.
Reusing Existing AS/400 Display Files for the GUI
With VisualAge RPG, you can reuse existing AS/400 display files by
importing them. If you choose to import display files, record formats are
converted to windows, and constants and fields defined in that format are
converted to parts in the newly created window. You will most likely want to
change the new window. The import function does its best to create an
identical GUI window; however, the window may not be identical to the
OS/400® display file.
See Programming with VisualAge RPG for a description of the import function.
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Editing Host or Workstation Source
In the VisualAge RPG and CODE/400 product, you use the same editor with
both VisualAge RPG and CODE/400.
The editor offers the following features:
v Seamless access to local files
v Seamless interface for opening OS/400 members and Application
Development Manager parts for editing with member locking that is similar
to SEU (source entry utility)
v Ability to customize and program the editor using either REXX or Java
v Java macros, called Lpexlets, are included in the product that can help you
understand your code. To use these macros, you must have the Java 2
Software Development Kit (J2SDK) from JavaSoft installed on your
workstation. See the Installation Guide for more information.
v Sequence numbers, which allow the use of SEU-style commands in the
prefix (sequence number) area
v C, C++, REXX, CL, and Java language-sensitive editing that offers
tokenizing, online language-sensitive help, and prompting (where
applicable)
v Interactive syntax checking

|
|
|
|
|
|
|
|
|

v Concurrent multiple edit sessions as well as multiple views of the same
document, all with cut and paste capabilities
v Configurable token highlighting of language constructs using different
colors and fonts to help identify different structures in a program
v Capability to view only specific types, such as C specs or lines with a
specific string
v Navigation through procedures and subroutines in one or more files
v Powerful regular expression searching
v Graphical file comparison
v Multiple file search
v Keystroke recording
v Command shell for running local or host commands with logged output
VisualAge RPG
When you use the editor in VisualAge RPG, you write event-driven
programming logic. You create and work with local RPG source directly on
your workstation.
Rather than coding the GUI, you use a visual interface to help you create the
GUI code. For example, you select a part such as a push button or an entry
field, drag it with the mouse, and drop it on the window you are designing.
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You then select an event for the part from the part’s popup menu and then
use the editor to create the workstation RPG program logic behind that event
for the part.
You create the program logic using the VisualAge RPG language. All the
pieces of workstation RPG source are added to one file.
|
|
|
|
|
|
|
|

CODE/400
In addition to the features listed in “Editing Host or Workstation Source” on
page 14, with CODE/400 installed, there are three more features:
v Detection of errors earlier in the coding cycle using workstation-based DDS,
RPG, and COBOL program verifiers.
v Seamless workstation interface for compiling programs on the AS/400 host.
v DDS, RPG, and COBOL editing that offers tokenizing, online
language-sensitive help, and prompting (where applicable).
When you use the editor in CODE/400, it automatically downloads source
from the AS/400 host to your workstation, where you do your editing. The
editor has features similar to the SEU editor that is part of Application
Development ToolSet for AS/400. However, because it is a workstation-based
tool that takes advantage of the graphical operating system, it offers many
additional features designed to optimize coding efficiency for the
programming language prior to calling the host compiler.
In addition, any source type can be edited using the editor.

Compiling RPG Source
|
|
|

This section describes the benefits of compiling RPG source with the
VisualAge RPG compiler and with the host compiler, accessed through
CODE/400.
VisualAge RPG
With VisualAge RPG, you perform builds on the workstation, and your
application also runs on the workstation. The VisualAge RPG compiler is an
extension to the RPG IV language definition. VisualAge RPG provides the
capability for your workstation application to access AS/400 database objects
or contain calls to programs that reside on the host.
The VisualAge RPG language supports event-driven programming. The
language extensions allow you to create action subroutines that can be called
at runtime when an event is triggered through the user interface. New RPG
operation codes are available to change part attributes dynamically and to get
the value of part attributes at runtime. For example, you can view or change
the color of a part by using the workstation RPG logic.
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When you build a VisualAge RPG application, error messages are displayed
in an Error List window. From there, you can double-click on an error, and
the source code is displayed (with the error highlighted) in the editor window.
Note that you can target the Windows NT/95/98 or Java runtime
environment when you decide to build an application.
CODE/400
When you use CODE/400, you can verify the syntax and the semantics of
program source on your workstation using the RPG program verifier before
sending the source to the host compiler. When you are ready to compile the
source, you can start the host compiler from CODE/400 with the program
generator. Because CODE/400 remembers which compile options are used to
compile each source member, you only need to specify unique options once.
When you start the RPG program verifier or the host compiler, error messages
are sent back to the editor and displayed in an Error List window, with the
editor still visible. You can begin locating and correcting errors in the source
code immediately. If you double-click on an error in the Error List window,
your mouse pointer goes to the location of the error in the source in the editor
window.
Verifying RPG source with CODE/400 offers the following:
v Fewer host compiles by using the CODE/400 RPG program verifier. It lets
you examine source for coding errors more thoroughly than the line-by-line
syntax checker and more quickly than the host compiler.
v Local verification off loads the host processing unit by assuring that there
will be no syntax or semantic errors at compile time.
v Caching of verification information on your workstation, further reducing
host processing requirements.

Debugging Host or Workstation-Based Programs
|

This section provides an overview of the IBM Distributed Debugger and the
VisualAge RPG debugger.

|
|
|

IBM Distributed Debugger
The IBM Distributed Debugger is the debugger for CODE/400, and is the
debugger for VisualAge RPG on Windows NT.
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|

For CODE/400:

|
|
|
|
|
|

The IBM Distributed Debugger is a source-level debugger that allows you to
debug applications running on the AS/400 host from your workstation. With
this debugger, you can:
v Quickly identify errors in the application’s logic.
v Set and change breakpoints in the application program.
v Monitor variables and the call stack.

|
|

v Use watchpoints.
v View source code or compiler listings on the workstation.

|
|

v Debug servlets and JavaServer Pages and Enterprise JavaBeans™ on the
AS/400 host.

|
|
|

v Browse source and set breakpoints before the application runs on the
AS/400 host.
v Attach to a Java Virtual Machine already running on the AS/400 host.

|
|
|

The IBM Distributed Debugger works with ILE C, C++, RPG, COBOL, and
CL. There is also support for OPM RPG, COBOL, and CL applications. Java
applications are supported with the AS/400 host V4R2 or later.

|

For VisualAge RPG:

|
|

In addition to the functions supported by the VisualAge RPG debugger, you
can debug Java applications generated by VisualAge RPG.
VisualAge RPG
The VisualAge RPG debugger helps you detect and diagnose errors in your
workstation application. The debugger provides three windows that display
different information about your program. These windows display your
source code, breakpoints, the program’s call stack and various monitors.
With the VisualAge RPG debugger, you can:
v Set breakpoints.
v Monitor variables, registers, the call stack, and storage.
v Debug VisualAge RPG or C++ applications.
v Customize the debugging session.
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Creating Help and Messages
VisualAge RPG allows you to incorporate online help and messages into your
workstation application by using the Information Presentation Facility (IPF)
tag language. IPF is a tool that supports the design and development of
online documents and online help facilities, and has similar syntax to UIM
help on the host.
Note: On Windows, the IPF-based help is converted to the native Windows
format (RTF) at compile time.
VisualAge RPG provides a smooth connection between the online help
information and the associated GUI object. As well, it provides national
language support for applications. For example, you can use substitution
variables as labels on any part that contains a label; for example, you could
use the substitution variable |ok for a push button. The text for that variable
would then be written for that label using the Define Messages function. The
Define Messages function separates the text from the RPG code, making it
easier to translate the user interface into another language.
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Chapter 2. Capitalizing on VisualAge RPG and CODE/400
The CODE/400 and VisualAge RPG features that make up VisualAge RPG
and CODE/400 provide you with a new way of creating and maintaining host
applications and client/server RPG applications. This chapter provides:
v An illustration showing the VisualAge RPG workstation-based tools you
can use to develop the various components of your workstation application.
v An illustration showing the CODE/400 workstation-based tools you can use
instead of host-based application development tools to develop AS/400 host
applications.
v An illustration showing the differences between applications created with
VisualAge RPG and those created with CODE/400.
v The steps you can follow to create a client/server distributed logic
application by using VisualAge RPG and CODE/400.

Using VisualAge RPG to Create New Client/Server Applications
Figure 4 on page 20 illustrates that when you create a VisualAge RPG
application, you create the application on your workstation. The application,
when built, will run on a workstation and access data and services on an
AS/400 host.

© Copyright IBM Corp. 1994, 2000

19

Host/Server
Workstation/Client

PC BASED TOOLS
VisualAge RPG
Direct manipulation, GUI, or
optionally the Project Organizer
RPG Logic
• Editor
• VisualAge RPG
Workstation compiler
• Debugger
Presentation Logic
• GUI Designer

Figure 4. Tools for VisualAge RPG Client/Server Application Development

During design time, you access an AS/400 server when you perform the
following tasks:
v Importing AS/400 display files
v Referring to AS/400 database fields
v
v
v
v
v

Backing up a project
Restoring a project
Checking-out a project
Checking-in a project
Extracting a project

During build time, you access an AS/400 server if your application accesses
an AS/400 file, and you have not previously built the application with
caching enabled.
During run time, you access an AS/400 server if your application calls
AS/400 programs, accesses AS/400 databases, or uses AS/400 data areas.
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Using CODE/400 to Work Efficiently with New or Existing Host RPG Logic
CODE/400’s cooperative environment allows you to access integrated tools
from an easy-to-use GUI on a workstation to develop and maintain AS/400
applications.
Figure 5 contrasts host-based application development tools with the
CODE/400 workstation-based tools that allow you to undertake cooperative
application development.

HOST BASED TOOLS
ADTS
PDM List Interface
RPG Logic
• Source Entry Utility (SEU) editor
• Interface Source Debugger (ISDB)
Presentation Logic
• Screen Design Aid (SDA)
• Report Layout Utility (RLU)

Host/Server
Workstation/Client

PC BASED TOOLS
CODE/400
Direct manipulation, GUI, or
optionally the Project Organizer
RPG Logic
• Editor
• Program Verifier
• Compiler
• Debugger
• Host Command Shell
Presentation Logic
• Editor support for DDS
• CODE Designer

Figure 5. Tools for Host-Based and CODE/400 Workstation-Based Application Development
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You do not require an AS/400 host connection to use most of the tools in
CODE/400, with the following exceptions:
v Program verifier: Verification is limited if information required by the
program verifier resides on an AS/400 and you have not previously
verified the program with caching enabled.
v Debugger: Requires an AS/400 connection since you monitor the
application in its runtime environment.
v Editor: When you edit an AS/400 member and then save it to the host, you
require an AS/400 connection. Click File > Save As on the menu bar to
save the file locally. Alternatively, you can use the GET action in the
CODE/400 Project Organizer to copy the AS/400 member to a workstation
file and later use PUT to return it.
v Compiler: When you launch a compile from the Program Generator or from
within the editor, the processing takes place on the host so a connection to
the AS/400 is required.
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Applications Created Using VisualAge RPG and CODE/400
Figure 6 illustrates the difference between an application that has been built
using VisualAge RPG and one that has been built using CODE/400. Both are
workstation products; however, end users run the applications that are built
using CODE/400 on the AS/400 system. End users run applications that are
built using VisualAge RPG from a workstation. Yet both products access data
and services that reside on the AS/400 host.

Application Created
Using CODE/400

Application Created
Using VisualAge RPG

Location of Data

On AS/400

On AS/400 or
a Workstation

Location of
Application Logic

On AS/400

On a Workstation

Location of
Presentation
Logic

On AS/400

On a Workstation

Figure 6. Differences Between an Application Built Using VisualAge RPG and Using CODE/400
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Client/Server Distributed Logic Applications
This section describes:
v How a client/server distributed logic application works on a client and a
server.
v The benefits of a distributed logic application.
v A brief scenario that shows, at a high level, how to use VisualAge RPG and
CODE/400 to create a distributed logic application.
Workstation applications can take advantage of the host’s power to provide
convenient centralized data storage and processing, as well as data accuracy.
You might, for example, develop individual customer file-maintenance
programs to run on workstation clients with GUIs, while maintaining a
central customer database on an AS/400.
A client/server application makes this remote data application scenario
possible, and takes advantage of both the host and workstation environments.
CODE/400 provides everything you need for host application development.
VisualAge RPG provides all the tools that are needed to create an application
with a GUI that runs on a workstation, and accesses data that is stored on an
AS/400 host.
This strategy may be appropriate if the application must search or process a
very large number of records. RPG logic on the workstation, or client, for
example, might send the request to process the data from the workstation
across the network to the server. The RPG logic that resides on the host server
would then query and process the data, and return the results to the client.
The logic could do this, for example, by updating the parameters of a remote
program call, or by using a data queue. The workstation RPG code could then
call a subroutine on the AS/400 server that would print a report of the
appropriate records from the database.
This is a distributed logic application; the programs would run on the
workstation client and on the AS/400 server.

Benefits of a Distributed Logic Application
A client/server distributed logic application offers the following benefits.
AS/400 Efficiency, Integrity, and Security
An AS/400’s processing power provides an efficient and safe server. Consider
the following scenarios:
v Processing from a centralized server:
Some logic, data, and resources are best processed in a central server
location, which can feed user-unique information to workstations on
demand.
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v Manipulating large amounts of data:
Traffic across the network between the host and the client is lower if the
AS/400 host performs the data manipulation instead of the workstation
client. Lower network traffic can give better performance on the client.
v Handling mission-critical data:
A bank application is an example of an application in which the integrity of
an AS/400 host is required for data validation and data manipulation.
v Operating in batch:
Many overnight batch operations are best left on the server next to the data
and resources they need.
|
|

Efficient User Interface
By moving relevant logic to the AS/400, you may see improved response
time.
Capacity for Event-Driven Workstation Programming
A window-based environment provides an application developer with the
capability to do event-driven programming, unlike OS/400 procedural
programming. Applications can be written that respond better to a user’s
demands. A user can jump from one task to another, instead of needing to
follow a specific series of tasks from start to finish. The result is better
productivity for the end user.
For example, an application could be written using VisualAge RPG to allow a
customer in a video store to list the selection of videos available, view the
information for a specific video, rent a video, and return a video. A customer
does not need to perform all the tasks in a predetermined order. The
event-driven method of programming more realistically reflects real-life
business processes.
Improved End-User Productivity
With the ability to create an application with a GUI, application developers
have more flexibility. A GUI can be designed that allows end users to perform
only the tasks they want, unlike an application written in a procedural
manner. This approach implies less training for the end user, tasks with fewer
steps that are easier to perform, and more flexibility for the end user. For
example, an end user could now see a specific subset of customers from the
AS/400 database.
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Server and Client Pieces of an Application
Figure 7 on page 27 illustrates the VisualAge RPG and CODE/400 tools that
are used to create the client and server pieces of a distributed logic
application.
The application that is described in the figure has the following
characteristics:
v Data that resides on the AS/400 server.
v RPG logic that resides on the server.
v Workstation RPG logic that resides on the client.
v Presentation logic that resides on the client.
You can use the following tools to develop the application:
|
|

v Editor:
– helps create the physical and logical files.

|
|

– helps create the host and workstation-based RPG logic.
v VisualAge RPG GUI Designer:
– helps create the graphical interface.

26

Getting Started with VisualAge RPG and CODE/400

An Application Under Development

Data File

Some RPG Logic
that will
run on the host

Host/Server
Workstation/Client
VisualAge RPG and
CODE/400
PC-Based Tools

Editor

Some RPG Logic
that will run on
the workstation

Presentation Logic
that will run
on the workstation

VisualAge RPG
GUI Designer

Figure 7. Creating a Client/Server Distributed Logic Application

Chapter 2. Capitalizing on VisualAge RPG and CODE/400

27

28

Getting Started with VisualAge RPG and CODE/400

Chapter 3. An Introduction to the VisualAge RPG and
CODE/400 Tools
When you use the tools in VisualAge RPG and CODE/400, your work is
greatly simplified. This chapter presents general information about the tools to
familiarize you with them. “Chapter 4. Creating Client/Server Applications”
on page 59 demonstrates how to use the tools to create a client/server
application.

The GUI Designer
Use the GUI Designer to create your VisualAge RPG applications. It consists
of the project window, the parts palette, and the design window.

Figure 8. The GUI Designer’s Project Window and Parts Palette

The Project Window
The project window is your interactive development environment. The project
window consists of the following:
Project view
The center of the window contains a representation of the GUI objects
in the project.
Menu Bar
Lists the actions you can invoke using menu items.
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Tool Bar
Contains graphic push buttons you can press to invoke frequently
performed actions.
Status Bar
Contains descriptive text when you place the cursor over certain areas
of the GUI Designer.
The Project View
The project view displays a representation of the current working project in
VisualAge RPG. The representation is displayed as either a tree view or an
icon view.
The tree view is a hierarchical structure showing an icon, name, and (where
applicable) the label for each window and part in the project.

Figure 9. Tree View
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The icon view shows a window part icon for each of the windows in the
project. Parts contained within windows are not displayed with this view.

Figure 10. Icon View

The Menu Bar
The VisualAge RPG product makes extensive use of menus to assist you in
designing an application. There are two types of menus:
v Pull-down Menus (from the menu bar)
v Pop-up Menus (from objects within the project view)
On the project window, the menu bar appears below the title bar. Actions on
the pull-down menus from the menu bar let you perform a variety of tasks
when you design an application. For example, creating and running your
application, customizing the GUI Designer, and using help.
Pop-up menus provide you with a list of choices specific to the object that the
mouse pointer is over, such as a part, group of parts, or window. These
menus are accessed directly from an object by right-clicking when the mouse
pointer is over the object in a design window or the project view. The same
choices can also be accessed from the Selected pull-down menu when an
object or group of objects is selected.
The choices on menus are called menu items. Some menu items contain a
right arrow (→) at the right side. This marking indicates there is additional
information you need to be aware of in a secondary list of choices. This
secondary list is called a submenu. Some menu items contain an ellipsis (...)
at the right side. This marking indicates that there is additional information
that will appear in a window when this item is selected.
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The Tool Bar
The tool bar is a menu of graphic push buttons. These push buttons represent
certain pull-down menu items, and are intended to provide quick access to
common actions you perform, for example, saving a project. Use the tool bar
as an alternative to using some menu items. When you place the cursor over
one of these push buttons, hover-help appears next to the button containing a
short description of the action. A description of the action is also displayed in
the status bar.
The initial location of the tool bar is at the top of the project window, but you
can change its position, as well as its contents.
The Status Bar
The status bar (also referred to as Information Area) provides you with
information for tool bar action icons and menu items. Position the mouse over
any of these items and the status bar displays a short description of it.
Some other windows within the GUI Designer also have a status bar that
displays a short description of objects that the mouse is positioned over.
By default, the status bar is located at the top of the project window. You can
change its position or you can hide the status bar if it is not required.
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The Parts Palette
The parts palette contains a customizable set of parts that you use to create
the screen layout for your VisualAge RPG application. Use the palette like a
painter uses a paint palette. It’s the place where you keep the parts that are
most appropriate for the design you are currently working on. As you finish a
design, you can wipe the palette clean and start all over with other parts from
the parts catalog. Use the palette if you wish to access your own personalized
set of parts when designing a GUI.

Figure 11. Parts Palette

By default, the parts palette is not part of the project window but appears in a
window of its own. You can configure the parts palette to be part of the
project window.
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The Parts Catalog
The parts catalog is an alternate view of the palette. It can be seen by clicking
the icon at the left end of the icons across the bottom of the palette. It contains
all of the parts that you use to create the screen layout for your VisualAge
RPG application. You can select parts from the catalog and copy them to the
parts palette if you intend to use them frequently. Use the catalog like a
painter uses a paint chest. It’s the place where you keep all of the various
parts you accumulate over time. Use the catalog if you wish to access all of
the parts when designing a GUI. To switch back to the palette view, click on
the icon at the left end of the row of icons at the bottom of the catalog.
Note: All the parts supplied by IBM are contained here. You cannot delete
these IBM-supplied parts from the catalog.

Figure 12. Parts Catalog

You can define your own customized parts, called user-defined parts. You can
delete customized parts from the catalog if you no longer want them.
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Customizing Your Work Environment
You can customize VisualAge RPG to suit your way of working.
v Most of the GUI Designer elements can be changed in size, position and
content.
v You can create programming templates for use in your program logic and
help files.
v You can define the servers and AS/400 information you will be using in the
VisualAge RPG applications you write.
v You can create your own customized parts that you can keep on the parts
palette or store in the parts catalog.

Customizing the Catalog and the Palette
Use the palette like a painter uses a paint palette. It’s the place where you
keep the parts that are most appropriate for the design you are currently
working on. As you finish a design you can wipe the palette clean and start
over with other parts from the catalog.
Use the catalog like a painter uses a paint chest. It’s the place where you keep
all of the various parts you accumulate over time.
Use the tool bar on the palette to toggle between the palette and the catalog.
The palette’s default view is floating. Using the icons on the palette’s tool bar,
you can display the palette attatched to the left side, right side, top or bottom
of your project window.
Adding Parts from the Catalog to the Palette
To add a part from the parts catalog to the parts palette:
1. Display the parts catalog by:
v Clicking the catalog icon from the tool bar along the bottom of the parts
palette.
v Clicking Options > Parts Palette > Catalog.
2. Right click to display the pop-up menu of the part in the catalog.
3. Click Add to palette.
The part is added to the palette.
Adding User-defined Parts to the Catalog or the Palette
A user-defined part is designated by its name and icon. To add a user-defined
part to the catalog or the palette:
1. Select the part or group of parts that you want to have as a user-defined
part. You can select from a design window or from the tree view in the
project view.
2. Select Add to catalog from the Selected menu or on the parts’ pop-up
menu. The Create User Defined Part window is displayed.
3. Enter a part name.
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4. Enter the name of the catalog page that you would like the part to appear
on. This defaults to the User-defined page.
5. If you do not want to use the default icon, you can specify another icon
by:
v Using Find to open the Find an icon for the part window:
a. Select the drive and directory where the icon is located.
b. Select an icon.
c. Click OK to close the window and accept the icon. Click Cancel to
close the window and ignore any selections.
6. Click Catalog only to place the part only in the parts catalog. Click
Catalog and palette to place the part in both the parts catalog and the
parts palette.
7. Click OK to close the window.
The part is created and added to the catalog on the specified page. If Catalog
and palette was specified, the part is also added to the palette.
Modifying User-defined and AS/400 Imported Parts
The name or icon of user-defined and AS/400 imported parts are modifiable.
You can also specify the catalog page on which the part appears. To modify a
user-defined or AS/400 imported part:
1. Display the pop-up menu for the user-defined part in the catalog.
2. Click Modify to open the Modify Part window.
3. Modify the properties.
4. Click OK to close the window.
The part is updated to reflect the modifications.
Removing Parts from the Catalog or the Palette
To remove a part from the parts catalog or the parts palette:
v Using a mouse:
1. Display the pop-up menu for the part.
2. Click Remove.
The part is removed. You can also remove selected parts by pressing the
Delete key.
Note: If a part is removed from the palette, it will still exist in the catalog.
Only user-defined parts and AS/400 imported parts can be removed
from the catalog.
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Changing the Position of Parts on the Palette
On the palette, parts are arranged in rows and ordered from left to right. To
change the position of a part:
v Using a mouse:
1. Display the pop-up menu for the part.
2. Click Move up or Move down.
If Move up was selected, the part moves one position to the left. If Move
down was selected, the part moves one position to the right.

Customizing the Tool Bar
The Customize Tool Bar window is used to change action icons on the tool
bar. Select Change from the Tool bar submenu in the Options menu to open
the Customize Tool Bar window. In this window, you are presented with two
containers: one lists all of the available action icons and the other lists the
action icons already selected for your tool bar. The Available icons window
also contains a separator which you may drag and drop as many times as you
wish to create spaces between the icons as they appear on the tool bar.
Adding Action Icons to the Tool Bar
To add an action icon to the tool bar:
v Select an action icon from the Available icons container in the Customize
Tool Bar window. Drag the icon to the Used icons container and drop it in
the order you want it to appear on the tool bar.
The action icon associated with the selected menu item is placed on the tool
bar.
Removing Action Icons from the Tool Bar
To remove an action icon from the tool bar:
v In the Customize Tool Bar window, select the action icon you wish to
remove from the Used icons container and drag and drop the icon into the
Available icons container.
The action icon is removed from the tool bar and appears back in the
Available icons container.
To remove a separator, drag and drop it back in the available icons container.
Arranging Action Icons on the Tool Bar
To change the position of an action icon or a separator on the tool bar:
v Drag the action icon or the separator to the desired location in the Used
icons container.
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Customizing the Grid
All open design windows have an associated grid. A grid is a visual aid that
facilitates the arranging of parts in a window.
The global grid applies to all newly created or opened design windows. Click
Change from the Grid submenu in the Options menu to open the Customize
Grid window. Use the Customize Grid window to customize the grid for all
newly created or opened design windows.
Defining the Grid Size
To define the grid size with the mouse:
1. Select the Scale grid with mouse radio button.
2. Place the mouse pointer within the boundary of the Grid Sample Window.
3. Click to enable sizing.
4. Move the mouse until the grid is sized to the desired value.
5. Click to set the grid size.
The grid size can also be defined using the radio buttons on the Customize
Grid dialog. Use the spin buttons to specify the number of partitions or the
number of pixels that you would like.
Modifying Grid Style and Options
To modify the grid style:
v Select the Markers radio button to display the grid as markers or dots.
v Select the Lines radio button to view the grid as lines.
To modify the other grid options:
v Select the Set grid on check box to display the grid in all design windows
that are created or opened.
v Select the Snap new parts to grid check box to make newly created or
repositioned parts snap to the grid. The bottom left corner of the part snaps
to the closest window grid point. If multiple parts are selected, each
selected part will snap to the grid point that is nearest to it.

Customizing VisualAge RPG Templates
VisualAge RPG provides a number of templates which are used when creating
program logic and help source files. You may wish to change these templates
according to your own coding standards.
The following is a brief description of each template:
Program
This template appears at the beginning of the application. It is
included as part of the Program specifications.
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Action
This template is used for each action subroutine that you create. The
BEGACT and ENDACT operation codes for the Calculation
specification are included after the header file.
User

This template is used for each user subroutine that you create. The
BEGSR and ENDSR operation codes for the Calculation specification
are included after the header file.

Help

This template is used for each help file that you create.

To customize the templates:
1. Select the template you wish to customize from the Templates submenu in
the Options menu. The template is displayed in the edit window.
2. Type in any changes, then save the file.
Note: Changes to these files affect the current project as well as all future
projects.

Defining AS/400 Information
If your application accesses data on an AS/400 system, you must define the
AS/400 information. This definition information is stored separately from the
application. Your application refers to this information which corresponds to
the AS/400 data to be accessed.
The following AS/400 information can be defined:
v Server aliases
v File aliases
v Program aliases
v Data area aliases
v Lock level
You define this information by adding it to the Define AS/400 Information
properties notebook. In the properties you can subsequently add to, change or
delete the information you define. Before you can use the Define AS/400
Information properties notebook, you need specific information for each
notebook tab you plan to use. If the notebook tabs do not contain the file alias
name, the program alias name, or the data area alias name, then the following
occurs:
1. The name of the file, program, or data area in the program is used.
2. If the file name, program name, or data area is library qualified in the
program, then this library is used.
3. If the file or program name is not library qualified in the program, the
library list (*LIBL) on the AS/400 server is searched.
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AS/400 Server Aliases
In the VisualAge RPG environment, a server is an AS/400 system that shares
its resources with other workstations. You must define the AS/400 system that
is used if your application accesses data from an AS/400 system.
When defining an AS/400 server, you need the following:
v Server alias name: The alias name used in the Remote Server Table.
v Select the radio button which conforms to the protocol that is running on
your server. VisualAge RPG can support either SNA or TCP/IP
v Remote location name: This name is selected from a drop-down list. The
names available for selection will depend on the servers defined for the
protocol selected. This name is required when adding the server alias. Refer
to Installing VisualAge RPG and CODE/400 for AS/400
v Description: Optional.
Notes:
1. The first entry on the Servers tab is used as a default. You can change the
default by using the Default server check box when defining that server’s
alias. It is then moved to the first entry position.
2. If you are trying to define server alias information for a TCP/IP server, the
server must be defined using the Define TCP/IP servers... menu item.
SNA servers will appear in the SNA protocol list if they have been defined
in Client Access/400.
AS/400 File Aliases
A VisualAge RPG application can use an AS/400 file.
When defining an AS/400 file alias, you need the following:
v File alias name: The alias name used by your application. This is the name
you specified on the File specification in your program source.
v Remote file name: The actual file name that is accessed on the AS/400
system when you run the application. The file name must be entered with
the syntax library/file(member), where library and member are optional. If
library is not specified, *LIBL is assumed. If member is not specified, *FIRST
is assumed.
v Server alias name: The server where the file resides.
v Description: Optional.
Note: You can define as many file aliases as you want.
AS/400 Program Aliases
When you define AS/400 program aliases, you must have the following:
v Program alias name: The alias name used by your application. It is coded in
your program.

40

Getting Started with VisualAge RPG and CODE/400

v Remote program name: The actual program that is accessed on the AS/400
system when you run the application. The program must be entered with
the syntax library/program, where library is optional. If library is not
specified, *LIBL is assumed.
v Server alias name: The server where the program resides.
v Description: Optional.
Note:
v The text of the program alias fields are validated when you enter
data in these fields. If these fields do not exist, you will receive an
error when you run the application.
v You can define as many programs as you want.
AS/400 Data Area Aliases
A VisualAge RPG application can use AS/400 data areas. An AS/400 data
area is a system object used to communicate data between programs. The
system-recognized identifier for the data area is *DTAARA.
When you define AS/400 data area aliases, you must have the following
information:
v Data area alias name: The alias name used by your application. It is coded
in your program.
v Remote data area name: The actual data area that is accessed on the AS/400
system when you run the application. A library name cannot be specified.
The data area must exist in your library list during run time.
v Server alias name: The server where the data area resides.
v Description: Optional.
Note:
v The text of the data area alias fields are validated when you enter
data in these fields. If these fields do not exist, you will receive an
error when you run the application.
v You can define as many data areas as you want.
AS/400 Lock Level
AS/400 lock level is a means of grouping database file operations that allows
the processing of a group of database changes as a single unit through the
AS/400 COMMIT operation code or the removal of a group of database
changes as a single unit through the AS/400 ROLBK operation code.
When defining AS/400 lock level information, you must have the following
information:
v Server alias name: The alias name used by your application. This is the
AS/400 server where a commitment control environment is established.

Chapter 3. An Introduction to the VisualAge RPG and CODE/400 Tools

41

v Lock level: The lock level used by the commitment control environment.
The values for lock level are *ALL, *CHG, *CS, or <NONE>. See the
AS/400 command STRCMTCTL for more information.
v Description: Optional and will only be saved if there is some sort of
commitment control.
Note: Zero or one entry for lock level can be defined.
Adding AS/400 Information Entries
To add AS/400 entries:
1. Select the Define AS/400 information menu item from the Server menu.
2. Select the one of the following tabs:
v Servers
v Files
v Programs
v Data areas
3. Click Add to bring up the Add Alias Name window.
4. Enter the information required, using the Tab key or the mouse to move
through the entry fields.
5. Click Apply to add the information to the properties notebook and
continue working in the window, or click OK to add the information and
exit the window. You can click Clear to clear the entry fields in the
window without eliminating them from the dialog.
6. The information is saved when you exit the dialog.
To
1.
2.
3.
4.

add AS/400 lock level alias information:
Click Lock level.
Select the Server alias name from the drop-down list.
Enter the lock level for the particular server from the drop-down list.
The information is saved when you exit the dialog.

Changing AS/400 Information Entries
To change an AS/400 entry:
1. Click the Define AS/400 information menu item from the Server menu.
2. Select one of the following alias tabs:
v Servers
v Files
v Programs
v Data areas
3. Select the alias entry that you want to change.
4. You can make changes to any of the information in the entry fields, using
the Tab key or the mouse to move between fields.
5. Click Apply to add the changes to the properties notebook and continue
working in the window, or click OK to accept the changes and return to
the properties notebook tab. You can click Clear to clear the entry fields in
the window without eliminating them from the properties notebook.
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6. The information is saved when you exit the properties notebook.
To change AS/400 lock level alias information:
1. Click Lock level.
2. Make any changes, using the Tab key or the mouse to move between entry
fields. You can select from items in the drop-down list if so desired.
3. The information will be saved when you exit the properties notebook.
Deleting AS/400 Information Entries
To delete an AS/400 entry:
1. Click the Define AS/400 information menu item from the Server menu.
2. Click one of the following alias tabs:
v Servers
v Files
v Programs
v Data areas
3. Select the entry you want to delete.
4. Click Delete.
5. Click Yes.
6. The entry is deleted and the information is saved when you exit the
properties notebook.
Note: You cannot delete items on the lock level tab. If you do not want to
enter unique information, you have to select from one of the items in
the drop-down list.

Using Servers with an Application
You must set up your TCP/IP protocol properties, or your Client Access/400
configuration if:
v your application refers to AS/400 database fields when you are building it
v you use the Display File Import function
v you backup and restore your application on an AS/400 system
Logging onto a Server
If you do not define the logon information for a server, you are prompted to
specify the password for logging on to a server the first time your application
accesses an AS/400 server.
Note: If you only define the user name for a server, you are prompted with a
window for logging onto a server the first time your application
accesses an AS/400 server.
Before you can log on to a server, you must have the following information:
v User ID
v Password
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To log on to a server:
1. Type the following information:
v User ID
v Password (the password is not displayed as you type)
2. Click OK to log on to the server.
Customizing AS/400 Server Logon Information for a Workstation
If your application accesses an AS/400 system while you are building or
running it, you can define the server logon information in advance. By doing
this, you avoid entering the server logon information each time your
application accesses an AS/400 system.
Before you can define logon information for a server, you must have the
following information:
v User name: You can only enter one user name per server.
v Password: You can optionally enter the password. If a password for a user
name must be kept secure, you may select not to enter it. In this case, you
will be prompted for the logon password each time you access the user
name on the server.
v Password Required: You can dictate whether or not a password is required
to log on to the server.
v Remote location name: With SNA protocol, the remote location name must
be the Router System name. With TCP/IP the name must refer to a defined
host name or IP address which is recognized by your Domain Name Server.
You specify a value here that you previously defined in the ’Define TCP/IP
Servers’ dialog. Refer to Installing VisualAge RPG and CODE/400 for AS/400 .
Defining AS/400 Server Logon Information: To define the logon information
for a server:
1. Click Server > Define server logon.
2. Click Add from the Define Server Logon dialog.
3. Enter the server logon information.
Note: If you select Password Required and type a password, the server
logon information is not displayed when your application accesses
the AS/400 server.
If you select Password Required and you do not type a password,
the server logon information is displayed when your application
accesses the AS/400 server.
If you do not select Password Required and you do not type a
password, the server logon information is not displayed when your
application accesses the AS/400 server.
4. Click Apply to add the information and continue working in the Add
AS/400 User ID window, or click OK to add the information and exit the
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window. You can click Clear to clear the entry fields in the window
without eliminating the information from the server list.
You must exit the GUI Designer to have the changes you make to the server
logon information take effect. For example, if you select Password Required
and type a password, but do not close the GUI Designer, the server logon
information may still be displayed when your application accesses the AS/400
server.
Changing AS/400 Server Logon Information: To change AS/400 server
logon information:
1. Click the Define server logon menu item from the Server menu.
2. Select the entry you want to change.
3. Click Change from the Define AS/400 User window.
4. Make your changes in the appropriate entry fields.
5. Click Apply to add the changes and continue working in the Change
AS/400 User ID window, or click OK to add the information and exit the
window. You can click Clear to clear the entry fields in the window
without eliminating the information from the server list.
Deleting AS/400 Server Logon Information: To delete the server logon
information:
1. Click the Server > Define server logon.
2. Select the entry you want to delete.
3. Click Delete.
4. Click Yes.

Building Client/Server GUI Applications
You start by designing your application and then build it from the top down.
You first focus on the look and feel of the interface, and then you tie all the
parts together with workstation RPG logic.
VisualAge RPG automatically generates the code to display the GUI you
create. The only code you have to write is the code that handles GUI events.
For example, you have to write an action subroutine to handle the selection of
a menu item by the user. Action subroutines can perform any function that a
regular subroutine can.
All the application development — such as creating the GUI, editing,
compiling, and debugging program logic, and packaging for distribution to
end users — can be performed within the GUI Designer. Writing and testing
your code is simplified by the language-sensitive editor and the debuggers
that are integrated with the VisualAge RPG and CODE/400 development
environment.
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Once you have created the GUI and written the RPG code, you build the
application using the VisualAge RPG compiler.
Even your existing OS/400 applications can be converted to run on a
workstation. Using the Display File Import function, you can import existing
display files and convert them to their graphical equivalents. With some
customizing, you can create a new look for an application that used to display
only on a 5250. At the same time, you are able to reuse existing RPG logic
using the LPEX editor to cut and paste the code into your source.
Now you can build real GUI applications without having to invest time and
money retraining in a whole new language. You can use the strengths of both
AS/400 and the workstation in a client/server environment and build on your
existing RPG skills.

Editing Source Code
This section describes the process you follow to edit source code for your
VisualAge RPG application.
For detailed descriptions of the VisualAge RPG language, see VisualAge RPG
Language Reference.

Editing Specifications
A VisualAge RPG component source file is made up of various specifications:
program, output, and ** (table and array data). These specifications are global
to the component. A component also has a Calculation specification. User
subroutines and action subroutines are coded in the Calculation specification.
Action subroutines are specific to, or shared by, the parts in the application.
For more detailed tips on how to use the editor, see the Editor help menu.
Editing Program Specifications
Program specifications are made up of the following specifications:
H
Control (Header) specifications provide information about program
generation and running of the compiled program.
F
File description specifications define all files in the program.
D
Definition specifications define data used in your program.
I
Input specifications describe record, and fields in the input files and
indicate how the records and fields are used by the program.
C
Calculation specifications describe program logic as well as global
parameter lists.
O
Output specifications describe the record and format of fields in a
program described output file, and when the record is to be written.

|
|

For more information, see VisualAge RPG Language Reference.
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To enter the program specifications:
1. Select Edit source code from the Project menu. The Editor window is
displayed.
2. Select Locate from the Edit menu, then select Program spec from the
submenu.
3. Type the program specifications source code, then save it.
Note: All comments after the program specifications code are not considered
to be part of the program specifications. These comments appear at the
beginning of the first user or action subroutine that you create. In order
to see these comments, you must either:
v Edit the first user or action subroutine
v Scroll through the source till you reach the comments.
Editing Output Specifications
All the output fields that are used by the component are defined in the output
specifications.
To enter the output specifications:
1. Select Edit source code from the Project menu. The Editor window is
displayed.
2. Select Locate from the Edit menu, then select Output spec from the
submenu.
3. Type the output specifications source code, then save it.
Note: All comments after the output specifications code are not considered to
be part of the output specifications. These comments appear at the
beginning of the table and array data. In order to see these comments,
you must either:
v Edit the table and array data
v Scroll through the source until you reach the comments.
Editing Table and Array Data
All of the table and array data used by the program is defined in the **
specifications.
To define the table and array data specifications:
1. Select Edit source code from the Project menu. The Editor window is
displayed.
2. Select Locate from the Edit menu, then select ** spec from the submenu.
3. Type the table and array data specifications source code, then save it.
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Working with User Subroutines
A user subroutine is defined using the operation codes BEGSR and ENDSR. It
can be called anywhere in the component using the operation code EXSR.
Creating User Subroutines
To create a user subroutine:
1. Select Edit user subroutines from the Project menu. The User Subroutine
window is displayed. The Editor window is also displayed.
2. Select Create. NEWUSRSUB is displayed in the list box and the Editor
window is updated with the user subroutine template. The default name
for the user subroutine is NEWUSRSUB.
3. In the Editor window, type your own user subroutine name over
NEWUSERSUB to change the default name, type the user subroutine
source code, then save it.
Deleting User Subroutines
To delete a user subroutine:
1. Select Edit user subroutines from the Project menu. The User Subroutine
window is displayed. The Editor window is also displayed.
2. Select the user subroutine you wish to delete from the list box, then select
Delete. The user subroutine is deleted from the list box and the source
code for the user subroutine is deleted from the Editor window.
Locating User Subroutines
To locate a user subroutine:
1. Select Edit user subroutines from the Project menu. The User Subroutine
window is displayed. The Editor window is also displayed.
2. Select the user subroutine you wish to locate from the list box, then select
Locate. The user subroutine that you selected in displayed in the Editor
window.
Viewing User Subroutines
To view the user subroutines:
1. Select Edit source code from the Project menu. The Editor window is
displayed.
2. Select User subroutines from the View menu.
3. The source code for the user subroutines is displayed in the Editor
window.

Working with Action Subroutines
An action subroutine is logic that you write to process an event. An event is
generated as a result of a change to the state of a part. For example, pressing
a button generates a Press event.
You create an action subroutine using the pop-up menu of a part or using the
Action Subroutine : Events View window.
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Using the Pop-up Menu to Create an Action Subroutine
To define an action subroutine for a window, part, and event using the
pop-up menu:
1. Right mouse click to get the pop-up menu for the part.
2. Select Events.
3. Select an event from the list. The action subroutine template is displayed
in the Edit window with the default name of the action subroutine:
v Factor 1 contains the part name
v Factor 2 contains the event name for the part
v The result field contains the window name
This action subroutine is referred to as Part+Event+Window.
4. Type the action subroutine source code, then save it. The code for the
action subroutine is now linked to the part’s event.
Using the Events View Window to Create an Action Subroutine
To define an action subroutine for a window, part, and event using the Events
View window:
1. Select Edit action subroutines from the Project menu. The Action
Subroutine - Events View window is displayed.
2. Select a window from the Windows list box. A list of parts for the window
is displayed.
3. Select a part from the Parts list box. A list of events for the part is
displayed.
4. Select an event from the Events list box, then select Create. The action
subroutine name is displayed in the Action subroutine list box. Note: An *
precedes both the event you selected and the action subroutine name.
The Editor window is updated with the action subroutine template. The
default name of the action subroutine is:
v Factor 1 contains the part (this is also the name of the action subroutine)
v Factor 2 contains the event for the part
v The result field contains the window
This action subroutine is referred to as Part+Event+Window.
5. Type the action subroutine source code, then save it. The code for the
action subroutine is now linked to the part’s event.
Locating an Action Subroutine
To locate an action subroutine in the source code:
1. Select Edit action subroutines from the Project menu. The Action
Subroutine - Events View window is displayed. The Editor window is also
displayed.
2. Select a window from the Windows list box. A list of parts for the window
is displayed.
3. Select a part from the Parts list box. A list of events for the part is
displayed.
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4. Select an event from the Events list box, then select Locate. The action
subroutine name is displayed in the Action subroutine list box and the
contents of the Editor window are repositioned to the beginning of the
selected action subroutine.
This action subroutine is referred to as Part+Event+Window.
Deleting an Action Subroutine
To delete an action subroutine in the source code:
1. Select Edit action subroutines from the Project menu. The Action
Subroutine - Events View window is displayed. The Editor window is also
displayed.
2. Select a window from the Windows list box. A list of parts for the window
is displayed.
3. Select a part from the Parts list box. A list of events for the part is
displayed.
4. Select an event from the Events list box, then select Delete. A message box
is displayed.
5. If you wish to remove the link, select Yes. The link is removed, the source
code for the action subroutine is deleted from the Editor window, and the
action subroutine is deleted from the Action subroutine list box.
Viewing Action Subroutines
To view an action subroutine:
1. Select Edit source code from the Project menu. The Editor window is
displayed.
2. Select Action subroutines from the Show option on the View pull-down
menu.
3. The source code for all the action subroutines is displayed in the Editor
window.
Reusing Existing Action Subroutines in the Same Component
You can link different events to one action subroutine. Source code that you
have written for this action subroutine can be reused by other part events
throughout one component.
A part can generate different events. Each of these different events can link to
the same action subroutine.
To link a part’s event to an action subroutine:
1. Select Edit action subroutines from the Project menu. The Action
Subroutine - Events View window is displayed. The Editor window is also
displayed.
2. Select a window from the Windows list box. A list of parts for the window
is displayed.
3. Select a part from the Parts list box. A list of events for the part is
displayed.
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4. Select an event (without an * preceding it) from the Events list box,
5. Select an action subroutine from the Action subroutine list box, then select
Create link. The part’s event is linked to the action subroutine that you
selected.
Note: An * precedes both the event you selected and the action subroutine
name. This action subroutine is referred to as Part+Event+Window.
Deleting a Link
To delete the link between a Part+Event+Window and the action subroutine:
1. Select Edit action subroutines from the Project menu. The Action
Subroutine - Events View window is displayed. The Editor window is also
displayed.
2. Select a window from the Windows list box. A list of parts for the window
is displayed.
3. Select a part from the Parts list box. A list of events for the part is
displayed.
4. Select an event from the Events list box, then select Delete link. The * that
precedes both the event and the action subroutine name is deleted. The
code for the action subroutine is no longer linked to the part’s event.
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The CODE Designer
The CODE Designer provides a rich graphical interface that makes it easy to
create, design, and maintain DDS display, printer, and physical files. Each
time you start the CODE Designer, an empty window appears. When you
open a DDS source file, the DDS Tree, Workbook, and Utilities notebook are
displayed on the screen. These panes are separated by vertical and horizontal
dividers which you can resize by dragging the dividers with the mouse.

Figure 13. Viewing a DDS source file in the CODE Designer.

The DDS Tree
On the left-hand side of the CODE Designer window is the DDS Tree. This
view presents the loaded DDS source as a tree structure, showing the
hierarchy of files, records, fields, and keywords in each selected DDS object.
When your program is writing to the display or to the printer, it often uses
multiple records to build a single screen or report. DDS does not remember
associations between records; however, the CODE Designer allows you to
group these records together as a single unit. Groups of records, which
represent the screens or reports you are designing, are shown as peers of the
file in the tree hierarchy.
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Figure 14. Creating a group of records for a DDS screen.

The Group properties notebook allows you to select records from a listbox
and add them to the group. As soon as a group exists, a corresponding
Design page tab with the name of this group appears in the Workbook
(located on the right-hand side of the CODE Designer window).

The Workbook
The Workbook is the working area of the CODE Designer where you design
screens or reports. This page contains the following tabs (from the left):
v
v
v
v

Details page
Design pages (depending on the number of groups in your file)
DDS Source page
Verify Listing page

The Details page provides a detailed view of the DDS objects which are
highlighted in the DDS Tree. Figure 13 on page 52 shows the Details page in
details mode where information about each record, field, or keyword is
displayed in columns.
The Design page contains a group of records which is one screen or report in
your DDS source. On this page, you can design and manipulate your
application’s screens or reports graphically by laying out records and fields in
the design area.
The Design page is made up of the following components:
Design area
Provides the area in which you can layout and construct DDS objects
for the screen or report.
Palette
Contains pushbuttons which allow you to create new records, fields,
and constants directly on the design area.
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Toolbar
Contains pushbuttons which provide quick access to many of the
CODE Designer editing features. This toolbar also displays
information about the currently selected object.

Figure 15. The Design page

The DDS Source page presents the entire DDS source generated by the CODE
Designer. It tokenizes the DDS source, providing a separate color for each
information type. You can work directly with your DDS source definitions.
You can check for syntax errors and verify for semantic errors. Additional
support includes format lines, prompting, auto-uppercasing, and integrated
DDS reference help. This helps to reduce the number of host compilations
necessary to produce the final object.
The last tab in the Workbook is the Verify listing page. This page provides you
with information regarding the correctness of the syntax and the semantic
structure of your DDS code.

Utilities
On the lower-right hand side of the CODE Designer window is the Utilities
notebook. This page contains the following tabs (from the left):
v Selected source page
v Create keywords page
v Comments page
v Error list page
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Figure 16. The Utilities notebook.

The Selected source page displays the generated DDS source for the currently
selected item in the Details or Design pages of the Workbook, or in the DDS
Tree.
The Create keywords page allows you to create file-level, record-level, and
field-level keywords, and obtain context-sensitive help for DDS keywords.
The Comments page displays the DDS comments associated with the selected
item and allows you to modify them.
The Error list page displays any errors found in the DDS source from the
previous source verification.

Launching CODE Designer from Windows Explorer
When you see a CODE-related file in the Windows Explorer (either on a local
disk or through the Integrated File System), you can launch directly into
CODE components.
For DDS Display (DSPF), Printer (PRTF), and Physical (PF) files, the current
default action is to launch the CODE Editor. You can change the default to the
CODE Designer by doing the following:
1. From the Windows Explorer menu, select View > Options.

|

2. In the Options window, select the File Types tab.
3. Among the Registered file types, you will see the following:
v DDS Source File - Display File
v DDS Source File - Print File
v DDS Source File - Physical File
4. Select one of the three file types and click on the Edit push button.
5. To add a new action, in the Edit File Type window, click on the New
push button.
6. In the New Action window, enter CODE design in the Action field, and
enter x:\adtswin\codedsu.exe in the Application used to perform action
field. Replace the x: with the appropriate drive on which VisualAge RPG
and CODE/400 is installed.
7. Click OK.
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8. In the Edit File Type window, select the newly created CODE design
action and click on the Set Default push button.
9. Click OK.
10. Repeat steps 4 through 9 for the other file type.

Working with DDS Source in the CODE Designer
This section shows you how to use the CODE Designer to create a simple
screen with one record and a text constant which is red. This task will help to
familiarize you with the CODE Designer and the basic steps involved in
designing a simple screen.
1. Click on the Start button and then select Programs > VisualAge RPG
and CODE400 > CODE400 Tools > CODE Designer. The CODE
Designer window appears.
2. Select File > New > DSPF. A new file appears in the CODE Designer.
3. Select the group SCREEN1 from the left-side of the window and click on
the right mouse button. A pop-up menu appears.
4. Select Insert record > Subfile. A record appears in the Design page
(located on the right-hand side of the window).
5. Place your cursor anywhere in the design area of the new record and
type Example Screen Title.
6. Select this text and move it to the top of the design area and center it.
You have just created your first text constant.
7. Double-click on this text constant. A properties notebook appears.
8. Click on the Color tab in this notebook.
9. Click on the red icon and press Add. The text constant has been changed
to red in the design area.
10. Close the properties notebook by clicking on the X in the top right-hand
corner.
11. Place your cursor anywhere in the design area of the type $999,999.99.
12. Press F11. The text is converted to a field.
13. Select the Source tab to view the entire DDS source as you would have
had to code it.
14. To exit the CODE Designer, select File > Exit. A prompt appears asking
you to save changes to the file. Click on NO.
|
| The Debuggers
In VisualAge RPG and CODE/400, two debuggers are provided: the IBM
Distributed Debugger and the VisualAge RPG debugger. Use the debuggers to
detect and diagnose errors in your application.

|
|
|
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|

IBM Distributed Debugger

|
|

The IBM Distributed Debugger is the debugger for CODE/400, and is the
debugger for VisualAge RPG on Windows NT.

|
|
|
|
|
|
|
|
|

With CODE/400, you can view source code or compiler listings on the
workstation while the program is running on the AS/400 host to follow the
execution of the program, or quickly identify errors in the application’s logic.
You can set and change breakpoints in the application program, monitor
variables and the callstack, and use watchpoints while the program is
running. You can also debug servlets, JavaServer Pages, and Enterprise
JavaBeans on the AS/400 host, browse source and set breakpoints before
executing the application on the AS/400 host, and attach to a Java Virtual
Machine already running on the AS/400 host.

|
|

With VisualAge RPG, you can debug Java Applications on Windows NT in
addition to the functions provided by the VisualAge RPG debugger.

|
|
|
|
|

Starting the IBM Distributed Debugger from the GUI Designer
Once you have built your application in the GUI Designer, you can start the
IBM Distributed Debugger with one of the following ways:
v Click Project > Debug on the menu bar.
v Click on the Debug push button on the tool bar.

|
|
|
|

Starting the IBM Distributed Debugger from the CODE Editor
If you want to debug an interactive application, start a 5250 emulation session
and connect to the AS/400 host using the STRCODE command before starting
the CODE Editor.

|
|

Note: An emulation session is not required to debug Java interactive
applications.

|
|

While editing the source code of your application in the CODE Editor, you
can start the IBM Distributed Debugger with the following steps:
1. Do one of the following:

|
|
|
|
|

2. The AS/400 host logon dialog appears. Logon to the AS/400 host.
3. When prompted, call your application on the AS/400 host.

|

4. Your application’s source code appears in the debugger’s source pane.

|
|

For more information on using the IBM Distributed Debugger and starting it
from the command line, refer to the online help.

v Click Actions > Debug > No prompt from the menu bar.
v Click on the Debug (no prompt) push button on the tool bar.
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VisualAge RPG Debugger

|
|
|
|
|

You can run your workstation application, set breakpoints, and monitor
variables, registers, the call stack, and storage from the three windows
provided by the debugger. To debug an application, you must select the
debug option on the build options dialog when you build the application.
Starting the VisualAge RPG Debugger from the GUI Designer
Once you have built your application in the GUI Designer, you can start the
VisualAge RPG Debugger with one of the following ways:

|
|
|
|
|

v Click Project > Debug on the menu bar.
v Click on the Debug push button on the tool bar.

|
|

For more detailed information about debugging an application, see
Programming with VisualAge RPG.
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Chapter 4. Creating Client/Server Applications
This section describes a scenario in which you have been asked to create
simple and quick methods for displaying the database and printing a
customer detail from an existing database. The purpose of the scenario is to
show you how to use the components of VisualAge RPG and CODE/400 to
develop a client/server application. The specifications of this application are:
1. Use an existing database on the AS/400 host for information retrieval.
2. Create a graphical interface from which users can interact with the
database. The interface must provide the following capabilities:
v Display a list of customer records from the database.
v Print a customer record in the database.
To achieve the above specifications, you will:
1. Use an existing database to retrieve customer information from the AS/400
host.
2. Create a host program that prints a customer report on the AS/400 host.
3. Use VisualAge RPG’s GUI Designer to design the graphical interface for
this application.
4. Use the VisualAge RPG editor to write the event logic behind the parts
you have selected to include in the GUI. The GUI Designer links the
workstation RPG code to the parts in the window you designed.
5. Build the application.
|
| Using the Database
|
|
|
|
|
|
|

To use the database on your AS/400 host:
1. You must have the correct PTF installed for your version of the AS/400
host. Obtain the CODE/400 AS/400 PTF required for the online tutorial
example at: http://www.ibm.com/software/ad/varpg
2. The files that you will be using are CUSTOML1 and CUSTOMER. You can
find these files in the library ADTSLAB.
Note: Ensure that ADTSLAB is in your library list.
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|

Writing the RPG Host Program
Begin by writing the RPG logic that will run on the AS/400 host. The host
program will perform the following functions:
v Retrieve a customer record from the database.
v Print a summary report of that customer.
This scenario assumes that you have designed a report that will print a
detailed summary for a selected customer. You can use the PRTF support in
the CODE Editor or CODE Designer to help you do this. Refer to the database
for the fields that you can use in the layout of the report. For more
instructions on creating the report, refer to the VisualAge RPG and CODE/400
tutorial.
To write the RPG host logic, use the CODE Editor. To start the editor, click
Start > VisualAge RPG and CODE400 > CODE400 Tools > CODE Editor.
1. Click File > New. The New window opens.
2. Select an RPG source type (RPG or RPGLE). A new edit window opens.
3. Enter the prologue section of the program to indicate program ID,
description, input, output, and field names.
Tip: You can also open an existing RPG source and copy reusable statements
from it.
The content of the format line can vary to reflect the particular specification
lines you choose:
1. Click View > Select format line. The RPG Format Line Selection window
opens. From here, you can select the type of specification you want to
work with.
2. Click C - Calculation. A calculation format line appears at the top of the
edit window as in Figure 17 on page 61.
3. Press Shift+F4 to prompt for a new line.
Type the RPG code according to Figure 17 on page 61.
|
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Figure 17. Using the Editor to Write Host-Based RPG Logic for a Print Function—The RPG Source

|

Verifying, Compiling, and Debugging the RPG Code
At this point, you can use CODE/400 to:
1. Verify the RPG source locally on your workstation by using the
CODE/400 program verifier (Click Actions > Verify Program).
2. Compile the RPG source on the AS/400 (Click Actions > Compile).
3. If you get any run time errors, debug the AS/400 program on your
workstation (Click Actions > Debug).
Note: You must be connected to an AS/400 host and have entered the
STRCODE command to establish a communication link with the host.
Communications setup is described in the Installing VisualAge RPG and
CODE/400 for AS/400 manual.
For hands-on exercises, refer to the task help on how to edit, compile, and
debug an RPG program.
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Verifying the RPG Source
If you select Verify Program, you can check for syntax errors or semantic
errors in the current source, including any copy files or external descriptions.
This checking occurs on your workstation. The program verifier needs the
host only to resolve external references or to retrieve copy files that exist in
the source.
If there are errors, an Error List window lists the errors that are found in the
current program and any copy files (/COPY) used by the program. If you
double-click on an error in the list, the mouse pointer goes to the location of
the error in the source in the editor window.

Compiling the RPG Source
If you select Compile, you can compile the source on the host to create a
program. You can choose to be prompted for the compile options. If you do,
the CODE Program Generator window opens where you can specify or
change compiler options prior to compiling the file.
The default compile action is CRTRPGMOD. For this application, make sure
that you select CRTBNDRPG as the compile action.

Debugging the RPG Program
If you select Debug, the debugger starts. You can set and change breakpoints
in the program, watch for variable value changes, monitor variable values,
and change variable values while the program is running. Breakpoints can be
conditional, based on the value of a variable.
To set, for example, a breakpoint, position the mouse pointer over the prefix
area at the line where you want the breakpoint set. Double-click at that
position. The prefix area indicates that a breakpoint is set.
In the source window, you can use the right mouse button to access a pop-up
menu. The popup menu in the text part of the source window allows you to
manipulate variables. The popup menu in the prefix area allows you to
manipulate breakpoints.
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Designing the Graphical User Interface
At this point, you can start designing the GUI for this small application. This
section describes the steps you need to follow to define the GUI:
1. Start the GUI Designer.
2. Design the window.
3. Save the window.
To start the GUI Designer, click Start > Programs > VisualAge RPG and
CODE400 > VisualAge for RPG > GUI Designer. The GUI Designer’s project
window and parts palette appear. Figure 18 shows the GUI Designer as it
appears before you begin working with it.

Figure 18. The VisualAge RPG GUI Designer

The Parts palette contains parts you can add to the window you are
designing. To select the way in which you use your mouse to add parts:
1. Click Options > Part Creation at the top of the screen.
2. Select Point and click, Point and click with auto off, or Drag and drop
operation.
The default setting is Point and click with auto off which is what we will
use.
To add parts to the design window:
1. Click a part on the palette.
Note: A brief description of each part appears in the information area as
the mouse pointer moves over the parts.
2. Move the pointer over the design window where the part is to be placed.
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3. Click again to place the part on the window.
To change the properties of the window and parts:
Open the Properties notebook for the window in one of the following ways:
v Right-click on the window or icon, select Properties.
v Click the window or icon so that it is active, then press Enter.
v Double-click on the window or icon.
To design the window:
|
|

Change the settings of the window.
1. Change the title of the window to Customer List.

|
|
|
|

2. Name the design window MAIN.
3. If you would like your program interface to have the same background as
your desktop settings, select dialog background under the Style tab in the
Properties notebook.

|

Create the subfile where the customer data can be viewed.
1. Click on the subfile icon and place it on the window.

This creates a subfile so that your user will be able to work with
customers by choosing their names from a list.
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Figure 19. Using point and click to create an instance of an object from the Parts Palette on the
Window you are designing

2. Change the name of the subfile to SFL1.
3. Place a Static Text part from the Parts palette at a point just above the
subfile to label the subfile.
4. Change the text to Customer List.
Add push buttons to print a customer record and close the program.
1. Place two push buttons at suitable locations in your design window.
Tip: Instead of repeating the operation for each individual push button
you want to add to the design window, select the ’sticky button’
check box on the palette to put the mouse pointer on ’sticky’ mode.
Click Options > Part Creation and select point and click. This
ensures that sticky mode continues to be enabled until you deselect
the sticky button. When the pointer is in this mode, you can add
multiple instances of the selected DDS object to the window without
reselecting its push button on the palette.
2. Change the text of the push buttons and name them appropriately.
|
|
|
|
|
|

Add a column to the subfile to display the customer name. To do this, the
VisualAge RPG communication with the AS/400 host must be configured. See
the VisualAge RPG Parts Reference manual for more information. To define the
server logon from VisualAge RPG, see “Using Servers with an Application” on
page 43.
1. Click Server > Define reference fields.

|
|
|

2. Click on the + sign beside your AS/400 host to expand the list of libraries
available.
3. Click to expand the list of files in the library ADTSLAB.
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4. Click to expand the list of formats in the file CUSTOMER.
5. Select the format CUSTOM01. A list of fields appears on the right.
6. Drag the field CUSTNA (Customer Name) to the subfile and click once to
place it on the subfile. See Figure 20.

|
|
|
|
|

Figure 20. Adding a Column to the Subfile to Display Customer Name

Use the GUI Designer to align the various parts in your window, or to
automatically adjust their size or spacing.

|

See the VisualAge RPG tutorial to learn more about how to align, size, and
space parts in your design window. For more information about VisualAge
RPG parts, part attributes, part events, and event attributes, see the VisualAge
RPG Parts Reference.
Once you have finished designing your window, it should look like Figure 21
on page 67.
|
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Figure 21. Graphical Interface Created in the GUI Designer

|

Save your application.
1. Click Project > Save as. The Save as Application — VisualAge RPG
window appears, as shown in Figure 22.
2. Type Customer Application in the Application name field.
In the Source File and Source Directory fields, you can accept the
defaults, or change them. The text that is entered in the Source File field
determines the names of the files VisualAge RPG creates.
3. Click OK to save.

Figure 22. Saving a New VisualAge RPG Application

The next step is to write the event logic to handle the appropriate events that
will occur.
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Writing the Workstation RPG Event Logic
|
|
|

You must define the file that you want to use from the AS/400 host in
VisualAge RPG. Your server must be defined before you continue. See
“AS/400 Server Aliases” on page 40.

|
|
|
|

To
1.
2.
3.

|
|
|

4. Type the appropriate information for File alias, Remote file and Server
alias. It should look like Figure 23.
5. Click OK to save your changes.

define the file:
Click Server > Define AS/400 Information.
Select the File tab.
Click Add.

|

Figure 23. Adding a File Alias to the AS/400 Information

|
|
|

Type the prologue and file definition in the RPG logic:
1. Click Project > Edit source code to start the editor.
2. Click Edit > Locate > Program spec.

|
|
|
|
|
|

3. Type the prologue section for the workstation RPG source.
4. Define the database file to use to fill the subfile file. The file specification
must come before any C specifications and any H specifications. The
definition should look like Figure 24 on page 69 if your file alias is
Customer. You can also press F4 after typing F on line 23 to enter the
information.

|
|

5. Click File > Save.
6. Click File > Close to close the editor.

|

68

Getting Started with VisualAge RPG and CODE/400

Figure 24. Defining the File Customer

|

Define an action subroutine for the window to read information from your
database when the program is started.
1. Right-click on the window.
2. Click Events > CREATE.
3. Write the RPG logic for the Create event.
Figure 25 shows the RPG logic needed for your program to read your
database and display the customer name in the subfile. The Begin Action
Subroutine (BEGACT) and the End Action Subroutine (ENDACT) are created
for you.

|

Figure 25. RPG Logic for Reading and Displaying Customer Name

|

Now you are ready to write the workstation RPG event logic for the parts on
the window you designed.
Define an action subroutine for the push button that ends the program:
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1. Right-click on the push button Close in the window you are designing. A
pop-up menu appears.
2. Click Events > PRESS. The editor appears.
3. Write RPG logic for the Press event.
Figure 26 shows the line of RPG you need to add to end the program
when a user clicks the Close push button.
4. When you have finished writing the action subroutine, save your work.
|

Figure 26. RPG Logic for Closing a Window

Define an action subroutine for the push button that prints the customer
record. Repeat similar steps used to define the subroutine for the close push
button. The RPG logic for the print function should look like Figure 27 on
page 71.

|

|
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Figure 27. RPG Logic for Printing a Customer Record

|
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Testing an Application
To test a client/server application from the VisualAge RPG GUI Designer:
1. Click Project from the menu bar. Click Build, and then click Windows
NT/95/98 or Java.
2. Click Project > Run.
All the required files will be compiled and then linked to from an executable
file (.EXE) for the application. The executable file has the name that was
entered in the Source File field in the VisualAge RPG Save as Application
dialog. The file name defaults to the first eight characters of the application’s
name, but you can enter any name in the Source File field.
You can then run the application from within the VisualAge RPG
environment. Establishing communication with the AS/400 host becomes
necessary if the application requires any externally described files.
For details on performing these two tasks, see Programming with VisualAge
RPG.
Your program should look like Figure 28 when you run it.
|

Figure 28. Graphical Interface

|
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Advanced Topics for VARPG
This section will briefly discuss the following topic:
v Online Help
Refer to Programming with VisualAge RPG for more detailed information about
this topic.

Creating Online Help
You can create general help for your application, as well as contextual help for
specific parts. To see the latter, the user gives the desired part focus, and then
presses F1. The following section describes how to write contextual help.
Refer to the ’Programming with VisualAge RPG’ guide for information
regarding application help.
To
1.
2.
3.

add online help to your application:
Display the part’s pop-up menu.
Select Help text. The editor is launched.
Type the contextual help text for the part. Tag the help text using the
Information Presentation Facility’s (IPF) tag language.
4. Save the help by clicking File > Save.
The help file is updated by VisualAge RPG whenever you edit the contextual
help using a part’s pop-up menu. It is recommended that you use the pop-up
to make changes to the help because the format of the file must be preserved.
However, if you absolutely must edit this file, simple text editing using any
compatible editor is acceptable as long as you ensure that you DO NOT:
v Modify or remove the resource id (resid) keyword.
v Remove the heading information.
For Windows, at build time, the IPF file is converted to an RTF file and is
compiled into a contextual help file with a file extension of .HLP.
For more information on IPF, see the Information Presentation Facility Reference
in VisualAge RPG folder. Also, refer to Programming with VisualAge RPG for
tips about creating IPF help and for reusing help source from an AS/400
system.
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Chapter 5. VisualAge RPG and CODE/400 Java Support
We have added support for editing, compiling, and debugging local and
AS/400 Java programs. This support complements the use of such tools as
IBM’s VisualAge for Java (see http://www.ibm.com/software/ad/vajava) and
assumes that you already have the Java 2 Software Development Kit,
Standard Edition (J2SDK), v 1.2 or later from JavaSoft installed on your
workstation. You can download the J2SDK by following the links from The
Source for Java Technology Web page at http://www.javasoft.com/. In addition,
IBM has published a book entitled Java for the RPG Programmers which you
may find useful. For those with Internet access, this book can be ordered at:
http://www.advice.com/ibm
Note: OS/400 Java support is part of Version 4 Release 2, or later.

Java with CODE/400
CODE/400 support for Java includes the following:
Editor
Parsing:
Editing local .java source files, with token highlighting and some Java
syntax checking (for example, missing comment or string delimiters).
Help

Pressing F1 while editing Java takes you to the appropriate
J2SDK or language reference help. From the Java Help menu
under the Help pulldown you can get help on specific classes
or the language reference. You will need to download the
J2SDK HTML documentation to use it in conjunction with the
CODE Editor. This help is also available from the Help
pulldown.
Note: The first time you use this, you will get a dialog box
where you should enter the docs/api directory where
the J2SDK help is and click Load all.

Actions Pull down:
The following menu items are available from the Actions pull down
when editing Java source:
Compile Local
Runs the javac compiler on your workstation from your locally
installed Java 2 Software Development Kit. Compilation errors are
presented in the Error List window. Successful compilation
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produces a .class bytecode file in the same directory where your
source file resides. To get the javac compile options, click Actions
> Compile > Local with prompt. To target your Java program for
use on the AS/400 system, keep your source file in an AS/400 IFS
directory that can be accessed as a mapped network drive. (Client
Access provides the necessary mapped network drive support.)
You can access the file as a local file with the CODE Editor.
Alternatively, always keep a local copy and use Actions > Export
to copy the .class and .java files to the AS/400 IFS (no Client
Access required).
Run Local
Runs your current class from its main method using your local
J2SDK. The output is logged in the command shell.
Debug Local
Debugs your local Java class that is currently open in the editor.
Note: Requires VisualAge for Java 2.0, Enterprise Edition or
higher.
Create Program Remote
Runs the AS/400 command CRTJVAPGM (Create Java Program)
available since V4R2. This command statically compiles a .class
file from the IFS and creates a direct execution program that will
run much faster. This menu item assumes the .class file has the
same name as the .java file you are currently editing, and that the
.class file exists in the IFS.
Run Program Remote
Invokes the AS/400 command RUNJVA (Run Java Program)
available since V4R2 to run your Java program on the AS/400.
This menu item assumes the .class file has the same name as its
.java file version, and that the .class file exists in the IFS accessed
as a mapped network drive.
Debug Remote
Runs the CODE Debugger on the AS/400 Java class. It does not
support debugging local Java programs. This menu item assumes
the .class file has the same name as its .java file version, and that
the file exists in the IFS accessed with the classpath specified in
the Debugger Settings dialog box. The dialog box is accessed from
the Advanced button in the Load Program dialog.

|
|
|
|
|
|

Export to AS/400
Exports local java classes to the AS/400 IFS for running there. You
would normally use this to copy both the .java and .class files to
your IFS directory after compiling and testing them locally.
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Macro support:
You can now write editor macros in Java! This gives you a free and
popular interpreted language with great user interface capabilities, in
addition to the existing REXX support. See the CODE Project
Organizer section for more information. If you write some great Java
editor extensions, you can share them with the rest of the CODE/400
community by posting them to our web site.
Program Generator
Support has been added for running a local JAVAC command on .java source
files and the OS/400 commands CRTJVAPGM (Create Java Program) and
RUNJVA (Run Java Program) available since V4R2. The OS/400 commands
assume that the java .class file exists in the AS/400 IFS. All commands are
accessible from the editor’s Actions pull down when editing java source.
CODE Debugger
Support has been added to debug AS/400 Java programs. Your AS/400
system must be running V4R2 OS/400, or higher. This support includes the
ability to debug threaded Java applications. The Distributed Debugger is also
available as part of the VisualAge for Java Enterprise Edition product, at the
1.01 level or higher.
CODE Project Organizer
New actions have been added for .java (edit, compile, compile with Error List
feedback, and javadoc) and .class files (debug, run local, run remote). Actions
have been added for invoking the J2SDK jar (Java Archive) command on
selected files, and for dearchiving and listing files in a java archive (.jar) file.
As well, there is a Show JAVA Class Hierarchy action for .java and .class files
that displays the parent class hierarchy for the class. Several of the Java
actions and macros have been integrated into the product. For more
information see the README in the ADTSWIN\JAVA\SRC subdirectory.
|
|
|
|
|
|
|
|

In the ADTSWIN\JAVA subdirectory, you will find a classes.jar, sample.jar,
and README file. Follow the instructions in the README or go to the help
section″Welcome to Java″ to find instructions on how to expand the sample.jar
and src.jar. You will now have sample .java files and associated
documentation in the ADTSWIN\JAVA\SRC subdirectory. These are offered
to you as sample java code for:
v Writing Java commands that can be invoked from the CODE Project
Organizer, such as JarUp.java
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|
|
|

v Writing LPEX macros in Java by writing code which extends the
LpexCommand class. This class is documented in the LpexCommand.html
file, and example .java source, like CodeToolbar.java.

|
|
|
|

Use this source code and documentation to help you tailor existing actions or
write your own Java actions for the CODE Project Organizer, or write new
LPEX macros in Java. As well, there are a number of supplied helper classes
that you may find useful in general.
Toolbox
We now ship the AS/400 Toolbox for Java classes and documentation. To
view the documentation go to the help section:″AS/400 Toolbox for Java″.

|
|

VisualAge RPG with Java Quick Start
The following sections show you how to use the VisualAge RPG GUI
Designer to create a simple application, create and activate an applet, and
enable your Web browser to run applets.

Creating a VisualAge RPG - Java Application
This section shows you how to use the VisualAge RPG GUI Designer to create
a simple window with a push button that changes color when pressed. This
task will help to familiarize you with the GUI Designer, the new Java support,
and the basic steps involved in designing, building, and running a simple
Java application.
1. Locate the VisualAge for RPG Projects folder on your desktop.
Double–click on this folder. The x:\ADTSWIN\PROJECTS window
appears. (The x:\ADTSWIN\ in the title bar shows the directory where
the VisualAge RPG and CODE/400 product is installed.)
2. Double-click on the Samples folder. The
x:\ADTSWIN\PROJECTS\VARPG PROJECTS\SAMPLES window
appears.
3. Right-click on any project folder and then select Edit with prompt.
4. In the Prompt window, click Create new project.
A status window appears showing the progress of the VisualAge RPG
GUI Designer initialization. When initialization is completed, the GUI
Designer displays the following windows:
v The Project View (Untitled– VisualAge for RPG)
v The Parts Palette
v The Design window (Window with canvas)
5. If necessary, rearrange the windows so they are all visible. Position the
mouse pointer over the title bar of the window you need to move. Press
and hold the left mouse button and drag the window to a different
position on the desktop.
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6. Resize the Parts Palette so that all part icons are visible. Move the mouse
pointer over the top right-hand corner of the window until you see a
double arrow (<–>). Press and hold the left mouse button. Drag the
mouse to resize the window.
7. Double-click the title bar of the design window. The Window Part
Properties notebook appears.
8. On the General tab, change the Title property to Change Push Button
Color.
9. Click OK to close the notebook and save your change. The title bar on
the design window now shows the new title.
10. Position the mouse pointer over the Push Button icon in the Parts Palette.
(The information area at the bottom displays a short description of the
part when you move the mouse pointer over its icon.)
11. Click the mouse. Move the mouse pointer to the center of the design
window. Click again. The Push Button part appears on the design
window.
You can reposition the Push Button part in the design window. To do
this, move the mouse pointer over the part, press and hold the left mouse
button, and drag the part to where you want it placed. Release the mouse
button.
You can resize the Push Button part, as well. Move the mouse pointer
over a sizing handle until you see a double arrow (<–>). A sizing handle
appears as a small box in the part’s outline. Press and hold the left mouse
button and drag the part’s outline to the desired size.
12. Double-click on the Push Button part.
13. On the General tab of the Push Button Part Properties notebook:
v Change the Part name to PSB01.
v Change the Label to PRESS ME.
14. Click OK to close the notebook and save your changes. The new label,
PRESS ME, now appears on the Push Button part.
15. Position the mouse pointer on the Push Button part and right-click the
mouse.
16. Click Events > PRESS. The VisualAge RPG editor appears with the
BEGACT and ENDACT operation codes already inserted in the action
subroutine.
*.. 1 ...+... 2 ...+... 3 ...+... 4 ...+... 5 ...+... 6 ...+... 7 ...+.
CSRN01Factor1+++++++Opcode(E)+Factor2+++++++Result++++++++Len++D+HiLoEq
*
C
PSB01
BEGACT
PRESS
FRA000000B
C
ENDACT

GUI applications are event-driven. An event can be linked to an action
subroutine, which begins with the BEGACT operation code and ends
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with the ENDACT operation code. The program logic between these two
statements is executed when the event is generated.
17. Position the mouse pointer anywhere on the line with the BEGACT
operation code.
18. From the editor menu bar, click Edit > Insert prompt. The C specification
prompt appears.
19. Add the following VisualAge RPG statements, one at a time, to complete
the application logic for the PRESS event. Use the Tab key to move from
one field to the next in the prompt. After you type a statement in the
prompt, click OK to add the line of code to your source.
*.. 1 ...+... 2 ...+... 3 ...+... 4 ...+... 5 ...+... 6 ...+... 7 ...+.
CSRN01Factor1+++++++Opcode(E)+Factor2+++++++Result++++++++Len++D+HiLoEq
*
C
PSB01
BEGACT
PRESS
FRA000000B
C
'PSB01'
GETATR
'BACKCOLOR'
BCOLOR
2 0
C
BCOLOR
IFNE
*RED
C
'PSB01'
SETATR
*RED
'BACKCOLOR'
C
ELSE
C
'PSB01'
SETATR
*GREEN
'BACKCOLOR'
C
ENDIF
C
ENDACT

After you enter the last statement in your source, click Cancel on the
Prompt window. This ends prompting.
20. From the editor menu bar, click File > Save. Close the editor window.
21. From the Project window menu bar, click Project > Build > Java. The
Save project – VisualAge RPG window appears.
22. Click Save. The Save As Application window appears.
23. Type the name psbcolor in the Application name field and press the Tab
key. Notice that the remaining fields are prefilled.
24. Click OK. The Build (Java) window appears showing the progress of
your build.
25. After completion, an information window appears with a Build
completed message. Click OK .
26. From the Project window menu bar, click Project > Run > Java. Your
window appears on the desktop.
27. Click PRESS ME several times to see its color change. Close this window.
28. Close the GUI Designer.
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Creating the Applet
1. Use the GUI Designer to create an application. (See “Creating a VisualAge
RPG - Java Application” on page 78.) When you build the Java source for
the application, the following files are created in the RT_JAVA directory of
your project’s source directory:
v *.CLASS
v *.RST
v *.ODX
v *Resources.properties (if you defined messages for the application)
where * represents the name of your application.
2. Copy the project’s *.CLASS, *.RST, *.ODX, *Resources.properties, and any
required graphics (GIFs, JPGs) files to your Web server. Or, package these
files together into a single jar file with the J2SDK jar tool and move the jar
package file to the server.
Note: Java file names are case sensitive. Make sure that all file names
(including graphics files) specified in the source code are exactly the
same case as the actual files on the Web server. This applies to both
the file name and extension.
3. To run VisualAge RPG Java applications, you will also need a copy of the
varpg.jar and varpgtb.jar files on your Web server. (These jar files are
located in the directory where you installed the VisualAge RPG and
CODE/400 product. For example, if you installed the product on your x
drive, these files will be in the x:\ADTSWIN\JAVA directory.)
4. To activate your applet from your server’s Web page, create an applet tag
in the HTML source. Code the attribute values for the applet tag as
follows:
archive
Specify the VisualAge RPG jar files (varpg.jar, varpgtb.jar) and,
optionally, the jar file created for your applet.
code
″VisualAgeRPG.class″
param
Specify name=″Component″. Value contains the name of the applet’s
class file name without the class extension.
For example, if your applet name is PSBCOLOR and you packaged the
VisualAge RPG files into a jar file called PSBCOLOR, the applet tag coding
would be:
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<applet archive="PSBCOLOR.jar , varpg.jar , varpgtb.jar"
code="VisualAgeRPG.class"
width=700 height=340>
<param name="Component" value="PSBCOLOR">
<p>Sorry, your browser does not support Java applets.</p>
</applet>

Enabling the Browser
Netscape Navigator and Microsoft’s Internet Explorer do not currently
support the same level of the J2SDK that VisualAge RPG uses. As such,
applets created with the VisualAge RPG GUI Designer will not run directly
with these browsers. To run VisualAge RPG applets in either of these
browsers, you need to install the Java Plug-in 1.1.1 and HTML Converter
available from JavaSoft. You can download these by following the links from
The Source for Java Technology Web page at: http://www.javasoft.com/
Use the HTML Converter to convert the HTML page with your applet tag so
it can use the Java Plug-in. The conversion creates an object tag that tells the
Web browser to use the Java Plug-in instead of its own Java runtime
environment.
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Chapter 6. Managing VisualAge RPG and CODE/400
Projects
There are several ways to keep track of your application source and related
materials.

What are Projects?
The term project has slightly different meanings, depending on its context. In
general, projects let you organize the pieces of your application and assign
actions to individual pieces or the entire project.
Application Development Manager Project
In the Application Development Manager environment, an application
is called a project. A project consists of all the application’s related
components, regardless of the phase of development they are in.
CODE/400 Project
In CODE/400, the Project Organizer is a shell which you can use to
enhance your use of the product. A project in this context is basically
a ″fastpath″ to lists of local, remote, and Application Development
Manager entities.
VisualAge RPG Project
In VisualAge RPG, the Project Organizer provides a container view of
all files in a VisualAge RPG application. Such a view is called a
project.
The Application Development Manager product is a change control
environment that also offers version control, automated builds (based on
deltas), problem tracking, and a distribution solution for host parts.
You can harness the power of Application Development Manager by using
CODE/400. All the CODE/400 tools are Application Development
Manager-aware.
You can store VisualAge RPG source as ADM parts, because ADM offers part
types specific to VisualAge RPG.
More information about how you can use VisualAge RPG and CODE/400
with Application Development Manager is available in the ADTS/400:
Application Development Manager User’s Guide.

© Copyright IBM Corp. 1994, 2000

83

Why Use Application Development Manager?
In the new world of ILE and workstation development, Application
Development Manager is important because it allows you to take control of
complex projects.
Building ILE applications
Creating ILE applications can be complex since there are sometimes
many source parts to manage. Application Development Manager lets
you rebuild your entire application with a single command.
Workstation-based development
When you are signed on to an AS/400 and editing a part that shared
with other developers on your team, you usually lock it. The lock
goes away when you sign off the AS/400. With Application
Development Manager, you check out the part, leaving it locked even
when you’re signed off. This becomes especially important for
workstation-based development. You can check out parts, take them
home or on the road, and check them back in when you return.

CODE/400 and Application Development Manager
The CODE/400 Project Organizer allows you to list Application Development
Manager projects, groups, and parts, and perform all ADM commands as
actions. The actions appear on a pop-up menu when you click mouse button
2. This effectively offers a workstation-based user interface to all the function
of Application Development Manager.
The Open dialog, as well as most of the CODE/400 application is Application
Development Manager-aware. To open an ADM source part for editing,
simply choose the ADM server and then traverse the part hierarchy. Unlike
SEU, the CODE/400 editor knows when it is editing an Application
Development Manager part. For example, the ADM part name shows in the
title bar (as opposed to the underlying native name), and the compile action
issues the ADM build command (as opposed to the CRTxxx commands).
Check-out of the parts occurs automatically when you edit.
The program verifiers can also operate directly on ADM source parts.
The Program Generator has facilities for building ADM parts and applications.
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Managing CODE/400 Projects
The CODE/400 Project Organizer lets you organize your work, and access the
tools in VisualAge RPG and CODE/400 through objects in your project.
To introduce you to the CODE Project Organizer, we’ll briefly cover the
following tasks:
v Creating a new project
v Adding files to your project
v Creating or modifying actions

Creating a New Project
Open the CODE Projects folder and select the ″new″ project. Double-click to
open it, then enter the name of your new project in the entry field of the New
Project window.
The next window to appear is the Project Setup window. This is accessible at
any time from the Project menu.

Adding Files to a Project
Since a project is a way of organizing your work, you may or may not have
existing files to work with. Filters are the key to getting your files into the
project.
Add new filters by selecting Add from the Filter menu. There are filters for
libraries, objects, members, and ADM projects, groups and parts.

Creating or Modifying Actions
At any filter level you can create or modify actions.
Project-level actions often apply to the way you work, or the environment in
which your application runs. From the Actions cascade on the Project menu,
you get a set of standard project-level actions.
Actions for filter levels below the project are available by right-clicking on an
item in the right-hand pane of the Project display.
To create or modify your own actions, click Actions from the Options menu.
The CODE Actions window contains a notebook that has all the levels of
actions you can create or modify. You need to know what command your
action will run, as well as what substitution variables are required in place of
that command’s parameters.
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Working with RPG Source in the CODE Project Organizer
This section shows you how to use the CODE Project Organizer to create
filters. This task will help you locate and open an OPM RPG file on your
system and then convert it in the CODE editor to ILE RPG source.
1. Locate the CODE Projects folder on your desktop. Double-click on this
folder. The CODE Projects window appears.
2. Double-click on new project.
3. When prompted, give the following project name Tour.
4. Click OK. The Project Setup notebook appears and click OK again.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.

Expand the Add Filter list by clicking on the plus sign (+).
Select the Local... file folder. The Add File Filter dialog appears.
Type sample* in the File Filter drop-down combo-box.
Specify x:\ADTSWIN in the Subdirectory field. Where x:\ is the drive to
which the product is installed.
Click OK. A filter is created displaying all the sample files available.
Double-click on the file sample.rpg.
Click OK in the confirmation window. The CODE editor appears
containing the RPG source file.
Click Actions > Convert RPG Source > Convert file. The RPG source is
converted to ILE RPG source.
Position the cursor in the C specification on line 8 and press F4 to display
the Prompt dialog.
Click the Move operator field and press Help to get context-sensitive
help for the Move keyword.
Click Cancel to close this dialog.

16. Click Actions > Verify program > No prompt. The Error List window
appears with errors.
17. Double-click on the first error message. This message appears in your
RPG source.
18. Click Actions > Delete messages to remove the error messages from
view.
19. Click File > Exit. A prompt appears asking you to save changes to the
file. Click NO.
Check the online help for more details about how to manage your work with
the CODE Project Organizer.
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The VARPG Application Development Environment
The VisualAge RPG application development environment is based on a
graphical user interface project organizer. The Project Organizer allows you to
find your project files and work with them.
In this interface, your application is organized into projects. A project
represents the complete set of objects (source code files, GUI objects, etc.) that
you need to build a single target program, such as a dynamic link library
(DLL) or executable file (EXE).
Associated with each project is a set of actions. In this environment, an action
is a description of a tool or a function of a tool that you can use to manipulate
a project. Edit, build, and debug are examples of actions.
You can organize complex applications into project hierarchies to give you a
visual perspective of how your application is organized. You can perform a
build from any point in a project hierarchy, giving you added control over the
way you build your applications.
Tools such as an editor and a debugger are integrated into this environment
so that you have quick and easy access to them as your program.

Project Organizer Help
You can get help on how to use any menu choice, window, or control. You
can access this context-sensitive help by pressing F1 when a field, menu item,
or control is in focus. You can also press the Help push button, where
available.

Managing VisualAge RPG Projects
VisualAge RPG’s Project Organizer stores and manages your project files. It
uses a project folder to organize the applications and components you create.
A VisualAge RPG project is basically a ″virtual folder″. The project contains all
the information required by the GUI Designer. Every VisualAge RPG project
must be specified as either an application or a component when it is created.
If a project is specified as an application, a .DLL and an .EXE are created. If a
project is specified as a component, only a .DLL is created. Components may
be created within applications. Every project has a primary file with extension
.IVG. All of your project’s source files are stored in the source directory you
specify. This group of files makes up a VisualAge RPG project.
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Sample Project Structure
Suppose you created a new application with the name Payroll and put it in
the VisualAge RPG Project folder.
The Project Organizer:
v Creates a project named Payroll and places it in your VisualAge RPG
project folder.
v Creates a file with a name similar to \PROJECTS\VARPG\PAYROLL.IVG.
Suppose you added a new component with the name Employee and put it in
the Payroll project.
The Project Organizer:
v Creates a project named Employee and places it in the Payroll project.
v Creates a file EMPLOYEE.IVG and places it in the source directory of the
Payroll project. If your project had d:\PAYROLL as the source directory; a
file with a name similar to d:\PAYROLL\VARPG\EMPLOYEE.IVG is
created.
The Project Organizer provides many different features to help you work with
your projects. One of these features is actions.
An action is a description of a tool or a function that can be used to
manipulate a project’s parts. Examples of actions are build, and edit. Actions
can be performed from the pop-up menu of a project, or from the Project
pull-down menu of the Project Organizer. The following list contains valid
actions for VisualAge RPG projects.
Edit

Edit with Prompt

Duplicate

Move

Rename

Delete

Backup

Check-in

Check-out

Extract

Restore

Package

Build Windows
NT/95/98

Run Windows
NT/95/98

Build Java

Run Java

Debug

Browse compile listing
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Creating a New Project
To
1.
2.
3.
4.
5.

6.
7.

create a new project:
Select Save as from the Project menu in the GUI Designer.
The Save as window displays.
Select New application for an application project, or select New
component for a component project.
Enter the full name of the project in the Application name or Component
name field.
Indicate in which folder or project you want to create the new GUI
Designer project. You can use Find to search for a folder or project. Once
you select a folder or project, the Target folder or project field indicates
the path name of that folder or project.
In the Source file field, indicate the file name you want assigned by the
GUI Designer for all of your project files.
In the Source directory field, indicate the drive and path where you want
the GUI Designer to store the files it creates.

Note: The GUI Designer initially creates six files using the source file
name and adds file extensions to differentiate their use. Do not
remove or rename any of these files. Do not create or add files with
these names in the target directory.
8. Click OK.
A project with the application name you specified is created in the target
folder or project you specified. All source files are created in the source
directory you specified. Subdirectories named RT_WIN32 and RT_JAVA are
created in the source directory. These directories are where objects are placed
when the project is compiled by the GUI Designer.
The properties for the project are:
v The source directory is the directory and path you specified.
v The target program is filename.EXE for a new application, or is filename.DLL
for a new component. Do not change this property since the GUI Designer
uses this to determine the file naming convention for the project. For
information on changing these properties, click Help from the pop-up
menu of the project folder.

Starting the VisualAge RPG GUI Designer with a New Project
To start the VisualAge RPG GUI designer with a new project:
1. Click Start > Programs > VisualAge RPG and CODE400 > VisualAge for
RPG > GUI Designer.
A status window appears showing you the progress of the VisualAge RPG
GUI Designer initialization process. When complete, the VisualAge RPG
project window and the parts palette are displayed, along with an empty
design window.
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Renaming a Project
Use the VisualAge RPG Rename action to rename a project.
Note: Follow the steps below closely. Do not confuse this action with
renaming Windows objects. The VisualAge RPG Rename action can
rename all files and directories associated with a project. Renaming a
Windows object only renames the selected object.
To rename a project:
1. Display the pop-up menu for the project you want to rename by pressing
mouse button 2.
2. Select Rename project from the pop-up menu. The Rename Component
window opens.
3. Enter the new name of the project in the Title field.
4. Enter the new file name in the File field.
5. Enter the new directory name in the Source subdirectory field.
6. Select Rename. The project is renamed according to the values entered.

Duplicating a Project
Use the VisualAge RPG Duplicate action to duplicate a project and its files in
a new directory.
Note: Follow the steps below closely. Do not confuse this action with the
Windows copy function. The VisualAge RPG Duplicate action copies all
files and directories associated with a project. The Windows copy
function only copies the selected object.
To duplicate a project:
1. Display the pop-up menu for the project you want to duplicate by
pressing mouse button 2.
2. Select Duplicate project from the pop-up menu. The Duplicate window
opens.
3. Select New application for an application project, or select New
component for a component project.
4. Enter the full name of the project in the Application name or Component
name field.
5. To rename the files for the new (duplicated) project enter the new file
name in the Filename field.
6. Indicate which folder you want to create the new GUI Designer project.
You can use Find to search for a folder or project. Once you select a folder
or project, the Target folder or project field indicates the path name of
that folder or project.
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Note: All of the folders and projects that are on the desktop are listed in
the Folders or Projects on Desktop list box. If you want to create
your application in a folder or project that is not on the desktop,
select Find.
7. In the Source directory entry field, indicate the drive and path where you
want the GUI Designer to store the files it duplicates.
8. Select Duplicate. The project is duplicated.
Note: If the project you are duplicating uses files in directories other than
those created by the GUI Designer, you are prompted to select which
directories to add to the new project. Non-GUI Designer directories are
not duplicated.
If there are other projects within the project that you chose to duplicate, a
warning message is displayed stating that there are projects inside this project
and that those projects will NOT be duplicated.

Deleting a Project
Use the VisualAge RPG Delete action to delete a project; including its files,
source, and target directories.
Note: Follow the steps below closely. Do not confuse this action with the
system delete function. The VisualAge RPG Delete action deletes all
files and directories associated with a project. The system delete
function only deletes the selected object.
To delete a project:
1. Display the pop-up menu for the project you want to delete by pressing
mouse button 2.
2. Select Delete project from the pop-up menu.
You are prompted to confirm that you want to delete the project. All files in
the source directory are deleted, then the project file itself is deleted. If the
project contains files in subdirectories, those files are deleted. If there is a
project inside the project you choose to delete, that project is not deleted, and
the source directory that contains that project is not removed.
To delete a project click Start > Programs > VisualAge RPG and CODE400 >
VisualAge for RPG > Delete Utility. You can choose the project you want to
delete in the window that appears.
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Building an Application
Once you have created the GUI and written all the logic and other
information, you can build (compile) your project.
Note: In order for VisualAge RPG to find all of the files used in your
application and its components, we recommend that you move them to
the RT_WIN32 or RT_JAVA subdirectory prior to performing a build.
Some of the types of files you may be using are:
v Icon files
v Bitmap files
v Sound files
v .DLL files
v .EXE files
To build the current project, select Build > Windows NT/95/98 or Build >
Java in the Project menu of the GUI Designer.
During the build process, the GUI Designer generates files used at run time.
The files are stored in the RT_WIN32 (for Windows NT/95/98builds) or
RT_JAVA (for Java builds) subdirectory. As well, all of the files from these
subdirectories (including any you have placed there) are copied into the
\install root directory\TEST.
The following files are created:
filename.odx
Contains the execution version of the ODF. Do not edit this file.
filename.dll
If the project you built is a component, this file is created. Do not edit
this file.
filename.hlp
Contains the help file. Do not edit this file.
filename.exe
If the project you built is an application, this file is created. Do not
edit this file.
filename.txm
Contains the message file. Do not edit this file.
Other files created as part of the build process include:
filename.lst
Contains the listing from the compilation.
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filename.rc
Contains a resource file.
Note: Depending on the compiler options you specify, you might get more or
fewer files than the ones listed above.
You can now run or debug your application.
To terminate the build process before it has completed, select the Stop button
on the Build dialog.
For information about the Build Options Properties Notebook, and all of the
options available, refer to the online help.

Running an Application
The GUI Designer run function allows you to run an application, once it has
been built. Use it to test all of the runtime aspects of a project before
packaging.
The \TEST directory is a repository for all files you build for testing
purposes. The files remain in this directory until you overwrite them in
subsequent builds or until you delete them explicitly. It is recommended that
you periodically delete files from this directory to conserve disk space.
Ensure that no file names are duplicated in the projects that you are testing. If
there are duplicate names, the file in the latest build overwrites any file with
the same name in a previous one.
To run an application:
v Using the Project window from the GUI Designer:
1. Ensure that all of the files used by the project and all of its components
are in the RT_WIN32 or RT_JAVA directory.
2. Open the project of the application in the GUI Designer.
3. Select Run in the Project menu.
You can also run the application by selecting run from the project’s pop-up
menu.
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Debugging an Application
The GUI Designer debug function allows you to debug an application, once it
has been built.
To debug an application:
v Using the Project window from the GUI Designer:
1. Open the project into the GUI Designer.
2. Ensure that the project has been built.
3. Select Debug in the Project menu.
You can also launch a Debug session from the project’s pop-up menu.

Backing up a Project
The GUI Designer backup function allows you to backup your VisualAge RPG
project to the AS/400.
To backup a VisualAge RPG project:
1. Display the Backup Project window:
v Using the Project Organizer window:
Select Backup from the Project menu.
v Using the pop-up menu of the project icon:
Display the pop-up menu from the project icon by pressing the right
mouse button and select Backup.
v Using the Backup Utility:
Click Start > Programs > VisualAge RPG and CODE400 > VisualAge
for RPG > Backup Utility.
2. Specify the name of the VisualAge RPG project you want to backup or use
the default provided.
Note: If you want to backup a project other than the one currently
selected, choose Find.
3. Select the Always refresh check box to ensure that the server information
is always updated.
4. Select Always overwrite to have the server overwrite the previously
backed up files.
5. Select Backup.
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Restoring a Project
The GUI Designer restore function allows you to restore a previously
backed-up VisualAge RPG project.
To restore a VisualAge RPG project:
1. Display the Restore Project window:
v Using the Project Organizer window:
Select Restore from the Project menu.
v Using the pop-up menu of the project icon:
Display the pop-up menu from the project icon by pressing the right
mouse button and select Restore.
v Using the Restore Utility:
Click Start > Programs > VisualAge RPG and CODE400 > VisualAge
RPG > Restore Utility.
2. Select the saved VisualAge RPG project you want to restore from the
Select project to be restored tree view.
3. Select the Always refresh check box to ensure that the server information
is always updated.
4. Click Restore.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|

VARPG and Application Development Manager
Should you wish to take advantage of change management or version control,
ADM can be used in conjunction with VisualAge RPG. The degree to which
you wish to take advantage of ADM will dictate how you set up ADM
projects and groups. In this example, ADM will be used in its simplest form,
one project with one group.
Within Application Development Manager a VisualAge RPG project is
contained in two parts. The first part is the project source, which is stored in a
part type of VRPGTXT. The second part is the project binaries, which are
stored in VRPGBIN. All projects contain groups which in turn contain parts.
The following is the definition of a project, group, and part:
v Project: one application, or a defined portion of a larger application. A
project consists of all the related components of an application, regardless
of the phase of development they are in.
v Group: AS/ 400 libraries. Create one or more groups that relate to the
development life cycle of the project. You can have master, test and
development groups. For example, a group called MASTER could represent
the most current version of your entire application. Another group, TEST,
could represent a mixture of changed or unchanged code that is still being
tested.
v Part: a member of a file, an AS/400 object.
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Briefly, here are the steps to follow to create an ADM project:

|

Create an ADM Project
You can create a project using the Programming Development Manager
(PDM) or the command line on the AS/400 host. For this exercise the
command line method is used. You will create a project called PAYROLL, with
a short project name of PAY. As the TEXT parameter describes, the PAYROLL
project is a weekly payroll processing application.
To create a project use the CRTPRJ command, as follows:
CRTPRJ PRJ(PAYROLL) SHORTPRJ(PAY) SAVDTA(*YES)
TEXT('WEEKLY PAYROLL PROCESSING APPLICATION')

Once you have created a project, you become the project administrator for it,
and can use all the administration commands to work with it. You can add
other project administrators or developers. The user profile QSECOFR is an
administrator for all projects. To give others access to a project, use the
ADDPRJUSR command.

Create a Group
You must have created your project and be an administrator for it, before you
can create a group.
To create a group MASTER in the project PAYROLL use the CRTGRP
command, as follows:
CRTPRJ PRJ(PAYROLL) GRP(MASTER) SHORTGRP(MST) PARENT(*NONE)
TEXT('MASTER GROUP IN PROJECT PAYROLL')'

Checking in a Project
The GUI Designer check-in function allows you to check-in a VisualAge RPG
project to ADM/400. VisualAge RPG projects that are checked in are called
parts on ADM/400.
Note: This function is only available if your server is V3R2, V3R7, V4R2,
V4R3, or V4R4.
To check-in a VisualAge RPG project:
1. Display the Check-in Project to ADM/400 window:
v Using the Project Organizer window:
Select Check-in from the Project menu.
v Using the pop-up menu of the project icon:
Display the pop-up menu from the project icon by pressing the right
mouse button and select Check-in.
2. Specify the name of the VisualAge RPG project you want to check-in. In
this example, PAYROLL is the name of the project.
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Note: If you want to check-in a project other than the one currently
selected, choose Find.
3. Select the ADM/400 group where the VisualAge RPG project should be
stored.
4. Select OK to invoke a secondary dialog to:
v Select the promote code to determine the promote path in the ADM
project hierarchy for the part. Select *NONE to assign no promote code
to the part. It cannot be promoted. Select *GRP to have the promote
code for the group specified on the GRP parameter assigned to the part.
v Specify the name of the ADM part-list to which the part (your
VisualAge RPG project) should be added.
5. Select the Always refresh check box to ensure that the server information
is always updated.
6. Select Always overwrite to have the server overwrite the previously
backed up files.
7. Select Check-in to check-in the VisualAge RPG project.

Checking out a Project
The GUI Designer check-out function allows you to check-out a VisualAge
RPG project on ADM/400.
Note: This function is only available if your server is V3R2, V3R7, V4R2,
V4R3, or V4R4.
To check out a VisualAge RPG project:
1. Display the Check-out Project from ADM/400 window:
v Using the Project Organizer window:
Select Check-out from the Project menu.
v Using the pop-up menu of the project icon:
Display the pop-up menu from the project icon by pressing the right
mouse button and select Check-out.
2. Select the server and ADM part name from the Select ADM/400 project
for check-out tree view.
3. Select the Always refresh check box to ensure that the server information
is always updated.
4. Click Check-out.
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Extracting a Project
The GUI Designer extract function allows you to extract a VisualAge RPG
project on ADM/400.
Note: This function is only available if your server is V3R2, V3R7, V4R2,
V4R3, or V4R4.
To extract a VisualAge RPG project:
1. Display the Extract Project window:
v Using the Project Organizer window:
Select Extract from the Project menu.
v Using the pop-up menu of the project icon:
Display the pop-up menu from the project icon by pressing the right
mouse button and select Extract.
2. Select the server and ADM part name from the Select ADM/400 project
for extract tree view.
3. Select the Always refresh check box to ensure that the server information
is always updated.
4. Select Extract.
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|

|
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|
|
|
|

When you use an AS/400 system, you may get Service Packs from IBM. These
Service Packs must be applied on your AS/400 and then downloaded to your
workstation or a LAN. You can also download the Service Packs from our
Web site: http://www.ibm.com/software/ad/varpg

|
|
|
|

A Service Pack can be copied to a LAN server for enterprise-wide
distribution. Alternatively, if you have access to a CD burner, you can create
your own CD-ROM to distribute the Service Pack to all VisualAge RPG and
CODE/400 license holders.

|

Instructions on using the Service Pack are found below.

|
|
|

Note: To see the latest information about a specific Service Pack, click Start >
Programs > VisualAge RPG and CODE400 > Service Packs >Service
Readme.

|
| Installing from a Managing AS/400 System
|
|
|
|
|
|

The following method should be used if you have received the VisualAge
RPG and CODE/400 Service Pack through the AS/400 PTF (Program
temporary fix) ordering process (either as an individual PTF order or as part
of an OS/400 PTF cumulative package). Once this Service Pack has been
applied to the managing AS/400 system with the LODPTF and APYPTF
AS/400 commands, it can be installed on individual PCs.

|
|

Client Access is required to attach to the AS/400 file system as a drive letter.
Other communication products with the same function can be used as well.

|
|

To install a Service Pack, click Start > Programs > VisualAge RPG and
CODE400 > Service Packs > Start Service.

|

Follow the online instructions.

|
|

If the AS/400 file system is attached with the command:

|
|

then the Service Pack source path should be:

|

If the AS/400 file system is attached as:

net use I: \\AS400_system_name\

I:\QADTSWIN
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|

net use I: \\AS400_system_name\QADTSWIN

|
|

then the Service Pack source path should be:
I:\

|
| Installing from a Local or Network Drive
|
|
|
|

The following method should be used if you received the VisualAge RPG and
CODE/400 Service Pack as a set of installation image files, not as PTFs
(program temporary fixes) from an AS/400 server. This is the case if you
downloaded the files from our Web site.

|
|

To install a Service Pack, click Start > Programs > VisualAge RPG and
CODE400 > Service Packs > Start Service.

|

Follow the online instructions.

|
|

If you installed the files in I:\, the Service Pack source path should be:

|
|

Once the install setup porgram has completed, you can remove the install
image files from your Local or Network drive.

I:\QADTSWIN

|
| Silent Installation (Unattended)
|
|
|
|

Setup.iss is a configuration file used by the Service Pack Utility to support
silent installation (unattended/remote installation). To install a Service Pack in
silent mode, type the command:

|
|
|
|
|
|

Where x: is the disk drive in which VisualAge RPG and CODE/400 is
installed from a DOS session. A single message indicates that silent
installation is running. All Servie Pack parameters are now taken from the
setup.iss configuration file. One parameter must be changed to indicate where
to install the Service Pack from, in the line:

|

Where xxx is the version of the Service Pack.

|
|
|
|

This line should point to the directory in which the Service Pack is located.
Silent installation creates a file called SETUP.LOG that contains the line
″ResultCode = 0″ which means successful installation. Any other value means
failure and you should talk to an IBM Service Representative for help.

x:\adtswin\setup.exe -s -fservice.ins

szDir=N:\ADTSWIN\SPxxx
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|
| Removing the Service Pack
|
|
|

It is strongly recommended that you close all applications and restart your PC
before removing a Service Pack to properly terminate any DLLs that are in
use.

|
|
|
|
|
|

To
1.
2.
3.

remove a Service Pack from your PC do the following:
Click Start > Settings > Control Panel.
Double-click on the Add/Remove Programs icon.
Click the Install/Uninstall tab, click on the ″VisualAge RPG and
CODE/400 Service Pack xxx″ item, and then click Add/Remove.
4. Follow the instructions on the screen.

|
|
|

Or you can click Start > Programs > VisualAge RPG and CODE/400 >
Service Packs > Start Service and select the Uninstall last Service Pack
option.

|
| Copying a Service Pack
|
|
|
|
|
|
|

The option to copy a Service Pack is designed mainly to copy a Service Pack
from an AS/400 server to a Local or Network drive. It creates a small version
of the product folder (QADTSWIN, QCODEWIN, and QVRPGWIN) with just
the files needed to install a Service Pack. The same instructions apply to how
the Source and Target locations are entered in the entry field, it should be:
I:\source_directory where source_directory is where the folder QADTSWIN
can be found.
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Notices
This information was developed for products and services offered in the
U.S.A. IBM may not offer the products, services, or features discussed in this
document in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any
functionally equivalent product, program, or service that does not infringe
any IBM intellectual property right may be used instead. However, it is the
user’s responsibility to evaluate and verify the operation of any non-IBM
product, program, or service.
IBM may have patents or pending patent applications covering subject matter
in this document. The furnishing of this document does not give you any
license to these patents. You can send license inquiries, in writing, to:
Director of Licensing
Intellectual Property & Licensing
International Business Machines Corporation
North Castle Drive, MD - NC119
Armonk, New York 10504-1785
U.S.A.
The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.
This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will
be incorporated in new editions of the publication. IBM may make
improvements and/or changes in the product(s) and/or the program(s)
described in this publication at any time without notice.
Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for
this IBM product and use of those Web sites is at your own risk.
© Copyright IBM Corp. 1994, 2000
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Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:
IBM Canada Ltd.
Department 071
1150 Eglinton Avenue East
Toronto, Ontario M3C 1H7
Canada
Such information may be available, subject to appropriate terms and
conditions, including in some cases payment of a fee.
The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer
Agreement, IBM International Program License Agreement, or any equivalent
agreement between us.

Programming Interface Information
This publication is intended to help you to create and manage VisualAge RPG
applications and user interfaces on the workstation, in a client/server
environment. This publication contains examples of data and reports that are
used in daily business operations. To illustrate them as completely as possible,
the examples include the names of individuals, companies, brands, and
products. All of these names are fictitious and any similarity to the names and
addresses that are used by an actual business enterprise is entirely
coincidental. This publication documents General-Use Programming Interface
and Associated Guidance Information provided by IBM VisualAge RPG and
Cooperative Development Environment for AS/400.

Trademarks and Service Marks
The following terms are trademarks or registered trademarks of the
International Business Machines Corporation in the United States or other
countries or both:
Application System/400
AS/400
AS/400e
Client Access
Client Access/400
COBOL
DB2/400
IBM
IBMLink
ILE
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Integrated Language Environment
OS/400
VisualAge
InstallShield is a registered trademark of InstallShield Corporation.
Intel is a registered trademark of Intel Corporation.
Java and all Java-based trademarks are trademarks or registered trademarks of
Sun Microsystems, Inc. in the United States and/or other countries.
Microsoft, Windows, and Windows NT are trademarks or registered
trademarks of Microsoft Corporation in the United States, or other countries,
or both.
Other company, product, and service names may be trademarks or service
marks of others.
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