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About This Book
This guide explains how to install the IBM VisualAge RPG and Cooperative
Development Environment for AS/400 (VisualAge RPG and CODE/400)
program, which consists of the following features:
v VisualAge RPG
v Cooperative Development Environment/400 (CODE/400)
This manual leads you through the following steps:
1. Planning for installation, which includes installing and configuring
prerequisite products
2. Installing VisualAge RPG and CODE/400
3. Configuring communications
4. Starting the VisualAge RPG and CODE/400 program
5. Maintaining the VisualAge RPG and CODE/400 program

Who Should Use This Guide
This guide is intended for AS/400 application developers or analysts who
want to install VisualAge RPG and CODE/400 on a programmable
workstation.
You should have a general knowledge of the Application System/400
(AS/400) product line. If you are the system administrator at your site, you
should also be familiar with the RSTLICPGM command.
We also suggest experience with a programmable workstation and experience
with either the Windows® 95, Windows 98, or Windows NT operating system.

Keeping in Touch
Contact us in one of the following ways:
v Visit our World Wide Web page at
http://www.ibm.com/software/ad/varpg. You can also get to this page
from the IBM® Software home page (http://www.ibm.com/software),
following the Application Development link.
Information that you can find on the Web site include:
– Service Pack and PTF information and downloads
– VisualAge RPG and CODE/400 tips and techniques
– Sample Editor macros and VisualAge RPG programs

© Copyright IBM Corp. 1994, 2000
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v Subscribe to the CODE400-L internet mailing list, which is moderated by a
CODE/400 customer for VisualAge RPG and CODE/400 discussions, tip
sharing, questions, and so on. While IBM does not own or maintain this
mailing list, we do monitor it. To subscribe to the list, send an e-mail
message to CODE400-L-SUB@midrange.com. To unsubscribe from the list,
send an email message to CODE400-L-UNSUB@midrange.com.
v Follow the VisualAge RPG and CODE/400 newsgroups and post your
questions at:

|
|

VisualAge RPG newsgroup
news://news.software.ibm.com/ibm.software.varpg/
CODE/400 newsgroup
news://news.software.ibm.com/ibm.software.code400/

How to Send Your Comments
Your feedback is important in helping us to provide the most accurate and
high-quality information possible. IBM welcomes any comments about this
book or any other AS/400 documentation.
v If you prefer to send comments by mail, use the following address:
IBM Canada Ltd. Laboratory
Information Development
2G/KB7/1150/TOR
1150 Eglinton Avenue East
Toronto, Ontario, Canada M3C 1H7
If you are mailing a readers’ comment form from a country other than the
United States, you can give the form to the local IBM branch office or IBM
representative for postage-paid mailing.
v If you prefer to send comments by facsimile, use the following number:
– 1-416-448-6161
v If you prefer to send comments electronically, use one of these e-mail
addresses:
– Comments on books:
Internet: torrcf@ca.ibm.com
IBMLink: toribm(torrcf)
– Comments on the AS/400 Information Center:
RCHINFOC@us.ibm.com
Be sure to include the following:
v The name of the book
v The publication number of the book
v The page number or topic to which your comment applies.
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Prerequisite and Related Information
Use the AS/400 Information Center as your starting point for looking up
AS/400 technical information. You can access the Information Center from the
AS/400e Information Center CD-ROM (English version: SK3T-2027-03 ) or
from one of these Web sites:
http://www.ibm.com/as400/infocenter
http://publib.boulder.ibm.com/pubs/html/as400/infocenter.htm
The AS/400 Information Center contains important topics such as logical
partitioning, clustering, Java™, TCP/IP, Web serving, and secured networks. It
also contains Internet links to Web sites such as the AS/400 Online Library
and the AS/400 Technical Studio. Included in the Information Center is a link
that describes at a high level the differences in information between the
Information Center and the Online Library.
For a list of related publications, see the “Related Publications” on page 59.

Conventions Used in this Guide
Directory names and file names appear LIKE THIS.
The drive letter d: is used as a generic disk drive designation.
Commands, coding examples, and any text that you enter appear Like
this.
User interface controls appear Like this.
New terms appear like this.
Note: This book does not contain a glossary. Terms are defined when they
first appear.
No special appearance is given to window titles, folder names, notebooks,
notebook tabs, or keys (for example, the Enter key).

Mouse Button Naming Conventions
The following mouse button naming conventions are used in this guide:
v The left button is used to select an object, open a file, or start an
application. It is the physical left button unless this button has been
customized to do something else.
v The right button is used to move or manipulate an object. It is the physical
right button unless this button has been customized to do something else.

About This Book
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You can define the function of each mouse button using the Windows Control
Panel. If you are not sure how your mouse is configured, check the properties
of the mouse item in your Windows Control Panel.
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Chapter 1. VisualAge RPG and CODE/400 Quick Start

|
|
|
|
|
|
|
|

This section provides instructions for installing the product from the
workstation CD and configuring TCP/IP communications for a quick start to
using VisualAge RPG and CODE/400. For this quick start, ensure that you
have the following prerequisites:
v AS/400™ host with OS/400® V4R3 or later
v All of the most recent PTFs installed on your AS/400 host. The list of PTFs
is available at: http://www.ibm.com/software/ad/varpg/support
v TCP/IP for communications with the AS/400 host

|
|

It is recommended that you refer to “Chapter 2. Preparing for Installation” on
page 3 for a complete list of prerequisite actions prior to installing.

|
|
|
|

If you do not have the above prerequisites, or wish to use other installation or
communication configuration methods, refer to “Chapter 3. Installing
VisualAge RPG and CODE/400” on page 9 and “Chapter 4. Configuring
Communications” on page 17.

|
| Installing from the Workstation CD
|
|
|

To install the product from the workstation CD:
1. Insert the CD-ROM into the CD drive.

|
|
|

If the installation utility does not start automatically, perform the following
steps:
1. From the Windows Start menu, select Run.
2. Type:

|
|
|

2. Follow the online instructions.

x:\qadtswin\setup.exe

Where x: is your CD-ROM drive.

|

© Copyright IBM Corp. 1994, 2000
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|
| TCP/IP Configuration

VisualAge RPG TCP/IP Setup

|
|
|
|

To identify the server you want to use do the following:
1. Click Start > Programs > VisualAge RPG and CODE400 > VisualAge
RPG > GUI Designer.
2. Select Server from the menu bar.
3. Select Define TCP/IP Servers.
4. Click Add. The Add TCP/IP Server dialog appears.
5. Enter the Host name or IP address of your AS/400 server.

|
|
|
|
|
|
|
|
|
|

6. Click OK and then Close.
7. Select Define AS/400 Information. The Define AS/400 Information
notebook appears.
8. Click Add. The Add Server Alias Name dialog appears.
9. Enter your AS/400 Server alias name.
10. Select the correct remote location name from the combination box.
11. Click OK to leave the Add Server Alias Name dialog..
12. Click OK to save and close the notebook.

|
|

CODE/400 TCP/IP Setup

|
|
|
|
|
|

To start the daemon with an interactive emulation session and STRCODE
command:
1. Click Start > Programs > VisualAge RPG and CODE400 > TCPIP
Communication Server.
2. Start a 5250 emulation session if it is not already started and sign on.

|
|
|
|

3. On the host’s command line, type STRCODE and then select PF4. Use the IP
address of your workstation (where the TCPIP Communication Server is
running) for the RMTLOCNAME parameter.
4. For the CMNTYPE parameter type *TCPIP.

|
|

5. Press Enter. The CODE/400 display appears on your 5250 emulation
window.

|
| Starting VisualAge RPG and CODE/400
|
|

For VisualAgeRPG, start the GUI Designer. Click Start > Programs >
VisualAge RPG and CODE400 > VisualAge for RPG > GUI Designer.

|
|

For CODE/400, start the CODE Editor. Click Start > Programs > VisualAge
RPG and CODE400 > CODE400 Tools > CODE Editor.

2

Installing VisualAge RPG and CODE/400

Chapter 2. Preparing for Installation
This chapter provides an overview for the planning required for installing
VisualAge RPG and CODE/400. Planning for installation involves meeting
hardware requirements, installing prerequisite software, uninstalling the
product, and migrating files for components from previous releases.
Table 1 shows the sequence of tasks involved in installing VisualAge RPG and
CODE/400. It also indicates where you can find more information about
completing the task.
Table 1. Installation Overview
AS/400 Host V4R3 or later
Stage
1

Task
Ensure prerequisite
AS/400 host
software installed

More Information
“AS/400 Host
Software” on page 6

2

3

Install VisualAge
RPG and CODE/400
(optional) on the host or LAN.
4

Workstation Windows 95/98/NT 4.0
Task

More Information

Ensure prerequisite
workstation host
software installed

“Workstation
Software” on page 5

Perform prerequisite
tasks if you have
previously installed
the product

“Before You Begin”
on page 7

Install the VisualAge
RPG and CODE/400
workstation
component from the
AS/400 host, LAN or
CD.

“Installing
VisualAge RPG and
CODE/400 on the
Workstation” on
page 13

“Installing on the
AS/400 Host” on
page 9“Installing on a
LAN Server” on page 11

5 (TCP /
IP)

Configuration

Configure Windows
networking (TCP/IP
protocol).

“TCP/IP
Configuration” on
page 17

5 (SNA)

Configuration

Configure
communications to
include at least one
AS/400 connection.

“SNA
Communications”
on page 20

© Copyright IBM Corp. 1994, 2000
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Prerequisites
This section describes what you need to install VisualAge RPG and
CODE/400.

Hardware Requirements
VisualAge RPG and CODE/400 has the following hardware requirements:
v Workstation Hardware
Minimum
|
|

– Programmable workstation with an Intel® Pentium® processor
100 MHz

|
|
|
|

–
–
–
–

64 MB of memory
350 MB free hard disk space
SVGA (800x600) display
A mouse

Recommended
– Intel Pentium processor 350 MHz or higher
– 128 MB of memory
– 425 MB free hard disk space
– SVGA (1024x768) display or higher

|
|
|
|

v AS/400 Hardware
Recommended
93 MB of available memory
The applications you create using VisualAge RPG will run on significantly
smaller machines than those required for development. For example, a
VisualAge RPG application can run on a PC with 12 MB of memory and 15
MB of disk space, and an AS/400 with 17 MB of available memory.
Also, the system requirements decrease if you choose to only install the
components you want and if you choose to run the product from the LAN.
v Communications Options
– Twinaxial
– SDLC
– Ethernet
– Asynchronous
– Token ring
Appropriate communications adapters (as supported by the workstation
operating system) are required as well.

4
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Software Requirements
v Workstation Software
You need:
– Microsoft® Windows® 95, Windows 98, or Windows NT® 4.0 or above
For service support from your AS/400 host, you need one of the following
products on at least one workstation:
– IBM® Client Access for Windows
– Client Access Express
– NetServer
Note: You can also download Service Packs from the World Wide Web,
avoiding this pre-requisite.
For communications with the AS/400 host, choose one of the following:
– IBM Client Access for Windows
– IBM Personal Communications for Windows
– RUMBA (for use with CODE)
– TCP/IP
For 5250 emulation sessions, choose your preferred emulation program such
as:
– IBM Personal Communications for Windows
– IBM Client Access or Client Express
– RUMBA
For client/server connectivity in your VisualAge RPG applications, choose
one of the following:
– APPC
– TCP/IP
|
|
|
|

For editing support of IFS files, you need:
– Java™ 2 Software Development Kit, Standard Edition (J2SDK), v 1.2 or
later

|
|
|

Note: The AS/400 Toolbox for Java supports V4R2 and later of the AS/400
host.

– AS/400 Toolbox for Java

Chapter 2. Preparing for Installation
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|
|
|
|

For viewing the online help, choose your preferred frames-capable Web
browser such as:
– Netscape Navigator 4.04 or later
– Microsoft Internet Explorer 4.01 or later

|
|
|
|

Note: Netscape Communicator 4.7 or Internet Explorer 5.0 is
recommended.
For your convenience, the Netscape Communicator workstation CD has
been included with the product.
See your IBM sales representative for product order numbers. Contact the
IBM Support Center to obtain any updates to the products listed.
v AS/400 Host Software
You need:
– IBM Operating System for AS/400 (5769-SS1), Version 4 Release 3 or
later.

|

Note: When using SNA communications, ensure you choose the Host
Server option when installing your OS/400® operating system.
– IBM Application Development ToolSet for AS/400 (5769-xxx)

|
|
|

The following compilers are supported, but not required:
– RPG/400® and ILE RPG for AS/400
– COBOL/400® and ILE COBOL for AS/400
– CL and ILE CL for AS/400
–
–
–
–

|

ILE C for AS/400
ILE C++ for AS/400 (5799–GDW)
SQL/400® and ILE SQL
CICS/400® and ILE CICS®

For Java support, you need:

|
|

– AS/400 Developer Kit for Java (5769–JV1)

|
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Before You Begin
This section provides information that you need to know prior to installing
VisualAge RPG and CODE/400.
Before you install VisualAge RPG and CODE/400 onto the workstation, it is
recommended that you do the following:
v For VisualAge RPG, you must deregister the .IVG filetype by doing the
following:
1. Select the View menu from any folder.
2. Choose Options, then File types.
3. Select VisualAge RPG projects.
4. Click Remove.
v If you want to install both IBM® VisualAge for C++ and VisualAge RPG
and CODE/400 on the same workstation, you must first install VisualAge
for C++.

Uninstalling VisualAge RPG and CODE/400 from the Workstation
It is strongly recommended that you delete any previous versions of this
product from the workstation before proceeding.
To remove all components of VisualAge RPG and CODE/400 from your
workstation, do the following:
v Click Start > Settings > Control Panel.
v From the Control Panel folder, click Add/Remove Programs.
v Select VisualAge RPG and CODE/400 V3R2M2 from the list.
v Click Add/Remove.

|
|
|
|

The uninstall process will remove all components and settings. However,
some files and directories may be left on your system. The uninstall process
should warn you about remaining directories and you can manually remove
them before restarting your system.
Note: NetQuestion will not uninstall until all other programs that use
NetQuestion are uninstalled.

Chapter 2. Preparing for Installation
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Migration Notes for Specific Components
The following sections contain information that you should be aware of when
migrating from one release to another.
Porting OS/2® Applications to the Windows platform
If you plan to port VisualAge RPG OS/2® applications to the Microsoft
Windows platform, post your question on the VisualAge RPG newsgroup at:
news://news.software.ibm.com/ibm.software.varpg/
CODE Project Organizer
If you choose to uninstall and re-install V3R2M3, you should backup the CPO
actions files (listed below) to a new directory. All you need to do after
re-installation is copy the files back to the base product directory (ADTSWIN
by default). You can either copy the files manually, or copy the actions using
the import feature in the CODE Actions dialog. CODE Project Organizer
automatically updates the files to the V3R2M3 format the first time they are
used.

|
|

The actions files are:
evfactfm.cpa
evfactfo.cpa
evfactfj.cpa
evfactfg.cpa
evfactfp.cpa
evfactpr.cpa
evftypes.cpa
evfactfl.cpa
CODE Program Generator
When you update your installation, a CODE/400 Initialization shortcut in the
Startup folder creates a file called PGV3R2M0.OUT in the SYSTEM
sub-directory of VisualAge RPG and CODE/400.
The file contains a list of all the Program Generator labels that need to be
manually migrated. All the labels appear in the label list on the Program
Generator window. However, they will have default settings after migration.
You must re-create the settings listed in the PGV3R2M0.OUT file by entering
them in the Options dialog.
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Chapter 3. Installing VisualAge RPG and CODE/400
|
|
|
|

The VisualAge RPG and CODE/400 program consists of host components and
programmable workstation components, shipped separately on an AS/400®
and a workstation CD-ROM. This section guides you through the various
methods of installing the product.

|
|
|
|
|

VisualAge RPG and CODE/400 can be installed on the user’s workstation
using the following methods:
1. Installing the product from the AS/400 host.
2. Installing the product from the LAN.
3. Perform silent installation from the LAN as part of a batch job.

|

4. Installing the product from the workstation CD-ROM.

|

The first three methods require that your system administrator install the
product on the AS/400 host or LAN.

Installing on the AS/400 Host
This section provides instructions for installing and removing the VisualAge
RPG and CODE/400 Version 3 Release 2 Modification Level 3 licensed
program on the AS/400 host system.

Installing with GO LICPGM from a CD-ROM
If you are installing VisualAge RPG and CODE/400 from an AS/400
CD-ROM, use the Work with Licensed Programs menu. To invoke this menu,
enter:
GO LICPGM

|
|
|

From this menu, you can perform all required program management functions
for VisualAge RPG and CODE/400, such as installation and deletion. Even
though you order the product using program number 5769–CL3, the ID used
for installing components is different. The ID for components of this product
is 5763CL2.
Do the following from the Work with Licensed Programs menu:
1. Go to option 10 – Display Installed Licensed Programs. Verify that no
5763CL2 parts that you want to install are in the list.
2. Go to option 11 – Install Licensed Programs
The Install Licensed Programs display shows the licensed programs available
from IBM at the time your currently installed operating system release,
© Copyright IBM Corp. 1994, 2000
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modification, or level became available. It also shows all licensed programs
currently installed.You can use this list to select licensed programs and
optional program parts to install on your system by typing 1 next to the
selected part and pressing Enter. You can add licensed programs to this list if
they are not present. The parts of this product are:
v Base - must be installed first
v CODE/400 optional part
v VisualAge RPG optional part
3. To install VisualAge RPG and CODE/400 if it is not in the list, type
1 5763CL2 and product option in the top blank field, and then press Enter.
The product option can be one of the following:
v *BASE to specify the base part of the product (must be installed first)
v 1 to specify the optional CODE/400 part
v 2 to specify the optional VisualAge RPG part
v *ALL to specify all available parts
The following is an example of how part of the screen would look like if you
specify the base part for installation:
Opt
1

Licensed Product
Program
Option
5763CL2
*BASE

4. After you press Enter, a message should say that 5763CL2 is added to the
list. Scroll down the list to verify that this is true. Position the cursor at the
line, type 1 and press Enter. You will enter the Confirm Install of
Licensed Programs panel.
5. Press Enter again to go to the Install Options panel. For the Installation
device category, enter OPT01. Press Enter. Installation will begin.
When the installation is complete, you will see the message ″Work with
Licensed Programs function has completed″. To verify this, go back to the
Work with Licensed Programs menu. Type 10 and then Enter to see a list of
installed licensed programs. Verify that the program you installed is present.
If you have additional parts to install, use option 11 and repeat the preceding
process.

Installing with RSTLICPGM
To install VisualAge RPG and CODE/400 onto the AS/400 system from a
CD-ROM, do the following:
1. Sign on to your AS/400 system with security officer (QSECOFR) authority.
2. Enter the Restore Licensed Program (RSTLICPGM) command:
RSTLICPGM LICPGM(5763CL2) DEV(XXXxx) OPTION(*BASE) LNG(*SAVVOL)

where XXXxx specifies the name of the CD-ROM used to restore the
licensed program.
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Installing the program creates a library and a folder on the system, both
named QADTSWIN.
3. You can use RSTLICPGM with OPTION(1) (for CODE/400) or OPTION(2) (for
VisualAge RPG). For CODE/400, a library and a folder are created called
QCODEWIN. For VisualAge RPG, a library and a folder are created called
QVRPGWIN.
The libraries contain product information, and the folders contain the files
necessary for installing and running VisualAge RPG and CODE/400 on a
workstation.

VisualAge RPG and CODE/400 Shared Folder Directories
When you install VisualAge RPG and CODE/400 on the AS/400 host system,
the folder QADTSWIN is created. You can access this folder as a workstation
directory by using the Client Access shared folders function.

Installing on a LAN Server
This section provides instructions for installing the VisualAge RPG and
CODE/400 Version 3 Release 2 Modification Level 3 licensed program on a
LAN server.
To copy necessary product files to a LAN server from the AS/400 host, use
the CPY2LAN command to copy an image of the Client Access shared folders
to the LAN. The QADTSWIN, QCODEWIN, and QVRPGWIN folders are
copied.

Using a LAN Server for All Installation Files
You can use the following command to copy all files usually found in the
shared folders to the LAN:
x:\QADTSWIN\CPY2LAN

where x: is a Client Access shared folder.
The CPY2LAN command uses Client Access to transfer all of the contents of
the shared folders to your LAN server. LAN users do not need to run Client
Access to do their individual installations.

Using a LAN Server for Compact Installation
Compact installation gives your LAN users the ability to install just part of
the VisualAge RPG and CODE/400 product on their workstation. Common
files can be kept on a centrally accessible server. This means your users save
local hard disk space, and you can do central product updates if necessary.
Compact Installation Considerations:
1. If your site is running compact installations, ensure that you adhere to the
VisualAge RPG and CODE/400 product license agreement.
Chapter 3. Installing VisualAge RPG and CODE/400

11

2. Service support for a compact installation may require you to use the
installation utility to update the workstation portion of the product
occasionally.
To set up a server for use in compact installations, ensure that the directory to
which you install matches the ServerInstallation entry in the SETUP.CTL
file for your language. By default, this is ADTSLAN.

|

Silent Installation

|
|
|
|
|

Silent installation (also known as remote or unattended installation) can be
useful for a network administrator who wants to install the product to a
workstation. You can use silent installation for the product and its
components.

|
|

There are five available files which will guide your installation depending on
the result you want:

|

setup.iss

Installs the entire VisualAge RPG and CODE/400 product.

|

code.iss

Installs all the CODE/400 components.

|

varpg.iss

Installs all the VisualAge RPG components.

|
|
|
|

compact.iss

Installs only the required workstation files to the user’s
workstation. All other files are accessed from a common
location on the LAN. For more information, see “Using a LAN
Server for Compact Installation” on page 11.

|
|
|

service.iss

Installs the Service Pack. More information about this is
available in the README file which comes with each Service
Pack.

|
|
|
|
|
|

After installing the product on the LAN, you must do the following before
performing silent installation on the workstation:
1. Modify the following entry in the .iss files, which are located in
x:\qadtswin and x:\qadtswin\mrm\nlsxxxx , that you want to use for silent
installation:
szDir = d:\dir

Where d:\dir is the drive and directory in which you want to silently
install the product or one of its components.

|
|
|
|
|
|
|

2. Rename the .iss file to setup.iss before running your silent installation. For
example, to silently install only the German CODE/400 components,
rename the file code.iss to setup.iss in the nls2929 subdirectory directory.
This must be done because InstallShield only recognizes the file setup.iss
during silent installation.

|
|

Note: You can have only one national language version of the VisualAge RPG
and CODE/400 product on your LAN server to use silent installation.
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|
|
|
|
|
|
|

If you have more than one language version, remove or rename the
language folders or subdirectories you do not need. For example, if you
want to use silent installation for the German version of VisualAge
RPG and CODE/400, you can have only the files in directory
qadtswin\mrm\nls2929 present. If you have any other language
subdirectories present (nls2931, nls2986, and so on), you must remove
or rename these subdirectories.

|
|
|

Installing on the Workstation
To perform silent installation of the product or one of its components on the
workstation, do the following:

|
|
|
|

1. Connect to your LAN.
2. Change the directory to x:\qadtswin where x: is the lan directory.
3. Run the following command on the workstation:

|
|
|
|
|
|

setup -s

Note: Silent installation assumes that the product is not installed, no
checking is done for previously installed versions.
4. After installation is complete, the file setup.log is created in the same
directory as the setup program. The ResultCode=0 entry indicates that the
installation is successful.
5. Restart the workstation after installation.

|

Adding Site-Specific Files to Your Installations
End-users at your site may write useful macros which should be available to
all users of VisualAge RPG and CODE/400. You can make the macros, or any
other files, available to people installing from an AS/400 shared folder or
LAN server.
The NEW.FLS file contains a list of site-specific files. The files listed in the
NEW.FLS file should be stored in the QADTSWIN\MRM subdirectory.

|

When you want to have the site-specific files installed on the end user
machines, ask your users to select User Additions as a component during the
workstation installation procedure.

|
| Installing VisualAge RPG and CODE/400 on the Workstation
|
|
|
|
|

Note: NetQuestion, a search tool for the help system, will be installed in the
root diretory of the drive specified for product installation. For
example, if the product is installed in x:\qadtswin, NetQuestion will be
installed in x:\imnnq. If NetQuestion is already installed, the existing
version will be updated.
Chapter 3. Installing VisualAge RPG and CODE/400
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If you are installing on Windows 95 or 98 and receive an error message
indicating NetQuestion cannot be installed, it is because the PATH
statement in your autoexec.bat file is longer than 200 characters. The
solution is to shorten PATH statement.

|
|
|
|

Installing from the AS/400 Host

|
|
|
|
|
|

To install the product from the AS/400 host:
1. Connect to your AS/400 host.
2. Access your Client Access shared folders using the type on a command
line:
net use x: \\<as400_system_name>\qdls

Where qdls is the AS/400 shared folder system library.
3. Type:

|
|
|
|

x:\qadtswin\setup.exe

4. Follow the online instructions.

Installing from the LAN

|
|

To install the product that will run independent of the LAN:
1. Connect to the LAN resource.

|
|
|
|
|
|
|

Note: Ensure that the Reconnect checkbox is marked. That way your
shared LAN drive will always be available and have the same drive
letter.
2. Issue the following command:

|

To install the product that will run from the LAN (compact installation):

|
|
|
|
|
|
|
|

Compact installation gives you the ability to install only part of the VisualAge
RPG and CODE/400 product on your workstation. Common files can be kept
on a centrally accessible server. This means you save local hard disk space,
and your LAN administrator can perform central product updates if
necessary. However, depending on the speed and capacity of your LAN, you
may notice decreased performance. Ensure that your system administrator has
setup the LAN for compact installation.
1. Connect to the LAN resource.

|
|
|
|
|

Note: Ensure that the Reconnect checkbox is marked. That way your
shared LAN drive will always be available and have the same drive
letter.
2. Issue the following command:

x:\QADTSWIN\setup

3. Follow the online instructions.

x:\QADTSWIN\setup
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|
|

3. Choose a compact installation.
4. Follow the online instructions.

|
|
|
|

By choosing a compact installation to a local workstation directory, the
installation utility only copies a subset of product files. All other product files
will remain on the LAN server and be accessed through the network as
needed.

|
|
|
|
|
|
|
|
|
|

Installing from the Workstation CD
To install the product from the workstation CD:
1. Insert the CD-ROM into the CD drive.
2. Follow the online instructions.
If the installation utility does not start automatically, perform the following
steps:
1. From the Windows Start menu, select Run.
2. Type:
x:\qadtswin\setup.exe

Where x: is your CD-ROM drive.

|
| Custom Installation
|
|

Custom installation gives you the ability to install VisualAge RPG and
CODE/400 components separately.

|
|

To install VisualAge RPG and CODE/400 components, select Custom
Installation from the installation utility.

|
|

For information on adding and updating components for an existing
installation, see “Adding and Updating Components” on page 38.

Chapter 3. Installing VisualAge RPG and CODE/400
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Enabling Java
You need to perform the following steps to enable the Java features in
VisualAge RPG and CODE/400:
1. Install the Java 2 Software Development Kit, Standard Edition (J2SDK), v
1.2 or later, from JavaSoft on your workstation. You can download the
J2SDK by following the links from The Source for Java Technology Web
page at http://www.javasoft.com/products/.
Note: The J2SDK v 1.2 includes the Java 2 Runtime Environment,
Standard Edition, v 1.2 (JRE) and the Java 1.2 plug-in support.
Install these components as well.
2. When J2SDK installation is completed, update your PATH environment
variable to include the appropriate J2SDK directory. For example, if you
installed the J2SDK in directory x:\jdk12, then add the following
information to your PATH variable: x:\jdk12\bin.
3. Install the Java Media Framework API if you plan to use the VisualAge
RPG Media part.
Netscape Navigator and Microsoft’s Internet Explorer do not currently
support the same level of the J2SDK that VisualAge RPG uses. As such,
applets created with the VisualAge RPG GUI Designer will not run directly
with these browsers. To run VisualAge RPG applets in either of these
browsers, you must have the Java Plug-in 1.2 installed (mentioned above),
and the HTML Converter available from JavaSoft. You can download these by
following the links from The Source for Java Technology Web page. The
HTML Converter allows you to convert the HTML page with your applet tag
in order to use the Java Plug-in. The conversion creates an object tag that tells
the Web browser to use the Java Plug-in instead of its own Java 2 Runtime
Environment.
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Chapter 4. Configuring Communications
Before you can use the VisualAge RPG and CODE/400 product, you must
define the communications between the host AS/400 and your workstation.
Determine whether you are using TCP/IP or SNA protocols and refer to the
appropriate sections for configuration instructions.

TCP/IP Configuration
Follow the standard configuration instructions in the Windows help. You will
need to know:
v Your workstation’s IP address (or hostname if you have a domain name
server)
v Your AS/400 system’s IP address (or hostname)
v Gateway information, depending on the configuration of your LAN
v Domain name server information, if your network has one
In most work locations, the network administrator can provide you with any
of the configuration information you do not have.

VisualAge RPG TCP/IP Setup
If your AS/400 system is running an OS/400 release older than V4R2, you
need to complete the following setup on your AS/400 system before you can
run VisualAge RPG applications using TCP/IP:
1. Install the latest VisualAge RPG PTF (see the README for details).
2. Create controller QCNSKSVR and device descriptions QCNSKSVS and
QCNSKSVT as described in the appropriate OS/400 PTF cover letter (see
the README):
CRTCTLAPPC CTLD(QCNSKSVR) LINKTYPE(*LOCAL)
CRTDEVAPPC DEVD(QCNSKSVS) RMTLOCNAME(QCNSKSVT)
LCLLOCNAME(QCNSKSVS) CTL(QCNSKSVR) APPN(*NO)
CRTDEVAPPC DEVD(QCNSKSVT) RMTLOCNAME(QCNSKSVS)
LCLLOCNAME(QCNSKSVT) CTL(QCNSKSVR) APPN(*NO)
VRYCFG CFGOBJ(QCNSKSVR) CFGTYPE(*CTL) STATUS(*ON)

Check that they are active.
Note: Make sure that the device descriptions QCNSKSVS and QCNSKSVT
use the BLANK mode description.
© Copyright IBM Corp. 1994, 2000
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3. Check that the remote command server is active. Use WRKACTJOB to
look for job QZRCSRVSD under subsystem QSYSWRK. If you cannot find
it, use STRHOSTSVR *ALL to start it.
4. Make sure that the QUSER profile is enabled and its password has not
expired. (QUSER is used by the server at startup time.)
5. Add library QSYS2 to your library list if it is not already there.
6. Check that the mode description BLANK has the correct number of
sessions and conversations configured. Use WRKMODD to work with the
mode description BLANK. The numbers for the Maximum sessions and
Maximum conversations should be greater than the number of
applications that you plan to run. After you make the changes, vary on
and vary off the device descriptions QCNSKSVS and QCNSKSVT.
Defining Server Information
To identify the server you want to use do the following:
1. Click Start > Programs > VisualAge RPG and CODE400 > VisualAge
RPG > GUI Designer.
2. Select Server from the menu bar.
3. Select Define TCP/IP Servers.
4.
5.
6.
7.
8.
9.
10.
11.
12.

Click Add. The Add TCP/IP Server dialog appears.
Enter the Host name or IP address of your AS/400 server.
Click OK and then Close.
Select Define AS/400 Information. The Define AS/400 Information
notebook appears.
Click Add. The Add Server Alias Name dialog appears.
Enter your AS/400 Server alias name.
Select the correct remote location name from the combination box.
Click OK to leave the Add Server Alias Name dialog..
Click OK to save and close the notebook.

CODE/400 TCP/IP Setup
|

After you have installed the product, start the CODE Daemon (also referred to
as TCP/IP Communication Server).

|
|

Note: Ensure that your user profile has a unique non-system library as its
current library.

|

To start the daemon with an interactive emulation session and STRCODE
command:
1. Click Start > Programs > VisualAge RPG and CODE400 > TCPIP
Communication Server.
2. Start a 5250 emulation session if it is not already started and sign on.
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3. On the host’s command line, type STRCODE and then select PF4. Use the IP
address of your workstation (where the TCPIP Communication Server is
running) for the RMTLOCNAME parameter.
Tip: If your TCP/IP nameserver is properly configured, you can use your
workstation’s hostname in the RMTLOCNAME field.
4. If the CMNTYPE parameter type *TCPIP does not exist, apply the correct
PTF for your AS/400 operating system (see the product README for
details).
Important: Read the cover letter which accompanies the PTF and follow
the instructions carefully.
5. For the CMNTYPE parameter type *TCPIP.
6. Press Enter. The Cooperative Development Environment/400 display
appears on your 5250 emulation window.
|
|

CODE communications can also be used without an interactive emulator
session and the STRCODE command.

|
|
|
|

To configure and define a VCOM server to use CODE/400 without the
STRCODE command:
1. Follow the TCP/IP setup instructions for VisualAge RPG but do not define
the server.

|
|
|

2. Start the TCP/IP Communications server. An icon will appear in your
taskbar.
3. Right-click on the icon and select Define TCP/IP servers.
4. Click Add. The Add TCP/IP Server dialog appears.
5. Enter the Host name or IP address of your AS/400 server.

|
|
|

6. Click OK, then Close.

|
|
|
|
|
|
|

Due to the fact that VCOM servers run in a batch job, the following functions
are unavailable to VCOM servers:
v Prompting CL commands in CODE Editor, CODE Program Generator, and
CODE Project Organizer
v Prompting CL help in CODE Editor and CODE Project Organizer
v Running interactive programs
v Debugging interactive programs

|
|

Tip: You can start up to twenty connections to one or multiple AS/400 hosts.
However, you must specify a unique server name for each host.

Chapter 4. Configuring Communications
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|

SNA Communications
SNA configuration involves many more steps than standard TCP/IP
configuration. You must fully configure the prerequisite products you choose
before you begin using VisualAge RPG and CODE/400. SNA setup must be
done separately for VisualAge RPG and CODE/400 components.

VisualAge RPG SNA Setup
|
|
|
|
|

Ensure that you have one of the following products installed:
1. IBM Personal Communications Release 4.3 or later for Windows and IBM
LLC2 protocol driver.
2. Client Access for Windows V3R1M2 or later and Microsoft DLC32 protocol
driver.

|
|

Note: If you have both products installed, then Personal Communications will
be used as the default.

|
|
|

Configuring Personal Communications
Install Personal Communications according to the instructions provided with
the product.

|
|
|

To configure Personal Communications for VisualAge RPG in a LAN
environment, click Start > Programs > IBM Personal Communications >
SNA Node Configuration.

|
|
|
|

Configure node:
1. From the Configuration Options dialog, select Configure Node.
2. Click New.
3. In the Define a Node window, under Basic, type:

|
|

Fully Qualified CP Name:
xxx.yyy

|
|

Where xxx is your SNA network ID (obtained from your system
administrator) and yyy is your workstation ID.

|
|
|

This will also be used as the name of the device description for your
connection to the AS/400 server.
4. Click OK.

|
|

Configure devices:
1. From the Configuration Options dialog, select Configure Devices.
2. Click New.

|
|

3. In the Define a LAN Device window, click OK to create the device.
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|
|
|
|
|
|
|
|

Note: If you are configuring multiple AS/400 servers, you need to create a
device for each server. Change the local SAP to one that has not
been used before by using the drop-down menu. The first one is 04,
the next one is 08, and so on.
Configure connections:
1. From the Configuration Options dialog, select Configure Connections.
2. Click New.
3. In the Define a LAN Connection window, under Basic, type:

|
|

Link Station Name:
zzz

|

Where zzz is the name assigned to your AS/400 server.

|
|

Destination Address:
############

|
|
|

Where ############ is the address of your AS/400 server. You can obtain
this from your system administrator.
4. In the Define a LAN Connection window, under Adjacent Node, type:

|
|

Adjacent CP Name:
xxx.zzz

|
|

Where xxx is your SNA network ID and zzz is the name assigned to your
AS/400 server.

|
|
|

Note: If you have multiple AS/400 servers, each one should have a
unique device name.
5. Click OK.

|
|
|
|

Configure Partner LU 6.2:
1. From the Configuration Options dialog, select Configure Partner LU 6.2.
2. Click New.
3. In the Configure A Partner LU 6.2 window, under Basic, type:

|
|

Partner LU Name:
xxx.zzz

|
|

Where xxx is your SNA network ID and zzz is the name assigned to your
AS/400 server.

|
|
|

Note: The Partner LU Alias will default to ZZZ in uppercase. The alias
must match the remote location server name specified in your RST
file. It is also the name that appears in your server list.
Chapter 4. Configuring Communications
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|

4. Click OK.

|

After completing the above steps, select File > Save to save the configuration.

|
|
|

To start the node, select Start > Program > IBM Personal Communications >
Administrative and PD Aids > SNA Node Operations. In the SNA Node
Operations window, select Operations > Start Node.
Configuring Client Access
To configure Client Access, do the following:
Configure the NetSoft Router for use with your AS/400 server:
1. Click Start > Programs > NS Router > Configuration Wizard.
2. At the dialog that contains Midrange Workspace, select Next.
3. Pick a Link Type of 802.2, then select Next.
4. The next few dialogs will prompt you for information about your AS/400
server, such as its Token Ring address, system name, your default user ID
and password information, the SNA/APPC Network ID, PC location
name, and so on. Use the computer name on the PC Information Panel.
5. Once you have provided this information, a summary appears. If correct,
select Finish.
Check the connection:
1. Click Start > Programs > NS Router > NS Administrator.
2. In the NS Administrator window, change the label to the name of your
AS/400 server by right-clicking on the router and selecting Rename.
3. Double-click on your AS/400 name. You will get an NS/Router dialog for
the AS/400 server.
4. Highlight the system name, and then click System > Connect System. The
program should report one of the following situations:
v The connection was successful.
Click System > Disconnect System and proceed to the next step.
v The connection failed.

|
|

Something may be wrong with your AS/400 server, or some element of
Client Access has not been installed correctly. Please recheck your
configuration.
Add Client Access information for the router connection you just confirmed:
1. From the Program menu, select Client Access, then double-click on
AS/400 Connections.
2. In the AS/400 Connections dialog, click Connection > New. The Add
AS/400 Connection wizard appears. Click Next.
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3. From the Provider list, click Netsoft NS Router. Click Next.
4. Enter the name of your AS/400 server, then click Next. If asked whether
this system is going to be your ″Managing System″, answer Yes.
The managing system provides the correct codepage tables for characters
displayed on your workstation.
5. Enter your default user ID, then click Next.
6. Select the default view type you want for this connection. Your choices
will depend on which Client Access components you have previously
installed. You should select a view that includes one of the emulators that
are provided by Client Access. If in doubt, select the default view (you
can change it later from the AS/400 Connections menu). Click Next.
7. Click Verify Connection.
8. After you have verified the information, click Finish.
9. Select your system from the AS/400 Connections window and then click
Connection > Connect to activate the connection.
10. Enter your password and then click OK.

CODE/400 SNA Setup
|
|
|
|
|

Ensure that you have one of the following products installed:
1. IBM Personal Communications Release 4.3 or later for Windows and IBM
LLC2 protocol driver
2. Client Access for Windows and Microsoft DLC32 protocol driver
3. RUMBA

|

Configuring Personal Communications
Install and configure the product according to the instructions for VisualAge
RPG in “Configuring Personal Communications” on page 20.
There are two transaction programs which must be configured for CODE/400,
EVFCCL62 and EVFCACK. To set up the Transaction Program definitions, do
the following:
1. From the SNA Node Configuration window, select Configure Transaction
Programs.
2. Click New.
3. In the Define a Transaction Program window, enter:
TP Name:
EVFCCL62
Complete Pathname:
d:\ADTSWIN\SYSTEM\EVFCCL62.EXE
Program Parameters:
EVFCPCOM
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Conversation Security:
None
4. Click OK.
5. Repeat the above steps to create a definition for EVFCACK. Use the
following values:
TP Name:
EVFCACK
Complete Pathname:
d:\ADTSWIN\SYSTEM\EVFCACK.EXE
Program Parameters:
EVFCAKPC
Conversation Security:
None
Configuring Client Access
Follow instructions for VisualAge RPG but insert the following step after
″Configure the NetSoft Router for use with your AS/400 server″ in
“Configuring Client Access” on page 22.
Set up transaction profiles using the NetSoft Administrator:
1. Click Start > Program > NS Router > NS Administrator.
2. Highlight New NS/Router. Right-click Rename, and enter your AS/400
name.
3. Right-click Properties. Configure the local transaction profiles (TPs) by
clicking Common > Advanced Properties > Local TP’s > Add. Enter the
following information:
Profile Name:
EVFCCL62
TP Name:
EVFCCL62
TP FileSpec:
d:\ADTSWIN\SYSTEM\EVFCCL62.EXE (full filespec for evfccl62.exe
including the drive where CODE/400 is installed on your
workstation)
TP Parameters:
(leave this blank)
Conversation Security:
(leave unchecked)
Click OK.
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4. Repeat step 3 for the transaction profile called EVFCACK, whose TP
FileSpec is d:\ADTSWIN\SYSTEM\EVFCACK.EXE
5. Click OK again.
Continue with ″Check the connection″.
Configuring RUMBA
Install and configure RUMBA according to the instructions provided with that
product.
There are two transaction programs which must be configured for CODE/400,
EVFCCL62 and EVFCACK. To set up the Transaction Program definitions, do
the following:
1. On the RUMBA APPC Configuration window, select Programs.
2. Click Add.
3. In the Configure Transaction Programs window, enter:
Full Name:
EVFCCL62
Executable File:
d:\ADTSWIN\SYSTEM\EVFCCL62.EXE
Command Line:
EVFCRMBA
4. Click OK.
5. Repeat the above steps to create a definition for EVFCACK. Use the
following values:
Full Name:
EVFCACK
Executable File:
d:\ADTSWIN\SYSTEM\EVFCACK.EXE
Command Line:
EVFCAKRU
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Additional Information for CODE/400 Users
Configuring Communications Between AS/400 Host Sessions and the
Workstation
Communication between a VisualAge RPG and CODE/400 workstation and
an AS/400 host system is based on SNA LU 6.2, supporting multiple
asynchronous communications links between a workstation requester and a
host server.
On the host side, to establish these links you must create a customized ICF
file for each AS/400 host you will use VisualAge RPG and CODE/400 with.
The file must reside in a library which appears in your library list. Follow the
instructions in “Creating a Customized Intersystem Communications Function
(ICF) File”.
On the workstation side, all necessary transaction profiles are created for you
when you install VisualAge RPG and CODE/400. A transaction profile is a
program that defines how communications should be handled between two
systems.
In addition to the communications outlined in this chapter, the debugger
requires a standard TCP/IP configuration for its communication. Use the
steps outlined in the Windows help to setup your network connection for
TCP/IP.
Creating a Customized Intersystem Communications Function (ICF) File
An ICF file is shipped with VisualAge RPG and CODE/400. Copy this file to
your personal library, and ensure that this library is in your library list. Each
user must have a personal copy of the file. To copy and customize it for your
use, do the following:
1. Use your communications program to establish a host session and log on.
2. On the AS/400 command line, type:
CRTDUPOBJ

and press F4 (Prompt). The Create Duplicate Object (CRTDUPOBJ) display
appears.
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3. Enter values on this display as follows:
Create Duplicate Object (CRTDUPOBJ)
Type choices, press Enter.
From object . . . > EVFCICFF00
Name, generic*, *AL
From library . . . > QCODE
Name, *CURLIB
Object type . . .> *FILE
*ALL, *ALRTBL, *AUT
+ for more values
To library . . . . > MYLIB
Name, *SAME, *FRO IB...
New object . . . . > EVFCICFF
Name, *SAME, *OBJ
F3=Exit F4=Prompt
F24=More keys

F5=Refresh

F12=Cancel

Bottom
F13=How to use this display

Figure 1. Example: Create Duplicate Object display, with values entered

4. Specify *YES for the Duplicate data field.
5. Press Enter. You are returned to the AS/400 Main Menu, which now
displays a message that this file has been created.
The ICF file required for VisualAge RPG and CODE/400 is now copied to
your personal library. Your personal library must be in your library list for the
ICF information to take effect.
SNA Startup Notes
The following sections deal with special notes about running your
communications when working with CODE/400.
ICF Device Entry: If your workstation and the AS/400 host do not have the
same network identifier (in other words, if they are not part of the same
network), you must customize your ICF device entry.
If you are not sure whether your workstation and the AS/400 host are part of
the same network, try specifying your remote location name the first time you
start CODE (STRCODE). If VisualAge RPG and CODE/400 cannot establish a
connection, you probably need to change the device entry for your ICF file.
For instructions on how to create an ICF file, refer to “Creating a Customized
Intersystem Communications Function (ICF) File” on page 26.
For instructions on how to either customize or change your ICF device entry,
see “Appendix B. Changing an Intersystem Communications Function (ICF)
Device Entry” on page 43.
Starting a Single VisualAge RPG and CODE/400 Server: For the first
execution of the STRCODE command, you must specify your LU name for the
parameter RMTLOCNAME.
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You can also use the same ICF file for a different workstation by specifying a
different RMTLOCNAME on the STRCODE command. The RMTLOCNAME
specified is remembered from one STRCODE execution to the next (that is, a
CHGICFDEVE is done for you automatically when you specify a value for the
RMTLOCNAME parameter).
Note: You cannot use the same ICF file to start two servers with different
RMTLOCNAMEs at the same time.
Depending on how much resource is available on your workstation,
you can use up to twenty servers linked to one or more host systems at
any one time.

|
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Chapter 5. Preparing Your Programs for Use with
CODE/400
The CODE/400 host compilers use events files to store compile messages. If
an events file is not created, these messages cannot be returned to the
workstation. There are several methods you can use to ensure that an events
file is created when you compile a program:
v If an events file is needed for the present compilation, add the following to
the appropriate Create Program command:
OPTIONS(*EVENTF)

v For Original Program Model (OPM), add either:
OPTION(*SRCDBG) or OPTIONS(*LSTDBG)

Note: All of the predefined compile actions in CODE/400 already have the
appropriate option specified.
If you are using the Application Development Manager/400 BLDPART
command to compile programs, you will need to do one of the following:
v If events files are always desired, put the required parameter in QDFT
BLDOPT in the root group.
v If events files are only desired at a certain group level, put the required
parameter in QDFT BLDOPT at that level.
v Specify the option as a BLDOPT part with the same part name as the
program part to be compiled.
The BLDOPT part template has a special CODE/400 section. To use the
options contained in that section, uncomment the lines containing the
appropriate command. For more information on BLDOPT parts, see
ADTS/400: Application Development Manager User’s Guide.
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Chapter 6. Starting VisualAge RPG and CODE/400
To introduce yourself to the product, click Start > Programs > VisualAge
RPG and CODE400 > VARPG and CODE400 Information > Getting Started
with CODE400 and VisualAge RPG.
Alternatively, you can use an HTML-based tutorial, which is available for
download on our Web site:
http://www.ibm.com/software/ad/varpg/download/#interactive. This
interactive tutorial records your progress so you can easily return to the last
exercise you completed. Quizzes at the end of each lesson help test your
understanding of the unit.
Note: To use the tutorial, you will require a browser that can handle frames,
Java, and Javascript. You also need a file extraction tool, like WinZip,
that can handle long file names.
To start VisualAge RPG and CODE/400, click Start > Programs > VisualAge
RPG and CODE400. Choose either VisualAge for RPG or CODE400 Tools.
Finally select the component you want.
For VisualAge RPG, the primary component is the GUI designer. For
CODE/400 the primary component is the CODE Editor.

Starting Communications
|
|
|

When using the STRCODE command and TCP/IP, you must start the CODE
Daemon (also referred to as TCP/IP Communication Server) on the
workstation.
To start the CODE Daemon, click Start > Programs > VisualAge RPG and
CODE400 > TCPIP Communication Server.
Note: This daemon runs on port 4200 by default. If you have other TCP/IP
processes which require that port, you can specify a different port by
starting the daemon from the command line. For example:
x:\ADTSWIN\SYSTEM\EVFCTCPD /P=4800

Other command line options are listed in “Appendix A. CODE Daemon
Reference” on page 41.
|
|

Before you begin using the STRCODE command, make sure your current
library points to a user library (not a system library such as QTEMP or QGPL)
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where the object *USRSPC can be created. This object stores your settings and
PC location for the STRCODE connection. In the future, CODE will retrieve
your settings from the library you defined.

|
|
|

To establish a CODE/400 host server for the first time, type STRCODE at an
AS/400 command line and press F4. The Start CODE (STRCODE) display
appears:
Start CODE (STRCODE)
Type choices, press Enter.
Host server name . . . . .
Remote location name . . .
Communications type . . .

OS400
Character value
myibmpc______________________
*TCPIP
*PRV, *APPC, *TCPIP

F3=Exit F4=Prompt F5=Refresh
F13=How to use this display

F10=Additional parameters
F24=More keys

Bottom
F12=Cancel

Figure 2. Start CODE (STRCODE)

For the first execution of the STRCODE command, you must specify your
host server, remote location name, and communications type.
Enter the name of your host server (the default is OS400).
Notes:
1. Any name (with the following exceptions) can be specified for the host
server.
2. The following server names are reserved, and should not be used:
v LOCAL
v REMOTE
3. The name of the server should not start with a digit (0-9).
You must also specify your remote location name. This is the name of your
remote workstation’s Logical Unit (LU) or PC local name specified in the SNA
base profile of your communications program. In this example it is MYIBMPC.
For each subsequent execution of the STRCODE command, you can enter
STRCODE without being prompted. You should only do this if your host
server name is OS400. The STRCODE command does not save your host
server name.

|
|
|

Press Enter.
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The following screen appears:
EVFCLOGO

TESAS999
IBM CoOperative Development Environment/400
Host Server: <OS400>
(c) Copyright IBM Corp., 1992, 1998. All rights reserved.
01-01
SA
MW
KS
IM
II S1 TESAS999 KB

Figure 3. CODE Logo

This emulator session is now acting as a VisualAge RPG and CODE/400
server with the name OS400. The name of your server should appear as an
option whenever you choose to select a file.

Using STRCODE in Batch
You can also issue the STRCODE command in batch. If you decide to do this,
you should consider the following requirements:
v No interactive host commands can be issued from your programmable
workstation.

Debugger Server
To use the IBM Distributed Debugger, the debugger server on the AS/400
host must be started. You or your system administrator can start this server
using the following AS/400 command:
STRDBGSVR

Once this has been done, it need not be repeated.

Multiple Servers
The VisualAge RPG and CODE/400 product on your workstation can
communicate with more than one AS/400 server. Multiple servers allow you
to work with files on several different AS/400 host machines at the same time.
You can edit files from different servers, and even cut and paste from a file on
one server to a file on a different server.
You may also want to start several servers on the same AS/400 host. This lets
you continue working if one server is tied up waiting for input or performing
a task. This can be especially useful for debugging.
Note: You must specify a unique server name for the host you wish to
connect to.

Servers and Break Messages
While the CODE server is active, VisualAge RPG and CODE/400 changes
your job’s break message state to *HOLD, and then restores it to its original
state when the server is shutdown. This prevents break messages from
causing your session to be temporarily suspended.
Chapter 6. Starting VisualAge RPG and CODE/400
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You may want to receive break messages while you are using a CODE server
so that you can see how a job is progressing without leaving the CODE host
session. To do this, use the same user profile to sign on to more than one
session, and default your *USRPRF message queue in the first sign-on to
*BREAK. You will not be able to obtain the *USRPRF message queue for
*BREAK mode in subsequent sign-ons. Start the CODE server in one of the
subsequent sign-ons so that the first sign-on will get the break messages
rather than the one with the CODE server.
Note: None of the above will prevent messages sent with the SNDBRKMSG
command from interrupting the CODE server.

Shutting Down CODE/400 Servers
If you want to shut down a server, right click the CODE daemon in the
system tray and select Work with STRCODE Servers from the popup menu.
The window that appears contains a list of all active servers. Select the one
you wish to shutdown and then click Shutdown. You can also click Start >
Programs > VisualAge RPG and CODE400 > CODE400 Tools > Work with
Servers to open the same window.
If you want to shut down all active CODE servers, right click the CODE
daemon in the system tray and select Shutdown all STRCODE Servers from
the popup menu.

Starting VisualAge RPG and CODE/400 Tools from an AS/400 Host
It is also possible to create user-defined options through the AS/400
Programming Development Manager, Application Development Manager/400,
and Application Dictionary Services/400 products. The following is an
example of a user-defined option to invoke the CODE Editor from a list of
members:
Change User-Defined Option
Type changes, press Enter.
Option . . . . . . . . .
CE
Value to change to
Command . . . . . . . . .
CALL QCODE/EVFCFDBK PARM('37' 'Y' 'OS400'
'<LOCAL> CODEEDIT "<>&L/&F(&N)"')

Figure 4. Change User-Defined Option display

User-defined options can also be created to use other commands like
CODEBRWS and CODEFSTR.
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|
|
|
|
|
|
|

Important Notes
v For SNA, in order to call the QCODE/EVFCFDBK command, the library
containing the EVFCICFF communications file must be found in the library
list of your interactive job.
v For TCP/IP, in order to call QCODE/EVFCFDBK command, the library that
contains the object STRCODE of type *USRSPC (which was created in your
current library when you issued the STRCODE command) must be found
in the library list of your interactive job.
v If you want to invoke a local command on the workstation from the
AS/400, you should have an active CODE server running on the
workstation.
v The first three parameters of the QCODE/EVFCFDBK command must be
specified. The parameters are the CCSID of the AS/400 job, to enable
acknowledgement messages (Y/N), and the server name from the
STRCODE command or the VCOM server name.
v The empty brackets (<>) shown in the example above specifies that the first
CODE active server that is found will be used. You may choose to provide
a specific server name, such as <OS400>.

Chapter 6. Starting VisualAge RPG and CODE/400
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Chapter 7. Maintaining VisualAge RPG and CODE/400
This section provides information on maintaining VisualAge RPG and
CODE/400. Tasks that you may need to perform are deleting and uninstalling
the product, adding components to the product, and applying service packs.

Deleting from the AS/400 System
There are two ways to delete VisualAge RPG and CODE/400 from the
AS/400 system.

Method 1
To delete the VisualAge RPG and CODE/400 licensed program:
1. Sign on to your AS/400 system as security officer (QSECOFR).
2. Type the Delete Licensed Program (DLTLICPGM) command:
DLTLICPGM LICPGM(5763CL2) OPTION(*ALL)

Method 2
To delete the VisualAge RPG and CODE/400 licensed program:
1. Type on an AS/400 command line:
GO LICPGM

The Work with Licensed Programs display appears.

LICPGM
Work with Licensed Programs
Select one of the following:
Manual Install
1. Install all
Licensed Programs
10. Display installed licensed programs
11. Install licensed programs
12. Delete licensed programs
13. Save licensed programs
Secondary Languages
20. Display installed secondary languages
21. Install secondary languages
22. Delete secondary languages
Selection or command
===> ______________________________________________________________
___________________________________________________________________
F3=Exit
F4=Prompt
F9=Retrieve F12=Cancel F13=Information Assistant
F16=AS/400 Main menu

Figure 5. Work with Licensed Programs display
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2. Type 12 on the command line to choose Delete licensed programs from the
menu.
3. Type 4 beside 5763CL2 components you wish to delete.
4. Confirm your selections.

Uninstalling VisualAge RPG and CODE/400 from the Workstation
To uninstall the product from the workstation, see “Uninstalling VisualAge
RPG and CODE/400 from the Workstation” on page 7.

Adding and Updating Components
To add or update selected components of an existing installation, issue the
x:\qadtswin\setup command. The installation utility will detect the existence
of the product on your system and you can choose one of the following
options:
v Delete and re-install
v Update/add component(s) to current installation
Note: Selecting to update the component will result in the installation of
the new version over the old version.
You will then be prompted to select which component(s) you want to install.

Service Packs
When you use an AS/400 system, you may get Service Packs from IBM. These
Service Packs must be applied on your AS/400 and then downloaded to your
workstation or a LAN. You can also download the Service Packs from our
Web site at http://www.ibm.com/software/ad/varpg.
A service pack can be copied to a LAN server for enterprise-wide distribution.
Alternatively, if you have access to a CD burner, you can create your own
CD-ROM to distribute the service pack to all VisualAge RPG and CODE/400
license holders.
Instructions on using the Service Pack are found below.
Note: To see the latest information about a specific service package, click Start
> Programs > VisualAge RPG and CODE400 > Service Packs >
Service README

Installing from a Managing AS/400 System
The following method should be used if you have received the VisualAge
RPG and CODE/400 Service Pack through the AS/400 PTF ordering process
(either as an individual PTF order or as part of an OS/400 PTF cumulative
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package). Once this Service Pack has been applied to the managing AS/400
system with the LODPTF and APYPTF AS/400 commands, it can be installed
on individual PCs.
Client Access is required to attach to the AS/400 file system as a drive letter.
Other communication products with the same function can be used as well.
|
|

To install, click Start > Programs > VisualAge RPG and CODE400 > Service
Packs > Start Service.
If the AS/400 file system is not pointed to the QADTSWIN folder, you must
specify QADTSWIN in the Service Pack source path.

Installing from a Local or Network Drive
The following method should be used if you received the VisualAge RPG and
CODE/400 Service Pack as a set of installation image files, not as PTFs from
an AS/400 server. This is the case if you downloaded the files from our Web
site.
|
|

To install, click Start > Programs > VisualAge RPG and CODE400 > Service
Packs > Start Service.
The Service Pack source path must point to the QADTSWIN folder to start
collecting the new Service Pack information.
Once the install setup program has completed, you can remove the install
image files from your Local or Network drive.

Silent Installation (Unattended)
Setup.iss is a configuration file used by the Service Pack Utility to support
silent installation (unattended/remote installation). To install a Service Pack in
Silent mode, type the command:
x:\adtswin\setup.exe -s -f service.ins

Where x: is the drive in which VisualAge RPG and CODE/400 is installed. A
single message indicates that Silent Installation is running. All Service Pack
parameters are now taken from the setup.iss configuration file. The following
parameter must be changed to indicate from where to install the Service Pack:
szDir=N:\ADTSWIN\SPxxx

Where xxx is the version of the service pack.
This line should point to the directory in which the Service Pack is located.
Silent Installation creates a file called SETUP.LOG that contains the line
″ResultCode = 0″ which means successful installation. Any other value means
failure and you should talk to an IBM Service Rep. for help.
Chapter 7. Maintaining VisualAge RPG and CODE/400
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Removing the Service Pack
It is strongly recommended that you close all applications and restart your PC
before removing a Service Pack to properly terminate any DLLs that are in
use.
To
1.
2.
3.

remove Service Pack from your PC:
Click Start > Settings > Control Panel.
Double-click on the Add/Remove Programs icon.
Click the Install/Uninstall tab, click on the ″VisualAge RPG and
CODE/400 Service Pack xxx″ item, and then click Add/Remove.
4. Follow the instructions on the screen.
Or you can click Start > Programs > VisualAge RPG and CODE/400 >
Service Packs > Start Service and select the Uninstall last Service Pack
option.

Copying a Service Pack
The option to copy Service Pack is designed mainly to copy a Service Pack
from an AS/400 server to a Local or Network drive. It creates a small version
of the product folder (QADTSWIN, QCODEWIN, and QVRPGWIN) with just
the files needed to install a Service Pack. The same instructions apply to how
the Source and Target locations are entered in the entry field, it should be:
I:\source_directory where source_directory is where the folder QADTSWIN
can be found.
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Appendix A. CODE Daemon Reference
The following information explains the features of the new CODE Daemon
(also referred to as TCP/IP Communication Server). The daemon is started by
issuing the command EVFCTCPD. The command has several parameters,
explained below.
Announce new connections
The daemon will display a message indicating the TCP/IP name or IP
address of the system every time a connection request is received
from an AS/400 server. If enabled, users will see this message
whenever they issue STRCODE or when they submit a batch compile
request that involves feedback.
/A (on)
/A+ (on)
/A- (off)
The default is off.

|
|

The STRCODE beep
If enabled, you will hear 3 beeps when STRCODE establishes a
connection. On Windows 95 and 98, you may hear nothing because
the default is no sound.
/B (on)
/B+ (on)
/B- (off)
The default is on.
Use TCP/IP domain name server (DNS) when reporting names
Any messages that include a reference to a host will use the TCP/IP
name instead of the IP address. For instance
″machine209.swlab.ibm.com″ instead of ″9.29.47.58″.
/N (on)
/N+ (on)
/N- (off)
The default is off.
Use a different TCP/IP port number
You can specify a value in the range from 1-65536. This value should
match whatever value is used for STRCODE on the AS/400 server.
STRCODE defaults to port 4200.
/P=4200 (default daemon value)
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/P=12345 (any value in 1-65536 range)
The daemon uses port 4200 by default.
Restrict daemon connections to a specific AS/400 system
For instance, to allow only connections from MACHINE209, specify
/S=TORAS209. Connections from any other system will result in the
daemon issuing an error message and then ending the connection.
The [system name] is the actual name of the AS/400 server, not its
TCP/IP name or IP address although the TCP/IP name may
coincidentally be the same.
/S=[system name]
There is no default.
This parameter only takes effect if it is specified.
Restrict daemon connections to a specific AS/400 userid
For instance, to allow only connections from an AS/400 user named
SMITH, specify /U=SMITH. Connections from any other userid will
result in the daemon issuing an error message and then ending the
connection. The [user id] is the AS/400 logon id or user profile name
being used to connect to the daemon.
/U=[user id]
There is no default.
This parameter only takes effect if it is specified.
General notes:
v Parameters are not case sensitive. You can specify them in either upper or
lower case.
v A dash ’-’ can be used in place of the slash ’/’ to indicate a parameter.
v To use these parameters, issue the command x:\ADTSWIN\SYSTEM\EVFCTCPD.
There are no parameters specified in the daemon shortcut; defaults are
used. You can update the shortcut by going into its properties, selecting
Shortcut, then adding any parameters to the ″target″ string.
v None of the parameters are mutually exclusive. All can be specified in any
order or combination. If you specify the same parameter more than once
(for example EVFCTCPD /N+ /N-) then the last one (/N-) will take effect.
v Extra security related parameters:
– /Y=[strcode user id] (restrict daemon connections via STRCODE
userid)
– /Z=[strcode password] (restrict daemon connections via STRCODE
password)
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Appendix B. Changing an Intersystem Communications
Function (ICF) Device Entry
This section describes how to customize an ICF device entry if your
workstation and the AS/400 host have different network identifiers. See “ICF
Device Entry” on page 27 for related information.
1. On the AS/400 command line, type:
CHGICFDEVE

2. Press F4 (Prompt). The following display appears:
Change ICF Device Entry (CHGICFDEVE)
Type choices, press Enter.
ICF communication file . .
__________ Name
Library . . . . . . . .
*LIBL
Name, *LIBL, *CURLIB
Program device . . . . . .
_________
Character value
F3=Exit F4=Prompt
F24=More keys

F5=Refresh

F12=Cancel

Bottom
F13=How to use this display

Figure 6. Change ICF Device Entry (CHGICFDEVE) display

3. Type the following values on this display:
ICF Communication file:
EVFCICFF
Library:
The name of the library in your library list where you copied the
ICF file.
Program device:
CODE
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The display is updated as follows:
Change ICF Device Entry (CHGICFDEVE)
Type choices, press Enter.
ICF communication file . . > EVFCICFF
Name
Library . . . . . . . . >
MYLIB
Name, *LIBL, *CURLI
Program device . . . . . . > CODE
Character value
Remote location . . . . .
*SAME
Name, *SAME, *REQUE
Communication type . . . .
*APPC
*ALL, *APPC, *ASYNC
F3=Exit F4=Prompt
F24=More keys

F5=Refresh

F12=Cancel

Bottom
F13=How to use this display

Figure 7. Change ICF Device Entry display, with initial values entered

4. In the Remote location field, type the remote location name that the
AS/400 system uses to refer to your workstation.
5. Press Enter. A display similar to the following appears:
Enter the following values on this display:
Change ICF Device Entry (CHGICFDEVE)
Type choices, press Enter.
ICF communication file . . > EVFCICFF
Name
Library . . . . . . . . >
MYLIB Name, *LIBL, *CURLIB
Program device . . . . . . > CODE
Character value
Remote location . . . . . > MYLUNAME
Name, *SAME, *REQUESTER
Communication type . . . .> *APPC
*ALL, *APPC, *ASYNC...
Device . . . . . . . . . .
Name, *SAME, *LOC
Local location . . . . . .
Name, *SAME, *LOC, *NETATR
Mode . . . . . . . . . . .
Name, *SAME, *NETATR
Remote network identifier.
Name, *SAME, *LOC, *NETATR...
Format select . . . . . .
*SAME, *PGM, *RECID, *RMTFMT
Conversation type . . . .
*SAME, *SYS, *USER, *SRCPGM
F3=Exit F4=Prompt
F24=More keys

F5=Refresh

F12=Cancel

Bottom
F13=How to use this display

Figure 8. Change ICF Device Entry display, with additional fields shown
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Device:

*LOC

Local location:

*NETATR

Mode:

QPCSUPP
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Remote network identifier:

The name of your workstation’s network.
You must include this value if your
workstation and the AS/400 host do not
have the same network ID.
If you need to check it, issue the following
command from an AS/400 command line.
DSPNETA

The Local network ID that appears in the
Display Network Attributes display is the
AS/400 network ID.
Format select:

*PGM

Conversation type:
*SYS
6. Press Enter. The AS/400 Main Menu appears, with a message at the
bottom:
MAIN

AS/400 Main Menu

System: SYSTEM1
Select one of the following:
1. User tasks
2. Office tasks
3. General system tasks
4. Files, libraries, and folders
5. Programming
6. Communications
7. Define or change the system
8. Problem handling
9. Display a menu
10. User support and education
11. PC Support tasks
90. Sign off
Selection or command
===>
F3=Exit
F4=Prompt
F9=Retrieve
F12=Cancel
F13=User support
F23=Set initial menu
Device changed in file EVFCICFF in library MYLIB.

Figure 9. AS/400 Main Menu, with completion message for Change ICF Device Entry
(CHGICFDEVE) command

|
|

The ICF configuration for your VisualAge RPG and CODE/400 session is
finished. The library to which the ICF File belongs should be in the library
list for CODE communications.
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Appendix C. VisualAge RPG SQL Setup
This section describes one configuration method that can be used to set up
access for SQL processing. Refer to the following publications for details on
DB2® setup and configuration:
v DB2® Universal Database™ for Windows NT Quick Beginnings, GC09-2835
v DB2® Connect™ Enterprise Edition Quick Beginnings, GC09-2828
The following products must be installed before you can set up access to an
AS/400 database:
v DB2 Universal Database with: a type of client, a SDK with a local database,
or a SDK with a server.
– Choose a client if you always access databases on other workstations or
hosts. Your own workstation cannot have its own database.
– Choose an SDK with a local database if you access databases on other
workstations, hosts, and on your own workstation.
– Choose an SDK with a server if you want the capability of the client
with local database choice and you want other clients to access databases
on your own workstations.
If you choose standalone, you cannot connect to a remote database.
v DB2 Connect
v DB2/400
OS/400 releases prior to V4R2 only support the SNA protocol. Releases V4R2
and above support both TCP/IP and SNA.
To set up access to an AS/400 database, do the following:
v Set up your DB2 Connect system.
v Set up the AS/400 server.
v Set up the DB2 server.
v Set up the DB2 Client Application Enabler.
v Test the database connection.

Setting up your DB2 Connect System for a Remote Database Server
The following environment variables should be defined on the workstation
where DB2 Connect is installed:
1. Click Start > Settings > Control Panel.
2. Double-click on the System icon.
3. Select the Environment page of System Properties.
4. Create or append these values to the following environment variables:
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DB2CODEPAGE
Code page number that matches the code page defined for the
user profile on the host.
DB2INSTANCE
DB2
DB2COMM
TCP/IP, APPC
It is easier to use TCP/IP to make the connection between the DB2 server
and the remote clients if the DB2 server is on a platform that supports
TCP/IP.
For SNA protocols, the following properties must be configured correctly
before DB2 Connect can communicate with the host:
v AS/400 Server Properties
v APPC Local LU Properties
v APPC Mode Properties
v Host Connection Properties
v APPC Remote LU Properties
v APPC Symbolic Destination Name Properties
To set up the DB2 Server to accept connection requests from DB2 Clients, refer
to DB2 Connect Enterprise Edition Quick Beginnings for step-by-step instructions
on configuring a server-to-client connection using the TCP/IP protocol.

Setting up the AS/400 Database Server
To set up the AS/400 server:
1. Sign on to the AS/400 server.
2. Issue the command CRTMODD IBMRDB.
3. Issue the command WRKRDBDIRE.
4. In the Relational Database field, type a descriptive name for the AS/400
server system, for example, DBon400.
5. In the Remote Local field, type *LOCAL.
6. Issue the command STRSQL.
7. Issue the command CREATE COLLECTION NULLID.
8. Press F12 to exit STRSQL.
9. Issue the command GRTOBJAUT NULLID/*ALL *ALL USER(your_userid).
10. Issue the following commands and include the appropriate parameters:
CRTJRNRCV, CRTJRN, and STRJRNPF.
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Setting up the DB2 Server
To update the Database Manager Configuration File for APPC:
1. Select the DB2 Command Window from the Start menu.
2. Issue the following command:
db2 update database manager configuration
using tpname 07F6C4C2

where 07F6C4C2 is the default value required by DB2.
3. Stop and then restart the database manager.
To complete the configuration, issue the following commands to catalog the
remote database for the workstation server:
1. Update the node directory:
db2 catalog appc node appcnode
remote DBon400 security program

where appcnode is a user defined name. DBon400 is the same name as the
one defined in the AS/400 server setup. Note that this name is case
sensitive.
2. Update the local system database directory:
db2 catalog database dbon400 as DBalias
at node appcnode authentication dcs

where dbon400 is the database entry in the local system database directory.
DBalias is the database alias. If the alias is not provided, the alias will be
the same name as the database name. appcnode is the node from the
previous step.
3. Update the dcs directory:
db2 catalog dcs database dbon400 as alias400

where dbon400 is the database entry in the local system database directory,
and alias400 is a user-defined alias for the target database name. If the
alias is not provided, the alias has the same name as the database name.
4. Stop and then restart the database manager.
To update the Database Manager Configuration File for TCP/IP:
1. Ensure the TCP/IP on NT has been configured correctly.
2. Define the connection port and interrupt port for the target AS/400 host.
Enter the following information to the file
\WINNT\SYSTEM32\DRIVERS\ETC\SERVICES.
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First specify the connection port number for the DB2 instance on the AS/400
server host by entering the command:
db2instlc 3700/tcp

Then specify the interrupt port number by entering the command:
db2instli 3701/tcp

Where db2instlc and db2instli are user-defined names and must be unique
to your workstation. The port numbers also must be unique and differ by 1.
To complete the configuration, issue the following commands to catalog the
remote database for the workstation server:
1. Update the node directory:
db2 CATALOG TCPIP node tcpnode remote DBon400 SERVER db2instlc SECURITY DCS

where tcpnode is a user-defined name. DBon400 is the same name as the
one defined in the AS/400 server setup. Note that the name is case
sensitive. db2instlc is the alias set up for connecting ports.
2. Update the system database directory:
db2 CATALOG DATABASE dbon400 AS DBalias AT NODE tcpnode AUTHENTICATION DCS

where dbon400 is the database entry in the system database directory.
DBalias is the database alias. If the alias is not provided, the alias will be
the same name as the database name. tcpnode is the node from the
previous step.
3. Update the dcs directory:
db2 CATALOG DCS DATABASE dbon400 AS alias400

where dbon400 is the database entry in the system database directory, and
alias400 is a user-defined alias for the target database name. If an alias is
not provided, the alias has the same name as the database name.
4. Stop and then restart the database manager.

Binding the Utilities with the Remote Database
Do the following to bind the SQL utilities files:
1. Issue:
db2 connect to dbon400 user USERID using PASSWORD

where dbon400 is the remote database name from previous step, and where
USER and PASSWORD are the signon userid and password of the user profile
on the host where the database is created.
2. Issue:
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db2 bind drive:\sqllib\bnd\@ddcs400.lst blocking all
sqlerror continue messages ddcs400a.msg grant public

where drive: is the drive where DB2 Connect was installed.
3. Stop and then restart the database manager.

Testing the Database Connection
From the command entry screen, test the database connection by issuing the
following commands:
1. db2 CONNECT TO dbon400 user USERID using PASSWORD
2. db2 SELECT * FROM table-name (any select statement)
3. db2 CONNECT RESET
If the database and the table exist, and if there is data in the database, the
records you selected are displayed.

Appendix C. VisualAge RPG SQL Setup
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|

|

Appendix D. Secure Sockets Layer (SSL) Setup

|
|
|
|
|
|
|

Secure Sockets Layer (SSL) provides secure connections by encrypting the data
exchanged between a client and an AS/400 server session and performing
server authentication. SSL can be used only with a SSL capable AS/400 server
running OS/400, Version 4 Release 4 or later. The use of SSL connection
significantly decreases performance of the product compared to the use of
connection without encryption. It is recommended that SSL be used only
when the sensitivity of data transferred merits the decrease in performance.

|
|

This section provides instructions on configuring your AS/400 server for
Secure Sockets Layer support.

|
|
|

Note: If any fixes are applied to the VARPG run time, the following
procedures must be repeated. For SSL to work properly on the AS/400
server, the QSECOFR user profile password must not be expired.

|
| SSL Considerations
v A good knowledge of SSL is required for setup. You should know how to
use the Digital Certificate Manager (DCM) program on the AS/400 server
to perform SSL related tasks, such as generating system certificates. For
information on the DCM program, invoke its online help or go to the Web
site at http://www.ibm.com/as400/infocenter.

|
|
|
|
|
|
|
|
|
|
|
|
|
|
|

v Ensure that you adhere to import and export regulations. IBM AS/400
Client Encryption products provide SSL version 3.0 encryption support
using non-exportable 128-bit for U.S. and Canada use only and exportable
40-bit for international use. In customer configurations where Client
Encryption products might be downloaded across national boundaries, the
customer is responsible for ensuring that the non exportable products are
not made available outside the U.S. and Canada. Both the non-exportable
and exportable Client Encryption products can be used in combination to
allow the appropriate Client Encryption product to be downloaded on
different Web sites.

|
| Prerequisites
|
|
|
|

The following prerequisites must be met before setting up SSL:
v Software:
– Crytographic Access Provider licensed program (5769-AC1, 5769-AC2, or
5769-AC3)

© Copyright IBM Corp. 1994, 2000
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|
|
|

– Client Encryption licenses program (5769-CE1, 5769-CE2, or 5769-CE3)
where CE1 is for use in France, CE2 is for use in countries other than the
US, Canada, or France, and CE3 is for use only in the US and Canada.

|
|
|
|
|
|
|
|
|
|

v Hardware:
– IBM HTTP Server (5769-DG1)
– Base operating system option 34 Digital Certificate Manager (DCM)
v Authorization:
Provide proper authorizations for users to access the SSL files. Follow these
steps to change the authority:
1. Enter the command:
wrklnk '/QIBM/ProdData/HTTP/Public/jt400/*

2. Choose option 9 in the correct directory (SSL40, SSL56, or SSL128).
3. Give users *RX authority to the directory.
Note: Individual users or groups of users can be authorized.

|

|
| SSL Setup for the AS/400 Server
|

Follow the instructions below to setup your AS/400 server for SSL:

|
|
|
|
|
|

Start DCM:
1. Start the HTTP servers by using the command:

|
|
|
|

The proper security officer authority, plus *secadm and *allobj authorities
are needed.
3. Enter your AS/400 user ID and password.
4. From the AS/400 Tasks page, access DCM by selecting the DCM link.

|
|

Obtain a system certificate for your AS/400 server from the Digital Certificate
Manager program:

|
|
|

Click on the ? icon for instructions on obtaining a system certificate. You can
either obtain the system certificate from a trusted Certificate Authority (CA)
or build your own.
v To obtain a system certificate from a trusted CA:

STRTCPSVR SERVER(*HTTP) HTTPSVR (*ADMIN)

2. Access the AS/400 Administration server by typing in your server’s URL
address and port number. For example:
http://your.server.name:2001/

|

Note: This is what you should use if your application is an internet
application and you need to distribute your run time.

|
|
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|
|
|
|

Select a CA. You can get a certificate from one of the following companies:
– VeriSign, Inc.
– Integration Financial Network
– Thawte Consulting

|

– RSA Data Security

|
|

Obtain request data for submission to the trusted CA:
1. Click System Certificates.

|
|

2. Select Work with Certificates.
3. Click Create.

|
|

4. Once you receive the request data, copy and paste it into the request
from required by your CA.

|
|
|
|

Your CA will process your request form and provide you with the
certificate. To install it onto your system, use the Receive a System
Certificate option.
v To obtain your own system certificate:

|
|

Note: This should only be used for an intranet because the run time
created can only be used for your specific AS/400 server.

|
|

1. Create your CA on the AS/400 server.
2. Generate the system certificate from your own CA.

|
|

For information on creating a CA, on the DCM page click on Certificate
Authority.

|
|
|

Apply the system certificate to your host servers:
1. If you obtained your certificate from a trusted CA, get the list of server
applications from theWork with Secure Applications option.

|
|
|
|
|
|
|
|
|

2. Apply the certificate to the following server applications:
QIBM_OS400_QZBS_SVR_CENTRAL
QIBM_OS400_QZBS_SVR_DATABASE
QIBM_OS400_QZBS_SVR_DTAQ
QIBM_OS400_QZBS_SVR_NETPRT
QIBM_OS400_QZBS_SVR_RMTCMD
QIBM_OS400_QZBS_SVR_SIGNON
QIBM_OS400_QZBS_SVR_FILE
QIBM_OS400_QRW_SVR_DDM_DRDA

|
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|
| SSL Setup for Workstation
|

To set up SSL for the workstation, follow the steps below:

|
|

Download the appropriate version of the SSL Client Encryption software to
your workstation from the AS/400 server:

||
|
|
|
|

Product

File to Download

Location for Download

5769-CE1
5769-CE2
5769-CE3

sslightx.zip
sslightx.zip
sslightu.zip

/QIBM/ProdData/HTTP/Public/jt400/SSL40
/QIBM/ProdData/HTTP/Public/jt400/SSL56
/QIBM/ProdData/HTTP/Public/jt400/SSL128

|
|
|
|
|
|
|
|
|
|
|

If you built your own certificate, perform the following steps to download the
CA certificate:

|
|

Where <systemname> is the name of your AS/400 server and <port> is
your port number.

|
|
|
|
|
|
|
|
|
|

Note: The server port can be any of the host servers to which you have
access. For example, you can use 9476, which is the default port for
the secure sign-on server on the AS/400 server. When you are
prompted to enter a password, enter toolbox. This is the only
password that works. The SSL tool then connects to the AS/400
server and lists the certificates it finds.
6. Enter the CA certificate number. Be sure to use the CA certificate and not
the site certificate. A message will be issued stating that the certificate is
being added to com.ibm.as400.access.KeyRing.class.

|

A KeyRing.class file has been created in the directory.

|

Create a customized varpg.jar file by following the instructions below:
1. Create a temporary directory. For example, c:\tempjar.

1. Download SSLTools.zip from the directory in which you downloaded the
SSL Client Encryption.
2. Add SSLTools.zip and sslightu.zip to your CLASSPATH statement.
3. Create a temporary directory. For example, c:\tempkey.
4. Create the following subdirectory under c:\tempkey:
com\ibm\as400\access

5. From the tempkey directory, run the following command in one line:
java com.ibm.sslight.nlstools.keyrng com.ibm.as400.access.KeyRing
connect <systemname>:<port>

7. Delete the file SSLTools.zip.

|
|

2. Copy the file sslightu.zip to c:\tempjar.
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|
|

3. Run the following command:

|
|
|
|
|
|
|
|
|
|

You will find the meta-inf and com\ibm\sslight subdirectories created for
you in c:\tempjar.
4. If you built your own certificate:
a. Under subdirectory c:\tempjar\com\ibm add subdirectory
\as400\access.

|
|
|
|

Note: C is in uppercase.
Running this command updates the varpg.jar file so that it can be used
with your SSL-enabled VARPG applications. This will also work for
regular, non SSL-enabled applications.

|
|
|
|

Enable your application to use SSL:
1. Rename the varpg.jar in your VARPG install directory \ADTSWIN\JAVA.
2. Compile your application with the /SSL user-defined option in the Build
options dialog.
3. Run the application with the customized file varpg.jar.

|

jar xvf sslightu.zip

b. Copy the KeyRing.class file in c:\tempkey\com\ibm\as400\access
subdirectory to the c:\tempjar\com\ibm\as400\access subdirectory.
5. Copy the varpg.jar file into c:\tempjar.
6. From c:\tempjar, run the following command:
jar uvf varpg.jar -C ./ com

Appendix D. Secure Sockets Layer (SSL) Setup
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Related Publications
v
v

AS/400 Information Center and Softcopy Library CD-ROM, SK3T-2027-03
ADTS/400: Application Development Manager User’s Guide, SC09-2133-01

© Copyright IBM Corp. 1994, 2000

59

60

Installing VisualAge RPG and CODE/400

Notices
This information was developed for products and services offered in the
U.S.A. IBM may not offer the products, services, or features discussed in this
document in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any
functionally equivalent product, program, or service that does not infringe
any IBM intellectual property right may be used instead. However, it is the
user’s responsibility to evaluate and verify the operation of any non-IBM
product, program, or service.
IBM may have patents or pending patent applications covering subject matter
in this document. The furnishing of this document does not give you any
license to these patents. You can send license inquiries, in writing, to:
Director of Licensing
Intellectual Property & Licensing
International Business Machines Corporation
North Castle Drive, MD - NC119
Armonk, New York 10504-1785
U.S.A.
The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.
This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will
be incorporated in new editions of the publication. IBM may make
improvements and/or changes in the product(s) and/or the program(s)
described in this publication at any time without notice.
Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for
this IBM product and use of those Web sites is at your own risk.
© Copyright IBM Corp. 1994, 2000
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Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:
IBM Canada Ltd.
Department 071
1150 Eglinton Avenue East
Toronto, Ontario M3C 1H7
Canada
Such information may be available, subject to appropriate terms and
conditions, including in some cases payment of a fee.
The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer
Agreement, IBM International Program License Agreement, or any equivalent
agreement between us.

Programming Interface Information
This publication is intended to help you install and configure our product.
This publication documents General-Use Programming Interface and
Associated Guidance Information provided by IBM VisualAge RPG and
Cooperative Development Environment for AS/400.

Trademarks and Service Marks
The following terms are trademarks or registered trademarks of the
International Business Machines Corporation in the United States or other
countries or both:
AFP
APPN
Application System/400
AS/400
AS/400e
C/400
CICS
CICS/400
Client Access
COBOL/400
DB2

DB2 Connect
DB2 Universal Database
IBM
IBMLink
ILE
Integrated Language Environment
Information Assistant
RPG/400
SQL/400
VisualAge

InstallShield is a registered trademark of InstallShield Corporation.
Intel and Pentium are registered trademarks of Intel Corporation.
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Java and all Java-based trademarks are trademarks or registered trademarks of
Sun Microsystems, Inc. in the United States and/or other countries.
Microsoft, Windows, and Windows NT are trademarks or registered
trademarks of Microsoft Corporation in the United States, or other countries,
or both.
Other company, product, and service names may be trademarks or service
marks of others.
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